summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD29
2 files changed, 27 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a0309384d0e..c97873f89ce7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,32 @@
-# Generated by mksrcinfo v8
-# Tue Jun 7 08:01:04 UTC 2016
pkgbase = rxvt-unicode-256xresources
pkgdesc = urxvt with patches to support 256 Xresource colors and fixes for line/font spacing
- pkgver = 9.22
- pkgrel = 2
+ pkgver = 9.31
+ pkgrel = 1
url = http://software.schmorp.de/pkg/rxvt-unicode.html
- arch = i686
arch = x86_64
license = GPL
+ makedepends = libxft
+ makedepends = perl
+ makedepends = startup-notification
+ makedepends = libnsl
+ depends = rxvt-unicode-terminfo
depends = libxft
depends = perl
depends = startup-notification
- depends = rxvt-unicode-terminfo
+ depends = libnsl
+ depends = libptytty
+ depends = libxext
optdepends = gtk2-perl: to use the urxvt-tabbed
provides = rxvt-unicode
conflicts = rxvt-unicode
- source = http://dist.schmorp.de/rxvt-unicode/rxvt-unicode-9.22.tar.bz2
+ source = http://dist.schmorp.de/rxvt-unicode/rxvt-unicode-9.31.tar.bz2
source = font-width-fix.patch
source = line-spacing-fix.patch
source = 256color.patch
source = urxvt.desktop
source = urxvtc.desktop
source = urxvt-tabbed.desktop
- sha256sums = e94628e9bcfa0adb1115d83649f898d6edb4baced44f5d5b769c2eeb8b95addd
+ sha256sums = aaa13fcbc149fe0f3f391f933279580f74a96fd312d6ed06b8ff03c2d46672e8
sha256sums = 686770fe4e8d6bb0ba497ad2e1f217d17515f2544d80abe76496c63ead2bfaa4
sha256sums = 546a388d0595404a59c71c3eaeba331031032a75f96c57e9a860f27bbd7ebfcc
sha256sums = e51a598ee616b5953c991a4135dd1acc13a62f1180a8b842297f5401df55dc69
@@ -31,4 +35,3 @@ pkgbase = rxvt-unicode-256xresources
sha256sums = ccd7c436e959bdc9ab4f15801a67c695b382565b31d8c352254362e67412afcb
pkgname = rxvt-unicode-256xresources
-
diff --git a/PKGBUILD b/PKGBUILD
index ec686d3b807e..1203f362ade4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,16 @@
-# Maintainer: Lukas Tobler <luk4s.tobler@gmail.com>
+# Maintainer: Michał Wojdyła < micwoj9292 at gmail dot com >
+# Contributor: Lukas Tobler <luk4s.tobler@gmail.com>
_pkgname=rxvt-unicode
pkgname=rxvt-unicode-256xresources
-pkgver=9.22
-pkgrel=2
+pkgver=9.31
+pkgrel=1
pkgdesc="urxvt with patches to support 256 Xresource colors and fixes for line/font spacing"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://software.schmorp.de/pkg/rxvt-unicode.html"
license=('GPL')
-depends=('libxft' 'perl' 'startup-notification' 'rxvt-unicode-terminfo')
+makedepends=('libxft' 'perl' 'startup-notification' 'libnsl')
+depends=('rxvt-unicode-terminfo' 'libxft' 'perl' 'startup-notification' 'libnsl' 'libptytty' 'libxext')
optdepends=('gtk2-perl: to use the urxvt-tabbed')
source=(http://dist.schmorp.de/rxvt-unicode/$_pkgname-$pkgver.tar.bz2
font-width-fix.patch
@@ -19,7 +21,7 @@ source=(http://dist.schmorp.de/rxvt-unicode/$_pkgname-$pkgver.tar.bz2
urxvt-tabbed.desktop)
provides=(rxvt-unicode)
conflicts=(rxvt-unicode)
-sha256sums=('e94628e9bcfa0adb1115d83649f898d6edb4baced44f5d5b769c2eeb8b95addd'
+sha256sums=('aaa13fcbc149fe0f3f391f933279580f74a96fd312d6ed06b8ff03c2d46672e8'
'686770fe4e8d6bb0ba497ad2e1f217d17515f2544d80abe76496c63ead2bfaa4'
'546a388d0595404a59c71c3eaeba331031032a75f96c57e9a860f27bbd7ebfcc'
'e51a598ee616b5953c991a4135dd1acc13a62f1180a8b842297f5401df55dc69'
@@ -33,6 +35,8 @@ build() {
patch -p0 -i ../line-spacing-fix.patch
# we disable smart-resize (FS#34807)
# do not specify --with-terminfo (FS#46424)
+ # workaround ncurses --disable-root-access (FS#79143)
+ export TIC="/usr/bin/tic -o${srcdir}/terminfo"
./configure \
--prefix=/usr \
--enable-256-color \
@@ -66,17 +70,14 @@ build() {
package() {
#install freedesktop menu
for _f in urxvt urxvtc urxvt-tabbed; do
- install -Dm644 $_f.desktop "$pkgdir/usr/share/applications/$_f.desktop"
+ install -Dm644 ${_f}.desktop "${pkgdir}/usr/share/applications/${_f}.desktop"
done
-
- cd $_pkgname-$pkgver
- #workaround terminfo installation
- export TERMINFO="$srcdir/terminfo"
- install -d "$TERMINFO"
- make DESTDIR="$pkgdir" install
+ cd ${_pkgname}-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
#install the tabbing wrapper ( requires gtk2-perl! )
sed -i 's/\"rxvt\"/"urxvt"/' doc/rxvt-tabbed
- install -Dm 755 doc/rxvt-tabbed "$pkgdir/usr/bin/urxvt-tabbed"
+ install -Dm 755 doc/rxvt-tabbed "${pkgdir}/usr/bin/urxvt-tabbed"
}