summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD41
-rw-r--r--urxvt-tabbed.desktop9
-rw-r--r--urxvt.desktop5
-rw-r--r--urxvtc.desktop5
5 files changed, 45 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 806eb0e324ee..0b3ff7492fc5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = rxvt-unicode-256xresources
- pkgdesc = urxvt with support for 256 Xresource colors and patches for line/font spacing
+ pkgdesc = urxvt with patches to support 256 Xresource colors and fixes for line/font spacing
pkgver = 9.21
- pkgrel = 1
+ pkgrel = 2
url = http://software.schmorp.de/pkg/rxvt-unicode.html
arch = i686
arch = x86_64
- arch = armv6h
- arch = armv7h
license = GPL
- depends = gcc-libs
depends = libxft
- depends = gdk-pixbuf2
- optdepends = perl: lots of utilities
+ depends = perl
+ depends = startup-notification
+ depends = rxvt-unicode-terminfo
optdepends = gtk2-perl: to use the urxvt-tabbed
provides = rxvt-unicode
conflicts = rxvt-unicode
@@ -21,12 +19,14 @@ pkgbase = rxvt-unicode-256xresources
source = 256color.patch
source = urxvt.desktop
source = urxvtc.desktop
+ source = urxvt-tabbed.desktop
md5sums = a9a06c608258c5fd247c3725d8f44582
md5sums = df0c3a8b6bb0578d1b91e4081c47881c
md5sums = d4e03127a0d3bbf2e173850770651b08
md5sums = fb78c2ecf87626962734320cc2bb7ab1
- md5sums = 88d8786d74b819450adf722180db09fd
- md5sums = bebf5b6b399b74b557fcedbdb47cc387
+ md5sums = fec94dc986fa37ec380079d81de3e0b2
+ md5sums = fac55f0a8404c86dad3e702146762332
+ md5sums = 8a5599197568c63720e282b9722a7990
pkgname = rxvt-unicode-256xresources
diff --git a/PKGBUILD b/PKGBUILD
index f510523d22e5..5848c976963a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,32 @@
# Maintainer: Lukas Tobler <luk4s.tobler@gmail.com>
-pkgname=rxvt-unicode-256xresources
+
_pkgname=rxvt-unicode
+pkgname=rxvt-unicode-256xresources
pkgver=9.21
-pkgrel=1
-pkgdesc="urxvt with support for 256 Xresource colors and patches for line/font spacing"
-arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+pkgrel=2
+pkgdesc="urxvt with patches to support 256 Xresource colors and fixes for line/font spacing"
+arch=('i686' 'x86_64')
url="http://software.schmorp.de/pkg/rxvt-unicode.html"
license=('GPL')
-depends=('gcc-libs' 'libxft' 'gdk-pixbuf2')
-optdepends=('perl: lots of utilities' 'gtk2-perl: to use the urxvt-tabbed')
+depends=('libxft' 'perl' 'startup-notification' 'rxvt-unicode-terminfo')
+optdepends=('gtk2-perl: to use the urxvt-tabbed')
source=(http://dist.schmorp.de/rxvt-unicode/$_pkgname-$pkgver.tar.bz2
font-width-fix.patch
line-spacing-fix.patch
256color.patch
urxvt.desktop
- urxvtc.desktop)
+ urxvtc.desktop
+ urxvt-tabbed.desktop)
provides=(rxvt-unicode)
conflicts=(rxvt-unicode)
md5sums=('a9a06c608258c5fd247c3725d8f44582'
'df0c3a8b6bb0578d1b91e4081c47881c'
'd4e03127a0d3bbf2e173850770651b08'
'fb78c2ecf87626962734320cc2bb7ab1'
- '88d8786d74b819450adf722180db09fd'
- 'bebf5b6b399b74b557fcedbdb47cc387')
+ 'fec94dc986fa37ec380079d81de3e0b2'
+ 'fac55f0a8404c86dad3e702146762332'
+ '8a5599197568c63720e282b9722a7990'
+ )
build() {
cd "$srcdir/$_pkgname-$pkgver"
patch -p0 -i ../256color.patch
@@ -60,18 +64,19 @@ build() {
}
package() {
- cd "$srcdir/$_pkgname-$pkgver"
- install -d "$pkgdir/usr/share/terminfo"
- export TERMINFO="$pkgdir/usr/share/terminfo"
+ #install freedesktop menu
+ for _f in urxvt urxvtc urxvt-tabbed; do
+ install -Dm644 $_f.desktop "$pkgdir/usr/share/applications/$_f.desktop"
+ done
+
+ cd $_pkgname-$pkgver
+
+ #workaround terminfo installation
+ export TERMINFO="$srcdir/terminfo"
+ install -d "$TERMINFO"
make DESTDIR="$pkgdir" install
#install the tabbing wrapper ( requires gtk2-perl! )
sed -i 's/\"rxvt\"/"urxvt"/' doc/rxvt-tabbed
install -Dm 755 doc/rxvt-tabbed "$pkgdir/usr/bin/urxvt-tabbed"
-
- #install freedesktop menu
- install -Dm644 ../urxvt.desktop \
- "$pkgdir/usr/share/applications/$urxvt.desktop"
- install -Dm644 ../urxvtc.desktop \
- "$pkgdir/usr/share/applications/$urxvtc.desktop"
}
diff --git a/urxvt-tabbed.desktop b/urxvt-tabbed.desktop
new file mode 100644
index 000000000000..172006b4ac12
--- /dev/null
+++ b/urxvt-tabbed.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Version=1.0
+Name=urxvt (tabbed)
+Comment=An unicode capable and tabbed rxvt clone
+Exec=urxvt-tabbed
+Icon=utilities-terminal
+Terminal=false
+Type=Application
+Categories=System;TerminalEmulator;
diff --git a/urxvt.desktop b/urxvt.desktop
index 0a9baf7dfcce..76229187034f 100644
--- a/urxvt.desktop
+++ b/urxvt.desktop
@@ -1,10 +1,9 @@
[Desktop Entry]
Version=1.0
-Encoding=UTF-8
Name=urxvt
Comment=An unicode capable rxvt clone
Exec=urxvt
-Icon=terminal
+Icon=utilities-terminal
Terminal=false
Type=Application
-Categories=Application;System;TerminalEmulator;
+Categories=System;TerminalEmulator;
diff --git a/urxvtc.desktop b/urxvtc.desktop
index e39a418f6522..3a2df410f7db 100644
--- a/urxvtc.desktop
+++ b/urxvtc.desktop
@@ -1,10 +1,9 @@
[Desktop Entry]
Version=1.0
-Encoding=UTF-8
Name=urxvt (client)
Comment=An unicode capable rxvt clone client for urxvtd
Exec=urxvtc
-Icon=terminal
+Icon=utilities-terminal
Terminal=false
Type=Application
-Categories=Application;System;TerminalEmulator;
+Categories=System;TerminalEmulator;