aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--add-space-to-extent_test_chars.patch32
-rw-r--r--enable-wide-glyphs.patch8
4 files changed, 44 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f51fb10f7ef..55d7367f8382 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rxvt-unicode-cvs-patched-wideglyphs
pkgdesc = Unicode enabled rxvt-clone terminal emulator (urxvt) with fixed font spacing and wide glyphs patch (cvs version)
pkgver = 20170412
- pkgrel = 5
+ pkgrel = 6
url = http://software.schmorp.de/pkg/rxvt-unicode.html
arch = i686
arch = x86_64
@@ -20,6 +20,7 @@ pkgbase = rxvt-unicode-cvs-patched-wideglyphs
source = font-width-fix.patch
source = line-spacing-fix.patch
source = sgr-mouse-mode.patch
+ source = add-space-to-extent_test_chars.patch
source = enable-wide-glyphs.patch
sha1sums = b5a4507f85ebb7bac589db2e07d9bc40106720d9
sha1sums = 62c4ffecfce6967def394dd4d418b68652372ea2
@@ -27,7 +28,8 @@ pkgbase = rxvt-unicode-cvs-patched-wideglyphs
sha1sums = 01ee8f212add79a158dcd4ed78d0ea1324bdc59b
sha1sums = b7fde1c46af45e831828738874f14b092b1e795f
sha1sums = f478acf3662aab3f5b1703a4a29bcfe055dbdd66
- sha1sums = 1b4feb5ab8b22ddc1498ac4d5d9789891e71ddc8
+ sha1sums = 69b77c0b4b4587117f3a6e240a5bd6389ed40be3
+ sha1sums = 5b37be933d9b6cc1f7e3129a69c338d232bf7808
pkgname = rxvt-unicode-cvs-patched-wideglyphs
diff --git a/PKGBUILD b/PKGBUILD
index f8bf1b92f0d1..d48a5c9c3b6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_pkgname=rxvt-unicode
pkgname=rxvt-unicode-cvs-patched-wideglyphs
pkgver=20170412
-pkgrel=5
+pkgrel=6
pkgdesc='Unicode enabled rxvt-clone terminal emulator (urxvt) with fixed font spacing and wide glyphs patch (cvs version)'
arch=('i686' 'x86_64')
url='http://software.schmorp.de/pkg/rxvt-unicode.html'
@@ -25,6 +25,7 @@ source=('urxvt.desktop'
'font-width-fix.patch'
'line-spacing-fix.patch'
'sgr-mouse-mode.patch'
+ 'add-space-to-extent_test_chars.patch'
'enable-wide-glyphs.patch')
sha1sums=('b5a4507f85ebb7bac589db2e07d9bc40106720d9'
'62c4ffecfce6967def394dd4d418b68652372ea2'
@@ -32,7 +33,8 @@ sha1sums=('b5a4507f85ebb7bac589db2e07d9bc40106720d9'
'01ee8f212add79a158dcd4ed78d0ea1324bdc59b'
'b7fde1c46af45e831828738874f14b092b1e795f'
'f478acf3662aab3f5b1703a4a29bcfe055dbdd66'
- '1b4feb5ab8b22ddc1498ac4d5d9789891e71ddc8')
+ '69b77c0b4b4587117f3a6e240a5bd6389ed40be3'
+ '5b37be933d9b6cc1f7e3129a69c338d232bf7808')
prepare() {
cd ${srcdir}
diff --git a/add-space-to-extent_test_chars.patch b/add-space-to-extent_test_chars.patch
new file mode 100644
index 000000000000..9a8b928ad5ac
--- /dev/null
+++ b/add-space-to-extent_test_chars.patch
@@ -0,0 +1,32 @@
+Add space to extent_test_chars to have FontAwesome being recognized.
+
+Fixes:
+
+ $ urxvt -fn "xft:FontAwesome"
+ urxvt: unable to calculate font width for 'FontAwesome:minspace=True', ignoring.
+ urxvt: unable to load base fontset, please specify a valid one using -fn, aborting.
+
+Posted to upstream mailinglist:
+
+http://lists.schmorp.de/pipermail/rxvt-unicode/2016q4/002308.html
+Followed up in http://lists.schmorp.de/pipermail/rxvt-unicode/2017q4/002441.html
+
+ src/rxvtfont.C | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/rxvtfont.C b/src/rxvtfont.C
+index c56921c..5932f03 100644
+--- a/src/rxvtfont.C
++++ b/src/rxvtfont.C
+@@ -155,7 +155,7 @@ static const struct rxvt_fallback_font {
+ // these characters are used to guess the font height and width
+ // pango uses a similar algorithm and doesn't trust the font either.
+ static uint16_t extent_test_chars[] = {
+- '0', '1', '8', 'a', 'd', 'x', 'm', 'y', 'g', 'W', 'X', '\'', '_',
++ ' ', '0', '1', '8', 'a', 'd', 'x', 'm', 'y', 'g', 'W', 'X', '\'', '_',
+ 0x00cd, 0x00d5, 0x0114, 0x0177, 0x0643, // ÍÕĔŷﻙ
+ 0x304c, 0x672c, // が本
+ };
+--
+2.10.0
+
diff --git a/enable-wide-glyphs.patch b/enable-wide-glyphs.patch
index 6132cd6aaa11..d7ca3376e496 100644
--- a/enable-wide-glyphs.patch
+++ b/enable-wide-glyphs.patch
@@ -63,18 +63,18 @@ index 3e3f78bd..b8b1591d 100755
# Check whether --enable-pixbuf was given.
if test "${enable_pixbuf+set}" = set; then :
enableval=$enable_pixbuf; if test x$enableval = xyes -o x$enableval = xno; then
-@@ -7734,6 +7746,11 @@ if test x$support_styles = xyes; then
+@@ -7733,6 +7745,11 @@ if test x$support_styles = xyes; then
+
$as_echo "#define ENABLE_STYLES 1" >>confdefs.h
- fi
++fi
+if test x$support_wide_glyphs = xyes; then
+
+$as_echo "#define ENABLE_WIDE_GLYPHS 1" >>confdefs.h
+
-+fi
+ fi
if test x$support_iso14755 = xyes; then
- $as_echo "#define ISO_14755 1" >>confdefs.h
diff --git a/configure.ac b/configure.ac
index 0da3b596..52ab8e4c 100644
--- a/configure.ac