summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD76
-rw-r--r--urxvt.desktop9
-rw-r--r--urxvtc.desktop9
4 files changed, 118 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..730f6356cec4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = rxvt-unicode-no-perl
+ pkgver = 9.22
+ pkgrel = 5
+ url = http://software.schmorp.de/pkg/rxvt-unicode.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = libxft
+ makedepends = startup-notification
+ provides = rxvt-unicode
+ conflicts = rxvt-unicode
+ source = http://dist.schmorp.de/rxvt-unicode/rxvt-unicode-9.22.tar.bz2
+ source = urxvt.desktop
+ source = urxvtc.desktop
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = rxvt-unicode-no-perl
+ pkgdesc = A unicode enabled rxvt-clone terminal emulator (urxvt). Perl disabled.
+ depends = rxvt-unicode-terminfo
+ depends = libxft
+ depends = startup-notification
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..266386b9ba88
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,76 @@
+# $Id$
+# Maintainer: asyncial <asyncial [at] posteo [de]
+# Contributor: Sébastien Luttringer
+# Contributor: Angel Velasquez <angvp@archlinux.org>
+# Contributor: tobias <tobias@archlinux.org>
+# Contributor: dibblethewrecker dibblethewrecker.at.jiwe.dot.org
+
+_pkgbase=rxvt-unicode
+pkgname=$_pkgbase-no-perl
+pkgbase=$pkgname
+pkgver=9.22
+pkgrel=5
+arch=('i686' 'x86_64')
+url='http://software.schmorp.de/pkg/rxvt-unicode.html'
+license=('GPL')
+makedepends=('libxft' 'startup-notification')
+provides=(rxvt-unicode)
+conflicts=(rxvt-unicode)
+source=(
+ "http://dist.schmorp.de/rxvt-unicode/$_pkgbase-$pkgver.tar.bz2"
+ 'urxvt.desktop'
+ 'urxvtc.desktop'
+)
+md5sums=( 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+build() {
+ cd $_pkgbase-$pkgver
+ # we disable smart-resize (FS#34807)
+ # do not specify --with-terminfo (FS#46424)
+ ./configure \
+ --prefix=/usr \
+ --enable-256-color \
+ --enable-combining \
+ --enable-fading \
+ --enable-font-styles \
+ --enable-iso14755 \
+ --enable-keepscrolling \
+ --enable-lastlog \
+ --enable-mousewheel \
+ --enable-next-scroll \
+ --disable-perl \
+ --enable-pointer-blank \
+ --enable-rxvt-scroll \
+ --enable-selectionscrolling \
+ --enable-slipwheeling \
+ --disable-smart-resize \
+ --enable-startup-notification \
+ --enable-transparency \
+ --enable-unicode3 \
+ --enable-utmp \
+ --enable-wtmp \
+ --enable-xft \
+ --enable-xim \
+ --enable-xterm-scroll \
+ --disable-pixbuf \
+ --disable-frills
+ make
+}
+
+package() {
+ pkgdesc='A unicode enabled rxvt-clone terminal emulator (urxvt). Perl disabled.'
+ depends=('rxvt-unicode-terminfo' 'libxft' 'startup-notification')
+
+ # install freedesktop menu
+ for _f in urxvt urxvtc; do
+ install -Dm644 $_f.desktop "$pkgdir/usr/share/applications/$_f.desktop"
+ done
+ cd $_pkgbase-$pkgver
+ # workaround terminfo installation
+ export TERMINFO="$srcdir/terminfo"
+ install -d "$TERMINFO"
+ make DESTDIR="$pkgdir" install
+}
+# vim:set ts=2 sw=2 et:
diff --git a/urxvt.desktop b/urxvt.desktop
new file mode 100644
index 000000000000..76229187034f
--- /dev/null
+++ b/urxvt.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Version=1.0
+Name=urxvt
+Comment=An unicode capable rxvt clone
+Exec=urxvt
+Icon=utilities-terminal
+Terminal=false
+Type=Application
+Categories=System;TerminalEmulator;
diff --git a/urxvtc.desktop b/urxvtc.desktop
new file mode 100644
index 000000000000..3a2df410f7db
--- /dev/null
+++ b/urxvtc.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Version=1.0
+Name=urxvt (client)
+Comment=An unicode capable rxvt clone client for urxvtd
+Exec=urxvtc
+Icon=utilities-terminal
+Terminal=false
+Type=Application
+Categories=System;TerminalEmulator;