summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5b8ea448096..f766478a4881 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat Jan 2 14:05:33 UTC 2016
+# Sat Jan 2 14:57:30 UTC 2016
pkgbase = ryzom-client
pkgdesc = Ryzom is a Free to Play MMORPG .This version is for playing on an official server
pkgver = 0.12.0.r6790
diff --git a/PKGBUILD b/PKGBUILD
index e1a8ea645dc0..29416369736e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -41,6 +41,10 @@ build() {
sed 's/nelmisc/nelmisc ${LIBXML2_LIBRARIES}/' -i \
../code/nel/src/$dir/CMakeLists.txt; done
+ # error with gcc-5.3.0
+ sed '/<climits>/a#include <limits>' -i \
+ ../code/nel/include/nel/misc/types_nl.h
+
cmake -G "Unix Makefiles" -DCMAKE_BUILD_TYPE=Release \
-DWITH_RYZOM_SERVER=OFF -DWITH_RYZOM_CLIENT=ON \
-DWITH_NEL_TOOLS=OFF -DWITH_NEL_TESTS=OFF -DWITH_PCH=OFF \
@@ -49,6 +53,7 @@ build() {
-DRYZOM_ETC_PREFIX=/etc/ryzom -DRYZOM_SHARE_PREFIX=/usr/share/ryzom \
-DRYZOM_BIN_PREFIX=/usr/bin -DRYZOM_GAMES_PREFIX=/usr/bin \
-DLUA_INCLUDE_DIR=/usr/include/lua5.2 ../code
+
make
}