summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD25
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e1f0177cd57
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = rzip
+ pkgdesc = rzip is a compression program, similar in functionality to gzip or bzip2, but able to take advantage long distance redundencies in files, which can sometimes allow rzip to produce much better compression ratios than other programs.
+ pkgver = 2.1
+ pkgrel = 1
+ url = https://rzip.samba.org/
+ arch = x86_64
+ license = GPL2
+ depends = bzip2
+ source = https://rzip.samba.org/ftp/rzip/rzip-2.1.tar.gz
+ sha256sums = 4bb96f4d58ccf16749ed3f836957ce97dbcff3e3ee5fd50266229a48f89815b7
+
+pkgname = rzip
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1d65adf6de3a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb9b44c0ef8e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Nathaniel Cook <nvcook42@gmail.com>
+pkgname=rzip
+pkgver=2.1
+pkgrel=1
+epoch=
+pkgdesc="rzip is a compression program, similar in functionality to gzip or bzip2, but able to take advantage long distance redundencies in files, which can sometimes allow rzip to produce much better compression ratios than other programs."
+arch=('x86_64')
+url="https://rzip.samba.org/"
+license=('GPL2')
+depends=('bzip2')
+source=("https://rzip.samba.org/ftp/rzip/$pkgname-$pkgver.tar.gz")
+sha256sums=('4bb96f4d58ccf16749ed3f836957ce97dbcff3e3ee5fd50266229a48f89815b7')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -D -m 755 rzip $pkgdir/usr/bin/rzip
+ install -D -m 644 rzip.1 $pkgdir/usr/share/man/man1/rzip.1
+}
+