summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
2 files changed, 10 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28cfd7d29458..6bcb8969c134 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Mar 4 19:31:49 UTC 2016
+# Fri Sep 16 22:18:43 UTC 2016
pkgbase = s-nail-git
pkgdesc = Commandline utility for sending and receiving email
- pkgver = 14.8.6_x12_g778f90c
+ pkgver = 14.9.0_pre1_x6_gfcd2892
pkgrel = 1
url = https://www.sdaoden.eu/code.html#s-nail
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 8981154ba033..740fa605b50b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Based on heirloom-mailx PKGBUILD
pkgname=s-nail-git
-pkgver=14.8.6_x12_g778f90c
+pkgver=14.9.0_pre1_x6_gfcd2892
pkgrel=1
pkgdesc="Commandline utility for sending and receiving email"
arch=('i686' 'x86_64')
@@ -21,8 +21,7 @@ pkgver() {
cd s-nail
# pacman treats "_" like a ".", so use "_x" to seperate the git tag.
# otherwise pacman may think XX.Y_git to XX.Y.Z_git is a downgrade
- gitver=$(git describe --tags | cut -c 2-)
- gitver=${gitver//-/_}; echo ${gitver/_/_x}
+ git describe --tags | cut -c 2- | tr - _ | sed 's#_\([0-9]\)#_x\1#'
}
build() {
@@ -33,12 +32,11 @@ build() {
config_target="CONFIG=DEVEL"
fi
- make PREFIX=/usr \
- SYSCONFDIR=/etc \
- SYSCONFRC=mail.rc \
- LIBEXECDIR=/usr/lib \
- MAILSPOOL=/var/spool/mail \
- WANT_AUTOCC=0 \
+ make VAL_PREFIX=/usr \
+ VAL_SYSCONFDIR=/etc \
+ VAL_SYSCONFRC=mail.rc \
+ VAL_LIBEXECDIR=/usr/lib \
+ OPT_AUTOCC=0 \
${config_target:-} \
config
@@ -49,7 +47,7 @@ build() {
package() {
cd s-nail
- make DESTDIR="${pkgdir}" chown=/usr/bin/true packager-install
+ make DESTDIR="${pkgdir}" chown=/usr/bin/true install
ln -sf s-nail "${pkgdir}"/usr/bin/mail
ln -sf s-nail "${pkgdir}"/usr/bin/mailx