summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore11
-rw-r--r--PKGBUILD37
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ee672921ee62
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = saaghar-git
+ pkgdesc = “Saaghar” (ساغر) is a Persian poetry software written by C++ under Qt framework, it uses ganjoor database as its database. It has tab feature in both its “Viewer” and its “Search” page that cause it be suitable for research goals.
+ pkgver = 303.8608a7e
+ pkgrel = 1
+ url = http://saaghar.pozh.org
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = qt5-base>=5.3.1
+ source = git://github.com/srazi/Saaghar.git
+ md5sums = SKIP
+
+pkgname = saaghar-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0045cadbfc4a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,11 @@
+*.xz
+*.zip
+*.deb
+*.tar.gz
+*.tar.gz.asc
+*.tgz
+*.bz2
+/pkg
+/src
+*.gz
+rc
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95df9511d551
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: FzerorubigD <Fzerorubigd {AT} GMail {DOT} com>
+
+pkgname='saaghar-git'
+
+_gitname=Saaghar
+#The real value will be calculated by pkgver() function
+pkgver=380.3dbbb51
+pkgrel=1
+
+pkgdesc="“Saaghar” (ساغر) is a Persian poetry software written by C++ under Qt framework, it uses "ganjoor" database as its database. It has tab feature in both its “Viewer” and its “Search” page that cause it be suitable for research goals."
+
+url="http://saaghar.pozh.org"
+
+arch=('any')
+license=('GPL3')
+
+depends=('qt5-base>=5.3.1')
+makedepends=('git')
+source=('git://github.com/srazi/Saaghar.git')
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_gitname}"
+ qmake
+ make
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ INSTALL_ROOT=${pkgdir} make install
+}