summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO30
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD28
3 files changed, 35 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 653178a70cec..41d0e927d029 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,29 @@
pkgbase = safesignidentityclient
pkgdesc = Smart card PKCS#11 provider and token manager
- pkgver = 3.5
- pkgrel = 2
- url = https://pronova.com.br/download-tokens
+ pkgver = 4.0.0.0
+ pkgrel = 1
+ url = https://safesign.gdamericadosul.com.br/download
arch = x86_64
license = custom:copyright
+ depends = gcc-libs
+ depends = glib2
+ depends = glibc
+ depends = hicolor-icon-theme
depends = pcsclite
+ depends = libsm
+ depends = libx11
+ depends = cairo
+ depends = pango
+ depends = gdk-pixbuf2
+ depends = at-spi2-core
+ depends = gtk3
+ depends = libxxf86vm
+ depends = openssl-1.1
depends = gdbm
- depends = wxgtk2
- depends = openssl-1.0
- depends = xdg-utils
- depends = libmspack
- depends = ccid
+ optdepends = ccid: Generic support for CCID devices,
optdepends = acsccid: ACS CCID PC/SC driver,
optdepends = scmccid: binary driver for the SCM Smart Card Readers
- source_x86_64 = http://www.pronova-usa.com/downloads/aet/SafeSign_3_5_Ubuntu_1604LTS_x86_x64.zip
- sha512sums_x86_64 = d56bb7f8918a9d488597389e95f032181cb9e356e245406a672fe8fc899153f664bc6ec620b0d166c2340ff2c5a7259c837e0ce762c6a615da6e253e7f461fe0
+ source_x86_64 = https://certificaat.kpn.com/files/drivers/SafeSign/SafeSign%20IC%20Standard%20Linux%204.0.0.0-AET.000%20redhat8%20x86_64.rpm
+ sha256sums_x86_64 = d78e8757afb61cc19424f2379c9cc7a7f187a096cc5ebb3445ccff3402403776
pkgname = safesignidentityclient
-
diff --git a/.gitignore b/.gitignore
index 945d2fa32ee5..e2566d230200 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,3 @@
*.pkg.tar.?z
+pkg
+src \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index bfa1480f5903..c32ed986fffd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,27 @@
# Maintainer: Denis A. AltoƩ Falqueto <denisfalqueto@gmail.com>
# Contributor: Geyslan G. Bem <geyslan@gmail.com>
pkgname=safesignidentityclient
-pkgver=3.5
-pkgrel=2
+pkgver=4.0.0.0
+pkgrel=1
pkgdesc="Smart card PKCS#11 provider and token manager"
arch=('x86_64')
-url="https://pronova.com.br/download-tokens"
+url="https://safesign.gdamericadosul.com.br/download"
license=('custom:copyright')
-depends=('pcsclite' 'gdbm' 'wxgtk2' 'openssl-1.0' 'xdg-utils' 'libmspack' 'ccid')
-optdepends=('acsccid: ACS CCID PC/SC driver',
+depends=('gcc-libs' 'glib2' 'glibc' 'hicolor-icon-theme' 'pcsclite' 'libsm' 'libx11' 'cairo' 'pango'
+ 'gdk-pixbuf2' 'at-spi2-core' 'gtk3' 'libxxf86vm' 'openssl-1.1' 'gdbm')
+optdepends=('ccid: Generic support for CCID devices',
+ 'acsccid: ACS CCID PC/SC driver',
'scmccid: binary driver for the SCM Smart Card Readers')
-source_x86_64=("http://www.pronova-usa.com/downloads/aet/SafeSign_3_5_Ubuntu_1604LTS_x86_x64.zip")
-sha512sums_x86_64=('d56bb7f8918a9d488597389e95f032181cb9e356e245406a672fe8fc899153f664bc6ec620b0d166c2340ff2c5a7259c837e0ce762c6a615da6e253e7f461fe0')
-
-prepare() {
- ar x SafeSign_IC_Standard_Linux_3.5.0.0_Ubuntu_1604LTS_x86_64.deb
- tar xvf data.tar.xz
-}
+_aet_version="AET.000_ub2004"
+source_x86_64=("https://certificaat.kpn.com/files/drivers/SafeSign/SafeSign%20IC%20Standard%20Linux%204.0.0.0-AET.000%20redhat8%20x86_64.rpm")
+sha256sums_x86_64=('d78e8757afb61cc19424f2379c9cc7a7f187a096cc5ebb3445ccff3402403776')
package() {
- cd ${pkgdir}
+ install -d ${pkgdir}/usr
+ cp -R ${srcdir}/usr/{bin,share} ${pkgdir}/usr/
- cp -R ${srcdir}/usr ${pkgdir}
+ install -d ${pkgdir}/usr/lib
+ install -m 744 ${srcdir}/usr/lib64/* ${pkgdir}/usr/lib/
install -d ${pkgdir}/usr/share/licenses/${pkgname}
install -m 644 ${srcdir}/usr/share/doc/${pkgname}/copyright ${pkgdir}/usr/share/licenses/${pkgname}/copyright