summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--sagemath-ipython7.patch141
-rw-r--r--sagemath-matplotlib-3.2.patch49
-rw-r--r--sagemath-pari-2.11.3.patch26
5 files changed, 181 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef712698b15d..cdc09103a15e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sagemath-git
pkgdesc = Open Source Mathematics Software, free alternative to Magma, Maple, Mathematica, and Matlab
- pkgver = 9.1.beta6.r0.gcdb4c0b073
+ pkgver = 9.1.beta7.r0.g6db1a26f5e
pkgrel = 1
url = http://www.sagemath.org
arch = x86_64
@@ -113,12 +113,12 @@ pkgbase = sagemath-git
sha256sums = 937074fa7a8a4e2aba9ea77ec622fe937985a1a9176c48460d51325ee877a4f5
sha256sums = ab7f6db1245add08447a95c6bbdda84dbab49b043d01c2f288460bc10515c8fd
sha256sums = e44bbde87f3312548faad75b7383ef21fade55be251ab5804de41cd3842ca8a0
- sha256sums = e0b970a5914b8221c33f2018f5da2e5a3661f1b45068bc7635517135155275fd
+ sha256sums = 4e8395aba68a0650ef56b6cdb5137662780adf0cfe6049900faeaa70f6460002
sha256sums = f812e32718eab0292d726bed386217524dcdae3d4078ce82c66c20d00b9806f7
sha256sums = 5e6d1aa34959bd4369bd08a80648a5c7bc2d38e72c97e9a5f986e91f8a7aca07
sha256sums = d75f551fd942963b0158f5b25cefbecb213c37549375dd2e0f88e1856555fa1e
- sha256sums = f7f3f914437f714427748f1fda1355e7f32ad98b76b89c54855efadd6e731c7a
- sha256sums = 3f73cb49cb17865c2e50ddab0d43a21c5450190bb193c62d19cb86a6a99dacbc
+ sha256sums = 979777363001cca87f73128dd4db5f372fc9e4f1079805a20af01df47797468f
+ sha256sums = e9c450a30c3f76b05808ece2f40b86f5222cd39563fe7d901712937df28eb4ee
pkgname = sagemath-git
optdepends = cython: to compile cython code
diff --git a/PKGBUILD b/PKGBUILD
index 1620910e950a..b9e38705fb32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgbase=sagemath-git
pkgname=(sagemath-git sagemath-jupyter-git)
-pkgver=9.1.beta6.r0.gcdb4c0b073
+pkgver=9.1.beta7.r0.g6db1a26f5e
pkgrel=1
pkgdesc="Open Source Mathematics Software, free alternative to Magma, Maple, Mathematica, and Matlab"
arch=(x86_64)
@@ -54,12 +54,12 @@ sha256sums=('SKIP'
'937074fa7a8a4e2aba9ea77ec622fe937985a1a9176c48460d51325ee877a4f5'
'ab7f6db1245add08447a95c6bbdda84dbab49b043d01c2f288460bc10515c8fd'
'e44bbde87f3312548faad75b7383ef21fade55be251ab5804de41cd3842ca8a0'
- 'e0b970a5914b8221c33f2018f5da2e5a3661f1b45068bc7635517135155275fd'
+ '4e8395aba68a0650ef56b6cdb5137662780adf0cfe6049900faeaa70f6460002'
'f812e32718eab0292d726bed386217524dcdae3d4078ce82c66c20d00b9806f7'
'5e6d1aa34959bd4369bd08a80648a5c7bc2d38e72c97e9a5f986e91f8a7aca07'
'd75f551fd942963b0158f5b25cefbecb213c37549375dd2e0f88e1856555fa1e'
- 'f7f3f914437f714427748f1fda1355e7f32ad98b76b89c54855efadd6e731c7a'
- '3f73cb49cb17865c2e50ddab0d43a21c5450190bb193c62d19cb86a6a99dacbc')
+ '979777363001cca87f73128dd4db5f372fc9e4f1079805a20af01df47797468f'
+ 'e9c450a30c3f76b05808ece2f40b86f5222cd39563fe7d901712937df28eb4ee')
pkgver() {
cd sage
diff --git a/sagemath-ipython7.patch b/sagemath-ipython7.patch
index 4666b7571678..3a9f7b270f42 100644
--- a/sagemath-ipython7.patch
+++ b/sagemath-ipython7.patch
@@ -286,7 +286,7 @@ diff --git a/src/sage/coding/linear_code.py b/src/sage/coding/linear_code.py
index 57ef7fb896..db347b9e2f 100644
--- a/src/sage/coding/linear_code.py
+++ b/src/sage/coding/linear_code.py
-@@ -3840,22 +3840,22 @@ class LinearCodeSyndromeDecoder(Decoder):
+@@ -2677,22 +2677,22 @@ class LinearCodeSyndromeDecoder(Decoder):
sage: D = codes.decoders.LinearCodeSyndromeDecoder(C, maximum_error_weight = 1)
sage: D._build_lookup_table()
{(0, 0, 0, 0): (0, 0, 0, 0, 0, 0, 0, 0),
@@ -321,7 +321,7 @@ index 57ef7fb896..db347b9e2f 100644
TESTS:
-@@ -3869,11 +3869,11 @@ class LinearCodeSyndromeDecoder(Decoder):
+@@ -2706,11 +2706,11 @@ class LinearCodeSyndromeDecoder(Decoder):
sage: D = codes.decoders.LinearCodeSyndromeDecoder(C)
sage: D.syndrome_table()
{(0, 0): (0, 0, 0),
@@ -1897,7 +1897,7 @@ index 4281de7bf0..8bc045a34b 100644
sage: LatticePolytope_PPL((0,0), (4,0), (0,4)).embed_in_reflexive_polytope()
Traceback (most recent call last):
diff --git a/src/sage/geometry/triangulation/element.py b/src/sage/geometry/triangulation/element.py
-index a80d9111e4..5930fd9396 100644
+index 6f8222d07c..5930fd9396 100644
--- a/src/sage/geometry/triangulation/element.py
+++ b/src/sage/geometry/triangulation/element.py
@@ -605,32 +605,32 @@ class Triangulation(Element):
@@ -1917,39 +1917,112 @@ index a80d9111e4..5930fd9396 100644
sage: triangulation = polytopes.cube().triangulate(engine='internal')
sage: triangulation._boundary_simplex_dictionary()
- {(0, 1, 2): ((0, 1, 2, 7),),
-- (0, 1, 4): ((0, 1, 4, 7),),
-- (0, 1, 7): ((0, 1, 2, 7), (0, 1, 4, 7)),
-- (0, 2, 4): ((0, 2, 4, 7),),
+- (0, 1, 5): ((0, 1, 5, 7),),
+- (0, 1, 7): ((0, 1, 2, 7), (0, 1, 5, 7)),
+- (0, 2, 3): ((0, 2, 3, 7),),
+- (0, 2, 7): ((0, 1, 2, 7), (0, 2, 3, 7)),
+- (0, 3, 4): ((0, 3, 4, 7),),
+- (0, 3, 7): ((0, 2, 3, 7), (0, 3, 4, 7)),
+- (0, 4, 5): ((0, 4, 5, 7),),
+- (0, 4, 7): ((0, 3, 4, 7), (0, 4, 5, 7)),
+- (0, 5, 7): ((0, 1, 5, 7), (0, 4, 5, 7)),
+- (1, 2, 7): ((0, 1, 2, 7),),
+- (1, 5, 6): ((1, 5, 6, 7),),
+- (1, 5, 7): ((0, 1, 5, 7), (1, 5, 6, 7)),
+- (1, 6, 7): ((1, 5, 6, 7),),
+- (2, 3, 7): ((0, 2, 3, 7),),
+- (3, 4, 7): ((0, 3, 4, 7),),
+- (4, 5, 7): ((0, 4, 5, 7),),
+- (5, 6, 7): ((1, 5, 6, 7),)}
+ {(1, 2, 7): ((0, 1, 2, 7), (1, 2, 3, 7)),
- (0, 2, 7): ((0, 1, 2, 7), (0, 2, 4, 7)),
++ (0, 2, 7): ((0, 1, 2, 7), (0, 2, 4, 7)),
+ (0, 1, 7): ((0, 1, 2, 7), (0, 1, 4, 7)),
+ (0, 1, 2): ((0, 1, 2, 7),),
+ (1, 4, 7): ((0, 1, 4, 7), (1, 4, 5, 7)),
- (0, 4, 7): ((0, 1, 4, 7), (0, 2, 4, 7)),
-- (1, 2, 3): ((1, 2, 3, 7),),
-- (1, 2, 7): ((0, 1, 2, 7), (1, 2, 3, 7)),
++ (0, 4, 7): ((0, 1, 4, 7), (0, 2, 4, 7)),
+ (0, 1, 4): ((0, 1, 4, 7),),
+ (2, 4, 7): ((0, 2, 4, 7), (2, 4, 6, 7)),
+ (0, 2, 4): ((0, 2, 4, 7),),
+ (2, 3, 7): ((1, 2, 3, 7),),
- (1, 3, 7): ((1, 2, 3, 7),),
-- (1, 4, 5): ((1, 4, 5, 7),),
-- (1, 4, 7): ((0, 1, 4, 7), (1, 4, 5, 7)),
++ (1, 3, 7): ((1, 2, 3, 7),),
+ (1, 2, 3): ((1, 2, 3, 7),),
+ (4, 5, 7): ((1, 4, 5, 7),),
- (1, 5, 7): ((1, 4, 5, 7),),
-- (2, 3, 7): ((1, 2, 3, 7),),
-- (2, 4, 6): ((2, 4, 6, 7),),
-- (2, 4, 7): ((0, 2, 4, 7), (2, 4, 6, 7)),
++ (1, 5, 7): ((1, 4, 5, 7),),
+ (1, 4, 5): ((1, 4, 5, 7),),
+ (4, 6, 7): ((2, 4, 6, 7),),
- (2, 6, 7): ((2, 4, 6, 7),),
-- (4, 5, 7): ((1, 4, 5, 7),),
-- (4, 6, 7): ((2, 4, 6, 7),)}
++ (2, 6, 7): ((2, 4, 6, 7),),
+ (2, 4, 6): ((2, 4, 6, 7),)}
"""
result = dict()
for simplex in self:
+@@ -655,22 +655,22 @@ class Triangulation(Element):
+
+ sage: triangulation = polytopes.cube().triangulate(engine='internal')
+ sage: triangulation
+- (<0,1,2,7>, <0,1,5,7>, <0,2,3,7>, <0,3,4,7>, <0,4,5,7>, <1,5,6,7>)
++ (<0,1,2,7>, <0,1,4,7>, <0,2,4,7>, <1,2,3,7>, <1,4,5,7>, <2,4,6,7>)
+ sage: triangulation.boundary()
+ frozenset({(0, 1, 2),
+- (0, 1, 5),
+- (0, 2, 3),
+- (0, 3, 4),
+- (0, 4, 5),
+- (1, 2, 7),
+- (1, 5, 6),
+- (1, 6, 7),
++ (0, 1, 4),
++ (0, 2, 4),
++ (1, 2, 3),
++ (1, 3, 7),
++ (1, 4, 5),
++ (1, 5, 7),
+ (2, 3, 7),
+- (3, 4, 7),
++ (2, 4, 6),
++ (2, 6, 7),
+ (4, 5, 7),
+- (5, 6, 7)})
++ (4, 6, 7)})
+ sage: triangulation.interior_facets()
+- frozenset({(0, 1, 7), (0, 2, 7), (0, 3, 7), (0, 4, 7), (0, 5, 7), (1, 5, 7)})
++ frozenset({(0, 1, 7), (0, 2, 7), (0, 4, 7), (1, 2, 7), (1, 4, 7), (2, 4, 7)})
+ """
+ return frozenset(facet for facet, bounded_simplices
+ in iteritems(self._boundary_simplex_dictionary())
+@@ -691,22 +691,22 @@ class Triangulation(Element):
+
+ sage: triangulation = polytopes.cube().triangulate(engine='internal')
+ sage: triangulation
+- (<0,1,2,7>, <0,1,5,7>, <0,2,3,7>, <0,3,4,7>, <0,4,5,7>, <1,5,6,7>)
++ (<0,1,2,7>, <0,1,4,7>, <0,2,4,7>, <1,2,3,7>, <1,4,5,7>, <2,4,6,7>)
+ sage: triangulation.boundary()
+ frozenset({(0, 1, 2),
+- (0, 1, 5),
+- (0, 2, 3),
+- (0, 3, 4),
+- (0, 4, 5),
+- (1, 2, 7),
+- (1, 5, 6),
+- (1, 6, 7),
++ (0, 1, 4),
++ (0, 2, 4),
++ (1, 2, 3),
++ (1, 3, 7),
++ (1, 4, 5),
++ (1, 5, 7),
+ (2, 3, 7),
+- (3, 4, 7),
++ (2, 4, 6),
++ (2, 6, 7),
+ (4, 5, 7),
+- (5, 6, 7)})
++ (4, 6, 7)})
+ sage: triangulation.interior_facets()
+- frozenset({(0, 1, 7), (0, 2, 7), (0, 3, 7), (0, 4, 7), (0, 5, 7), (1, 5, 7)})
++ frozenset({(0, 1, 7), (0, 2, 7), (0, 4, 7), (1, 2, 7), (1, 4, 7), (2, 4, 7)})
+ """
+ return frozenset(facet for facet, bounded_simplices
+ in iteritems(self._boundary_simplex_dictionary())
diff --git a/src/sage/graphs/base/boost_graph.pyx b/src/sage/graphs/base/boost_graph.pyx
index 6ba0a44c9a..c50374c542 100644
--- a/src/sage/graphs/base/boost_graph.pyx
@@ -2161,7 +2234,7 @@ index 8b8c98cb15..6823e13b26 100644
Weighted case::
-@@ -18864,18 +18864,18 @@ class GenericGraph(GenericGraph_pyx):
+@@ -18906,18 +18906,18 @@ class GenericGraph(GenericGraph_pyx):
'#00ff00': [((1,3,2,4), (1,4)(2,3), 3), ...],
'#ff0000': [((1,3,2,4), (1,3)(2,4), 1), ...]}
sage: G._color_by_label() # py3
@@ -2186,7 +2259,7 @@ index 8b8c98cb15..6823e13b26 100644
TESTS:
-@@ -19020,8 +19020,8 @@ class GenericGraph(GenericGraph_pyx):
+@@ -19062,8 +19062,8 @@ class GenericGraph(GenericGraph_pyx):
sage: g.layout(layout="acyclic_dummy", save_pos=True)
{('0', 0): [0.3..., 0],
@@ -2196,7 +2269,7 @@ index 8b8c98cb15..6823e13b26 100644
('1', 1): [0.6..., 1]}
sage: D3 = g.layout(dim=3); D3 # random
-@@ -19157,10 +19157,10 @@ class GenericGraph(GenericGraph_pyx):
+@@ -19199,10 +19199,10 @@ class GenericGraph(GenericGraph_pyx):
sage: g = graphs.LadderGraph(3)
sage: g.layout_ranked(heights={i: (i, i+3) for i in range(3)})
{0: [0.668..., 0],
@@ -2209,7 +2282,7 @@ index 8b8c98cb15..6823e13b26 100644
5: [1.33..., 2]}
sage: g = graphs.LadderGraph(7)
sage: g.plot(layout="ranked", heights={i: (i, i+7) for i in range(7)})
-@@ -19344,13 +19344,13 @@ class GenericGraph(GenericGraph_pyx):
+@@ -19386,13 +19386,13 @@ class GenericGraph(GenericGraph_pyx):
sage: G = graphs.BalancedTree(2, 2)
sage: G.layout_tree(tree_root=0)
@@ -2228,7 +2301,7 @@ index 8b8c98cb15..6823e13b26 100644
sage: G = graphs.BalancedTree(2, 4)
sage: G.plot(layout="tree", tree_root=0, tree_orientation="up")
-@@ -19362,15 +19362,15 @@ class GenericGraph(GenericGraph_pyx):
+@@ -19404,15 +19404,15 @@ class GenericGraph(GenericGraph_pyx):
sage: T.set_embedding({0: [1, 6, 3], 1: [2, 5, 0], 2: [1], 3: [4, 7, 8, 0],
....: 4: [3], 5: [1], 6: [0], 7: [3], 8: [3]})
sage: T.layout_tree()
@@ -2251,7 +2324,7 @@ index 8b8c98cb15..6823e13b26 100644
sage: T.plot(layout="tree", tree_root=3)
Graphics object consisting of 18 graphics primitives
-@@ -23529,7 +23529,8 @@ class GenericGraph(GenericGraph_pyx):
+@@ -23571,7 +23571,8 @@ class GenericGraph(GenericGraph_pyx):
sage: G = DiGraph({1: [10], 2:[10,11], 3:[10,11], 4:[], 5:[11, 4], 6:[11], 7:[10,11], 8:[10,11], 9:[10], 10:[11, 5, 8], 11:[6]})
sage: G.katz_centrality(.85)
@@ -2261,7 +2334,7 @@ index 8b8c98cb15..6823e13b26 100644
2: 0.000000000000000,
3: 0.000000000000000,
4: 16.7319819819820,
-@@ -23538,7 +23539,6 @@ class GenericGraph(GenericGraph_pyx):
+@@ -23581,7 +23581,6 @@ class GenericGraph(GenericGraph_pyx):
7: 0.000000000000000,
8: 18.6846846846847,
9: 0.000000000000000,
@@ -2269,7 +2342,7 @@ index 8b8c98cb15..6823e13b26 100644
11: 202.778914049184}
-@@ -23558,7 +23558,7 @@ class GenericGraph(GenericGraph_pyx):
+@@ -23600,7 +23600,7 @@ class GenericGraph(GenericGraph_pyx):
sage: graphs.PathGraph(4).katz_centrality(1/20,3)
21/379
sage: (graphs.PathGraph(3) + graphs.PathGraph(4)).katz_centrality(1/20)
@@ -2308,7 +2381,7 @@ diff --git a/src/sage/graphs/graph_coloring.pyx b/src/sage/graphs/graph_coloring
index 47b93c1f38..7493fd8dd1 100644
--- a/src/sage/graphs/graph_coloring.pyx
+++ b/src/sage/graphs/graph_coloring.pyx
-@@ -1029,10 +1029,10 @@ def edge_coloring(g, value_only=False, vizing=False, hex_colors=False, solver=No
+@@ -1028,10 +1028,10 @@ def edge_coloring(g, value_only=False, vizing=False, hex_colors=False, solver=No
[(0, 5), (2, 7)],
[(1, 6), (3, 4), (5, 8), (7, 9)]]
sage: edge_coloring(g, value_only=False, hex_colors=True, solver='GLPK')
@@ -3830,7 +3903,7 @@ diff --git a/src/sage/rings/polynomial/multi_polynomial_libsingular.pyx b/src/sa
index 0311cd71bb..4f26f35011 100644
--- a/src/sage/rings/polynomial/multi_polynomial_libsingular.pyx
+++ b/src/sage/rings/polynomial/multi_polynomial_libsingular.pyx
-@@ -3018,7 +3018,7 @@ cdef class MPolynomial_libsingular(MPolynomial):
+@@ -3015,7 +3015,7 @@ cdef class MPolynomial_libsingular(MPolynomial):
sage: R.<x,y,z> = QQ[]
sage: f=2*x*y^3*z^2 + 1/7*x^2 + 2/3
sage: f.dict()
@@ -3882,7 +3955,7 @@ diff --git a/src/sage/rings/polynomial/polynomial_ring.py b/src/sage/rings/polyn
index 5e170e635b..5d5cb2f7ad 100644
--- a/src/sage/rings/polynomial/polynomial_ring.py
+++ b/src/sage/rings/polynomial/polynomial_ring.py
-@@ -1206,7 +1206,7 @@ class PolynomialRing_general(sage.algebras.algebra.Algebra):
+@@ -1203,7 +1203,7 @@ class PolynomialRing_general(sage.algebras.algebra.Algebra):
sage: R.<y,x,a42> = RR[]
sage: R.gens_dict()
@@ -4542,7 +4615,7 @@ diff --git a/src/sage/geometry/polyhedron/base.py b/src/sage/geometry/polyhedron
index 8f740b7621..1a2ff5a135 100644
--- a/src/sage/geometry/polyhedron/base.py
+++ b/src/sage/geometry/polyhedron/base.py
-@@ -6035,20 +6035,20 @@ class Polyhedron_base(Element):
+@@ -6072,20 +6072,20 @@ class Polyhedron_base(Element):
sage: P = polytopes.twenty_four_cell()
sage: P.flag_f_vector()
{(-1,): 1,
@@ -4571,7 +4644,7 @@ index 8f740b7621..1a2ff5a135 100644
(3,): 24,
(4,): 1}
-@@ -6078,18 +6078,18 @@ class Polyhedron_base(Element):
+@@ -6115,18 +6115,18 @@ class Polyhedron_base(Element):
sage: P = (Polyhedron(lines=[[1]]) * polytopes.cross_polytope(3))
sage: P.flag_f_vector()
{(-1,): 1,
@@ -4595,7 +4668,7 @@ index 8f740b7621..1a2ff5a135 100644
(2,): 12,
(3,): 8,
4: 1}
-@@ -6129,22 +6129,22 @@ class Polyhedron_base(Element):
+@@ -6166,22 +6166,22 @@ class Polyhedron_base(Element):
sage: polytopes.hypercube(4)._flag_f_vector()
{(-1,): 1,
diff --git a/sagemath-matplotlib-3.2.patch b/sagemath-matplotlib-3.2.patch
index 8f9ef8c548be..c8f542ca5bd5 100644
--- a/sagemath-matplotlib-3.2.patch
+++ b/sagemath-matplotlib-3.2.patch
@@ -11,3 +11,52 @@ index a7533fa3d9..12a2b1f670 100644
@suboptions('label', fontsize=9, colors='blue', inline=None, inline_spacing=3,
fmt="%1.2f")
@options(plot_points=100, fill=True, contours=None, linewidths=None,
+diff --git a/src/sage/plot/colors.py b/src/sage/plot/colors.py
+index 1860b6c948..af6fc7ec64 100644
+--- a/src/sage/plot/colors.py
++++ b/src/sage/plot/colors.py
+@@ -20,7 +20,7 @@ comprises the "official" W3C CSS3_ / SVG_ colors.
+ For a list of color maps in Sage, evaluate::
+
+ sage: sorted(colormaps)
+- [u'Accent', u'Accent_r', u'Blues', u'Blues_r', u'BrBG', u'BrBG_r', ...]
++ [u'Accent', u'Blues', u'BrBG', ...]
+
+ These are imported from matplotlib's cm_ module.
+
+@@ -1374,7 +1374,7 @@ def get_cmap(cmap):
+ and color names. For a list of map names, evaluate::
+
+ sage: sorted(colormaps)
+- [u'Accent', u'Accent_r', u'Blues', u'Blues_r', ...]
++ [u'Accent', u'Blues', ...]
+
+ See :func:`rgbcolor` for valid list/tuple element formats.
+
+@@ -1468,7 +1468,7 @@ class Colormaps(collections.MutableMapping):
+ For a list of map names, evaluate::
+
+ sage: sorted(colormaps)
+- [u'Accent', u'Accent_r', u'Blues', u'Blues_r', ...]
++ [u'Accent', u'Blues', ...]
+ """
+ def __init__(self):
+ """
+@@ -1495,7 +1495,7 @@ class Colormaps(collections.MutableMapping):
+ sage: len(maps.maps)
+ 0
+ sage: maps.load_maps()
+- sage: len(maps.maps)>130
++ sage: len(maps.maps)>65
+ True
+ """
+ global cm
+@@ -1539,7 +1539,7 @@ class Colormaps(collections.MutableMapping):
+
+ sage: from sage.plot.colors import Colormaps
+ sage: maps = Colormaps()
+- sage: len(maps)>130
++ sage: len(maps)>65
+ True
+ """
+ self.load_maps()
diff --git a/sagemath-pari-2.11.3.patch b/sagemath-pari-2.11.3.patch
index 41d59ec9651c..67870ccf5507 100644
--- a/sagemath-pari-2.11.3.patch
+++ b/sagemath-pari-2.11.3.patch
@@ -1,24 +1,22 @@
diff --git a/src/sage/lfunctions/dokchitser.py b/src/sage/lfunctions/dokchitser.py
-index 680ac17dfd..1fe0671c10 100644
+index 680ac17dfd..1bf8953a77 100644
--- a/src/sage/lfunctions/dokchitser.py
+++ b/src/sage/lfunctions/dokchitser.py
-@@ -110,8 +110,7 @@ class Dokchitser(SageObject):
- sage: L.taylor_series(1,4)
+@@ -111,7 +111,7 @@ class Dokchitser(SageObject):
0.000000000000000 + 0.305999773834052*z + 0.186547797268162*z^2 - 0.136791463097188*z^3 + O(z^4)
sage: L.check_functional_equation()
-- 6.11218974700000e-18 # 32-bit
+ 6.11218974700000e-18 # 32-bit
- 6.04442711160669e-18 # 64-bit
-+ 6.11218974700000e-18
++ 6.11218974738703e-18 # 64-bit
RANK 2 ELLIPTIC CURVE:
-@@ -669,8 +668,7 @@ class Dokchitser(SageObject):
-
+@@ -670,7 +670,7 @@ class Dokchitser(SageObject):
sage: L = Dokchitser(conductor=1, gammaV=[0], weight=1, eps=1, poles=[1], residues=[-1], init='1')
sage: L.check_functional_equation()
-- -1.35525271600000e-20 # 32-bit
+ -1.35525271600000e-20 # 32-bit
- -2.71050543121376e-20 # 64-bit
-+ -1.35525271600000e-20
++ -1.35525271560688e-20 # 64-bit
If we choose the sign in functional equation for the
`\zeta` function incorrectly, the functional equation
@@ -39,6 +37,16 @@ diff --git a/src/sage/schemes/elliptic_curves/ell_number_field.py b/src/sage/sch
index 2967f085ca..b423c2b7ed 100644
--- a/src/sage/schemes/elliptic_curves/ell_number_field.py
+++ b/src/sage/schemes/elliptic_curves/ell_number_field.py
+@@ -302,7 +302,8 @@ class EllipticCurve_number_field(EllipticCurve_field):
+ (3,
+ 3,
+ [(0 : 0 : 1),
+- (-1/2*zeta43_0^2 - 1/2*zeta43_0 + 7 : -3/2*zeta43_0^2 - 5/2*zeta43_0 + 18 : 1)])
++ (-1/2*zeta43_0^2 - 1/2*zeta43_0 + 7 : -3/2*zeta43_0^2 - 5/2*zeta43_0 + 18 : 1),
++ (5/8*zeta43_0^2 + 17/8*zeta43_0 - 9/4 : -27/16*zeta43_0^2 - 103/16*zeta43_0 + 39/8 : 1)])
+ """
+ verbose = int(verbose)
+ if known_points is None:
@@ -810,7 +810,7 @@ class EllipticCurve_number_field(EllipticCurve_field):
sage: K.<v> = NumberField(x^2 + 161*x - 150)
sage: E = EllipticCurve([25105/216*v - 3839/36, 634768555/7776*v - 98002625/1296, 634768555/7776*v - 98002625/1296, 0, 0])