summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--sagemath-ipython7.patch26
-rw-r--r--sagemath-python-3.8.patch43
4 files changed, 44 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90bb72871a4b..b92fdcf059cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -114,9 +114,9 @@ pkgbase = sagemath-git
sha256sums = 937074fa7a8a4e2aba9ea77ec622fe937985a1a9176c48460d51325ee877a4f5
sha256sums = 998e2c619d47849f977778906e2e492a09d8767b8f2e6d72a787368e7cf7b956
sha256sums = e44bbde87f3312548faad75b7383ef21fade55be251ab5804de41cd3842ca8a0
- sha256sums = a2688f139d53e7cd3bd4e4187571222463df7fdb55f574654e678fbaa86ac2f5
+ sha256sums = 151c4918e8f1198d195a83ad454431929d6a66319b31f68b43715825c604e5a1
sha256sums = 9062b412595e81a5ca560a5ae789f8b7318981689cb8d076b30d8c54a4fc4495
- sha256sums = bb1b0f45807c1badccd2f50d5ec6d0a8a98b35ab5ef0dbdfb4a6ec7efefbbd0e
+ sha256sums = f2152e2ddf004c53273f61ea95938a82a60f71211826f1cf67db554617f5e6d2
pkgname = sagemath-git
optdepends = cython: to compile cython code
diff --git a/PKGBUILD b/PKGBUILD
index a600a37bc578..05290a55c539 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -52,9 +52,9 @@ sha256sums=('SKIP'
'937074fa7a8a4e2aba9ea77ec622fe937985a1a9176c48460d51325ee877a4f5'
'998e2c619d47849f977778906e2e492a09d8767b8f2e6d72a787368e7cf7b956'
'e44bbde87f3312548faad75b7383ef21fade55be251ab5804de41cd3842ca8a0'
- 'a2688f139d53e7cd3bd4e4187571222463df7fdb55f574654e678fbaa86ac2f5'
+ '151c4918e8f1198d195a83ad454431929d6a66319b31f68b43715825c604e5a1'
'9062b412595e81a5ca560a5ae789f8b7318981689cb8d076b30d8c54a4fc4495'
- 'bb1b0f45807c1badccd2f50d5ec6d0a8a98b35ab5ef0dbdfb4a6ec7efefbbd0e')
+ 'f2152e2ddf004c53273f61ea95938a82a60f71211826f1cf67db554617f5e6d2')
pkgver() {
cd sage
diff --git a/sagemath-ipython7.patch b/sagemath-ipython7.patch
index 2af60a47d285..71be45ce8fff 100644
--- a/sagemath-ipython7.patch
+++ b/sagemath-ipython7.patch
@@ -2205,7 +2205,7 @@ index 8b8c98cb15..6823e13b26 100644
sage: pos = g.layout(layout='planar', save_pos=True, test=True)
sage: pos[0]
@@ -5225,7 +5225,7 @@ class GenericGraph(GenericGraph_pyx):
- [3, 64]
+ [93, 14]
sage: g = graphs.CycleGraph(7)
sage: g.layout(layout='planar', save_pos=True, test=True)
- {0: [0, 5], 1: [1, 4], 2: [5, 1], 3: [3, 1], 4: [1, 0], 5: [2, 1], 6: [1, 3]}
@@ -2734,23 +2734,15 @@ diff --git a/src/sage/graphs/partial_cube.py b/src/sage/graphs/partial_cube.py
index 7174a23662..fba9755ff2 100644
--- a/src/sage/graphs/partial_cube.py
+++ b/src/sage/graphs/partial_cube.py
-@@ -113,12 +113,12 @@ def breadth_first_level_search(G, start):
- sage: list(sage.graphs.partial_cube.breadth_first_level_search(H, '00'))
+@@ -110,7 +110,7 @@ def breadth_first_level_search(G, start):
+ EXAMPLES::
+
+ sage: H = digraphs.DeBruijn(3,2)
+- sage: list(sage.graphs.partial_cube.breadth_first_level_search(H, '00'))
++ sage: list(sage.graphs.partial_cube.breadth_first_level_search(H, '00')) # random
[{'00': {'01', '02'}},
{'01': {'10', '11', '12'}, '02': {'20', '21', '22'}},
-- {'10': set(),
-+ {'22': set(),
- '11': set(),
-- '12': set(),
-- '20': set(),
- '21': set(),
-- '22': set()}]
-+ '12': set(),
-+ '20': set(),
-+ '10': set()}]
-
- """
- neighbors = G.neighbor_out_iterator
+ {'10': set(),
diff --git a/src/sage/graphs/schnyder.py b/src/sage/graphs/schnyder.py
index 241288a4de..391317fae5 100644
--- a/src/sage/graphs/schnyder.py
@@ -4422,8 +4414,8 @@ index 9818f2ada9..e87f5d1f74 100644
{N(-2): 2, N(1): 1}
"""
@@ -1955,7 +1955,7 @@ class SchemeMorphism_fan_fiber_component_toric_variety(SchemeMorphism):
- N(1, -3) (9, 2)
N(-1, 2) (11, 1)
+ N(1, -3) (9, 2)
sage: f._ray_index_map
- {N(-3, 4): 10, N(-1, 2): 11, N(0, 1): 5, N(1, 0): 4, N(2, -6): 9}
+ {N(1, 0): 4, N(0, 1): 5, N(-3, 4): 10, N(2, -6): 9, N(-1, 2): 11}
diff --git a/sagemath-python-3.8.patch b/sagemath-python-3.8.patch
index 71e8cd944bba..e15fc121255d 100644
--- a/sagemath-python-3.8.patch
+++ b/sagemath-python-3.8.patch
@@ -118,7 +118,7 @@ diff --git a/src/sage/combinat/growth.py b/src/sage/combinat/growth.py
index cb9efbbb22..48eee6b42e 100644
--- a/src/sage/combinat/growth.py
+++ b/src/sage/combinat/growth.py
-@@ -1691,7 +1691,7 @@ class Rule(UniqueRepresentation):
+@@ -1707,7 +1707,7 @@ class Rule(UniqueRepresentation):
EXAMPLES::
sage: from sage.combinat.growth import Rule
@@ -355,7 +355,7 @@ diff --git a/src/sage/dynamics/arithmetic_dynamics/generic_ds.py b/src/sage/dyna
index be7e0c46d0..d470fdcc5b 100644
--- a/src/sage/dynamics/arithmetic_dynamics/generic_ds.py
+++ b/src/sage/dynamics/arithmetic_dynamics/generic_ds.py
-@@ -468,13 +468,13 @@ class DynamicalSystem(SchemeMorphism_polynomial):
+@@ -476,13 +476,13 @@ class DynamicalSystem(SchemeMorphism_polynomial):
sage: f.periodic_points(3,minimal=False, R=N)
[(0 : 1),
(a : 1),
@@ -378,7 +378,7 @@ diff --git a/src/sage/dynamics/arithmetic_dynamics/projective_ds.py b/src/sage/d
index 99ad85b695..4d2642366a 100644
--- a/src/sage/dynamics/arithmetic_dynamics/projective_ds.py
+++ b/src/sage/dynamics/arithmetic_dynamics/projective_ds.py
-@@ -3146,8 +3146,8 @@ class DynamicalSystem_projective(SchemeMorphism_polynomial_projective_space,
+@@ -3147,8 +3147,8 @@ class DynamicalSystem_projective(SchemeMorphism_polynomial_projective_space,
sage: D6 = DynamicalSystem_projective([y^2,x^2])
sage: D6.automorphism_group()
[
@@ -410,7 +410,26 @@ index 99ad85b695..4d2642366a 100644
::
-@@ -5112,7 +5112,7 @@ class DynamicalSystem_projective_field(DynamicalSystem_projective,
+@@ -3894,13 +3894,13 @@ class DynamicalSystem_projective(SchemeMorphism_polynomial_projective_space,
+ sage: P.<x,y,z> = ProjectiveSpace(K,2)
+ sage: f = DynamicalSystem_projective([x^2+z^2, y^2+x^2, z^2+y^2])
+ sage: f.periodic_points(1)
+- [(-s^5 + 3*s^4 - 5*s^3 + 4*s^2 - 3*s + 1 : s^5 - 2*s^4 + 3*s^3 - 3*s^2 + 4*s - 1 : 1),
+- (-2*s^5 + 4*s^4 - 5*s^3 + 3*s^2 - 4*s : -2*s^5 + 5*s^4 - 7*s^3 + 6*s^2 - 7*s + 3 : 1),
+- (-s^5 + 3*s^4 - 4*s^3 + 4*s^2 - 4*s + 2 : -s^5 + 2*s^4 - 2*s^3 + s^2 - s : 1),
++ [(2*s^5 - 6*s^4 + 9*s^3 - 8*s^2 + 7*s - 4 : 2*s^5 - 5*s^4 + 7*s^3 - 5*s^2 + 6*s - 2 : 1),
+ (s^5 - 2*s^4 + 3*s^3 - 3*s^2 + 3*s - 1 : -s^5 + 3*s^4 - 5*s^3 + 4*s^2 - 4*s + 2 : 1),
+- (2*s^5 - 6*s^4 + 9*s^3 - 8*s^2 + 7*s - 4 : 2*s^5 - 5*s^4 + 7*s^3 - 5*s^2 + 6*s - 2 : 1),
++ (-s^5 + 3*s^4 - 5*s^3 + 4*s^2 - 3*s + 1 : s^5 - 2*s^4 + 3*s^3 - 3*s^2 + 4*s - 1 : 1),
++ (-2*s^5 + 4*s^4 - 5*s^3 + 3*s^2 - 4*s : -2*s^5 + 5*s^4 - 7*s^3 + 6*s^2 - 7*s + 3 : 1),
++ (s^5 - 2*s^4 + 2*s^3 + s : s^5 - 3*s^4 + 4*s^3 - 3*s^2 + 2*s - 1 : 1),
+ (1 : 1 : 1),
+- (s^5 - 2*s^4 + 2*s^3 + s : s^5 - 3*s^4 + 4*s^3 - 3*s^2 + 2*s - 1 : 1)]
++ (-s^5 + 3*s^4 - 4*s^3 + 4*s^2 - 4*s + 2 : -s^5 + 2*s^4 - 2*s^3 + s^2 - s : 1)]
+
+ ::
+
+@@ -5497,7 +5497,7 @@ class DynamicalSystem_projective_field(DynamicalSystem_projective,
sage: f.rational_periodic_points()
doctest:warning
...
@@ -419,7 +438,7 @@ index 99ad85b695..4d2642366a 100644
"""
from sage.misc.superseded import deprecation
deprecation(28109, "use sage.dynamics.arithmetic_dynamics.projective_ds.all_periodic_points instead")
-@@ -5472,8 +5472,8 @@ class DynamicalSystem_projective_field(DynamicalSystem_projective,
+@@ -5941,8 +5941,8 @@ class DynamicalSystem_projective_field(DynamicalSystem_projective,
(w^2 + w - 25/16 : 1),
(-w : 1),
(-w^2 + 29/16 : 1),
@@ -429,7 +448,7 @@ index 99ad85b695..4d2642366a 100644
(-w^2 + 21/16 : 1),
(w^2 - 21/16 : 1),
(w^2 + w - 33/16 : 1),
-@@ -5601,8 +5601,8 @@ class DynamicalSystem_projective_field(DynamicalSystem_projective,
+@@ -6070,8 +6070,8 @@ class DynamicalSystem_projective_field(DynamicalSystem_projective,
sage: g = f.conjugate(m)
sage: f.conjugating_set(g) # long time
[
@@ -585,7 +604,7 @@ diff --git a/src/sage/geometry/lattice_polytope.py b/src/sage/geometry/lattice_p
index fe36a712f5..2383bade13 100644
--- a/src/sage/geometry/lattice_polytope.py
+++ b/src/sage/geometry/lattice_polytope.py
-@@ -1911,8 +1911,8 @@ class LatticePolytopeClass(SageObject, collections.Hashable):
+@@ -1927,8 +1927,8 @@ class LatticePolytopeClass(SageObject, collections.Hashable):
sage: D = L.hasse_diagram()
sage: D.neighbors(face)
[1-d face of 2-d lattice polytope in 2-d lattice M,
@@ -596,7 +615,7 @@ index fe36a712f5..2383bade13 100644
However, you can achieve some of this functionality using
:meth:`facets`, :meth:`facet_of`, and :meth:`adjacent` methods::
-@@ -3917,7 +3917,7 @@ class LatticePolytopeClass(SageObject, collections.Hashable):
+@@ -3933,7 +3933,7 @@ class LatticePolytopeClass(SageObject, collections.Hashable):
sage: p = lattice_polytope.cross_polytope(2).polar()
sage: p.traverse_boundary()
@@ -696,7 +715,7 @@ diff --git a/src/sage/graphs/generic_graph.py b/src/sage/graphs/generic_graph.py
index 9f7e1f418e..0ec459e7d3 100644
--- a/src/sage/graphs/generic_graph.py
+++ b/src/sage/graphs/generic_graph.py
-@@ -5152,7 +5152,7 @@ class GenericGraph(GenericGraph_pyx):
+@@ -5153,7 +5153,7 @@ class GenericGraph(GenericGraph_pyx):
This method is deprecated since Sage-4.4.1.alpha2. Please use instead:
sage: g.layout(layout = "planar", save_pos = True)
@@ -705,7 +724,7 @@ index 9f7e1f418e..0ec459e7d3 100644
"""
deprecation(24494, 'This method is replaced by the method layout. '
'Please use layout(layout="planar", save_pos=True) '
-@@ -5206,25 +5206,25 @@ class GenericGraph(GenericGraph_pyx):
+@@ -5207,25 +5207,25 @@ class GenericGraph(GenericGraph_pyx):
sage: g = graphs.PathGraph(10)
sage: g.layout(layout='planar', save_pos=True, test=True)
@@ -744,7 +763,7 @@ index 9f7e1f418e..0ec459e7d3 100644
sage: g = graphs.CompleteGraph(5)
sage: g.layout(layout='planar', save_pos=True, test=True, set_embedding=True)
Traceback (most recent call last):
-@@ -5750,17 +5750,17 @@ class GenericGraph(GenericGraph_pyx):
+@@ -5751,17 +5751,17 @@ class GenericGraph(GenericGraph_pyx):
sage: T = graphs.TetrahedralGraph()
sage: T.faces({0: [1, 3, 2], 1: [0, 2, 3], 2: [0, 3, 1], 3: [0, 1, 2]})
[[(0, 1), (1, 2), (2, 0)],
@@ -1270,7 +1289,7 @@ diff --git a/src/sage/schemes/product_projective/homset.py b/src/sage/schemes/pr
index f1508cf794..1ec855b01a 100644
--- a/src/sage/schemes/product_projective/homset.py
+++ b/src/sage/schemes/product_projective/homset.py
-@@ -110,7 +110,7 @@ class SchemeHomset_points_product_projective_spaces_field(SchemeHomset_points_pr
+@@ -117,7 +117,7 @@ class SchemeHomset_points_product_projective_spaces_field(SchemeHomset_points_pr
sage: P.<x,y,z,w> = ProductProjectiveSpaces([1,1], NumberField(u^2 - 2, 'v'))
sage: X = P.subscheme([x^2 - y^2, z^2 - 2*w^2])
sage: X(P.base_ring()).points()