summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
-rw-r--r--sagemath-pynac-0.7.6.patch44
-rw-r--r--skip-check.patch21
4 files changed, 55 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93a10dda4515..f515ede22d3b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sagemath-git
pkgdesc = Open Source Mathematics Software, free alternative to Magma, Maple, Mathematica, and Matlab
- pkgver = 8.0.beta1.r0.g4f31f7bc4e
+ pkgver = 8.0.beta3.r0.g2f5a28f235
pkgrel = 1
url = http://www.sagemath.org
arch = i686
@@ -92,7 +92,6 @@ pkgbase = sagemath-git
optdepends = tachyon: alternative 3D plots engine
source = git://git.sagemath.org/sage.git#branch=develop
source = env.patch
- source = skip-check.patch
source = cython-sys-path.patch
source = is-package-installed.patch
source = package.patch
@@ -104,9 +103,9 @@ pkgbase = sagemath-git
source = r-no-readline.patch
source = fes02.patch
source = create_extension.patch
+ source = sagemath-pynac-0.7.6.patch
sha256sums = SKIP
sha256sums = e0b5b8673300857fde823209a7e90faecf9e754ab812cc5e54297eddc0c79571
- sha256sums = 178074c0a22da4a8129ec299a6845aaae8cf3ef1da6f62b34f2ec0ed50c1e6a2
sha256sums = ff7e034d08ab084fdb193484f7fe3a659ebcd8ab33a2b7177237d65b26de7872
sha256sums = 57349b0d1596a1719ba97f1c4d0cceb1ab0051a551c9904064145a5583c883f2
sha256sums = 4a2297e4d9d28f0b3a1f58e1b463e332affcb109eafde44837b1657e309c8212
@@ -118,6 +117,7 @@ pkgbase = sagemath-git
sha256sums = ef9f401fa84fe1772af9efee6816643534f2896da4c23b809937b19771bdfbbf
sha256sums = a39da083c038ada797ffc5bedc9ba47455a3f77057d42f86484ae877ef9172ea
sha256sums = 362bd7603e14f729c87eebc9d3f56eb8a9ec94456038f0cb17591e81c459ef8e
+ sha256sums = 42d6549d9a07bcea9fa79bb63961ebbfaaa4ca64e9c6a402ae90d559bb256c12
pkgname = sagemath-git
optdepends = cython2: to compile cython code
@@ -158,7 +158,6 @@ pkgname = sagemath-jupyter-git
depends = sagemath
depends = python2-jupyter_client
depends = python2-ipywidgets
- depends = jupyter-notebook
depends = mathjax
optdepends = sage-notebook-exporter: convert flask notebooks to Jupyter
diff --git a/PKGBUILD b/PKGBUILD
index 49028056c8e8..7160a57c559a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgbase=sagemath-git
pkgname=(sagemath-git sagemath-jupyter-git)
-pkgver=8.0.beta1.r0.g4f31f7bc4e
+pkgver=8.0.beta3.r0.g2f5a28f235
pkgrel=1
pkgdesc="Open Source Mathematics Software, free alternative to Magma, Maple, Mathematica, and Matlab"
arch=(i686 x86_64)
@@ -33,12 +33,11 @@ optdepends=('cython2: to compile cython code' 'python2-pkgconfig: to compile cyt
makedepends=(cython2 boost ratpoints symmetrica python2-jinja coin-or-cbc libhomfly libbraiding
mcqd coxeter3 cryptominisat2 modular_decomposition bliss-graphs tdlib python2-pkgconfig meataxe libfes git)
source=("git://git.sagemath.org/sage.git#branch=develop"
- env.patch skip-check.patch cython-sys-path.patch is-package-installed.patch package.patch latte-count.patch
+ env.patch cython-sys-path.patch is-package-installed.patch package.patch latte-count.patch
jupyter-path.patch sagemath-python3-notebook.patch test-optional.patch ecm-7.patch r-no-readline.patch fes02.patch
- create_extension.patch)
+ create_extension.patch sagemath-pynac-0.7.6.patch)
sha256sums=('SKIP'
'e0b5b8673300857fde823209a7e90faecf9e754ab812cc5e54297eddc0c79571'
- '178074c0a22da4a8129ec299a6845aaae8cf3ef1da6f62b34f2ec0ed50c1e6a2'
'ff7e034d08ab084fdb193484f7fe3a659ebcd8ab33a2b7177237d65b26de7872'
'57349b0d1596a1719ba97f1c4d0cceb1ab0051a551c9904064145a5583c883f2'
'4a2297e4d9d28f0b3a1f58e1b463e332affcb109eafde44837b1657e309c8212'
@@ -49,7 +48,8 @@ sha256sums=('SKIP'
'06bc1e5b409e21d49fc71ef03e96ec35b7a9b524bfd1f81a2dbf5c64a55e5acf'
'ef9f401fa84fe1772af9efee6816643534f2896da4c23b809937b19771bdfbbf'
'a39da083c038ada797ffc5bedc9ba47455a3f77057d42f86484ae877ef9172ea'
- '362bd7603e14f729c87eebc9d3f56eb8a9ec94456038f0cb17591e81c459ef8e')
+ '362bd7603e14f729c87eebc9d3f56eb8a9ec94456038f0cb17591e81c459ef8e'
+ '42d6549d9a07bcea9fa79bb63961ebbfaaa4ca64e9c6a402ae90d559bb256c12')
pkgver() {
cd sage
@@ -64,8 +64,6 @@ prepare(){
patch -p0 -i ../package.patch
# set env variables
patch -p0 -i ../env.patch
-# skip checking build status
- patch -p0 -i ../skip-check.patch
# don't list optional packages when running tests
patch -p0 -i ../test-optional.patch
# set jupyter path
@@ -86,6 +84,8 @@ prepare(){
patch -p1 -i ../fes02.patch
# replace is_package_installed usage http://trac.sagemath.org/ticket/20377
patch -p1 -i ../is-package-installed.patch
+# port to pynac 0.7.6 https://trac.sagemath.org/ticket/22838
+ patch -p1 -i ../sagemath-pynac-0.7.6.patch
# use python2
sed -e 's|#!/usr/bin/env python|#!/usr/bin/env python2|' -e 's|exec python|exec python2|' -i src/bin/*
@@ -153,7 +153,7 @@ package_sagemath-git() {
package_sagemath-jupyter-git() {
pkgdesc='Jupyter kernel for SageMath'
- depends=(sagemath python2-jupyter_client python2-ipywidgets jupyter-notebook mathjax)
+ depends=(sagemath python2-jupyter_client python2-ipywidgets mathjax)
optdepends=('sage-notebook-exporter: convert flask notebooks to Jupyter')
cd sage/src
diff --git a/sagemath-pynac-0.7.6.patch b/sagemath-pynac-0.7.6.patch
new file mode 100644
index 000000000000..f121e06268c2
--- /dev/null
+++ b/sagemath-pynac-0.7.6.patch
@@ -0,0 +1,44 @@
+diff --git a/src/sage/libs/pynac/pynac.pxd b/src/sage/libs/pynac/pynac.pxd
+index 15e8ac2..568dbd6 100644
+--- a/src/sage/libs/pynac/pynac.pxd
++++ b/src/sage/libs/pynac/pynac.pxd
+@@ -319,7 +319,7 @@ cdef extern from "sage/libs/pynac/wrap.h":
+
+
+ GEx g_abs "GiNaC::abs" (GEx x) except + # absolute value
+- GEx g_step "GiNaC::step" (GEx x) except + # step function
++ GEx g_step "GiNaC::unit_step" (GEx x) except + # step function
+ GEx g_csgn "GiNaC::csgn" (GEx x) except + # complex sign
+ GEx g_conjugate "GiNaC::conjugate_function" (GEx x) except + # complex conjugation
+ GEx g_real_part "GiNaC::real_part_function" (GEx x) except + # real part
+diff --git a/src/sage/symbolic/expression.pyx b/src/sage/symbolic/expression.pyx
+index 01319b5..735d6fa 100644
+--- a/src/sage/symbolic/expression.pyx
++++ b/src/sage/symbolic/expression.pyx
+@@ -7018,7 +7018,7 @@ cdef class Expression(CommutativeRingElement):
+ def step(self, hold=False):
+ """
+ Return the value of the Heaviside step function, which is 0 for
+- negative x, 1/2 for 0, and 1 for positive x.
++ negative x, 1 for 0, and 1 for positive x.
+
+ EXAMPLES::
+
+@@ -7026,7 +7026,7 @@ cdef class Expression(CommutativeRingElement):
+ sage: SR(1.5).step()
+ 1
+ sage: SR(0).step()
+- 1/2
++ 1
+ sage: SR(-1/2).step()
+ 0
+ sage: SR(float(-1)).step()
+@@ -7038,7 +7038,7 @@ cdef class Expression(CommutativeRingElement):
+ sage: SR(2).step()
+ 1
+ sage: SR(2).step(hold=True)
+- step(2)
++ unit_step(2)
+
+ """
+ return new_Expression_from_GEx(self._parent,
diff --git a/skip-check.patch b/skip-check.patch
deleted file mode 100644
index 202b661da099..000000000000
--- a/skip-check.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- src/bin/sage.orig 2014-12-18 09:47:27.354829070 +0100
-+++ src/bin/sage 2014-12-18 09:48:00.041563401 +0100
-@@ -355,18 +355,6 @@
-
- # Prepare for running Sage, either interactively or non-interactively.
- sage_setup() {
-- # Check that we're not in a source tarball which hasn't been built yet (#13561).
-- if [ ! -d "$SAGE_LOCAL/lib/python/site-packages/sage" ]; then
-- echo >&2 '************************************************************************'
-- echo >&2 'It seems that you are attempting to run Sage from an unpacked source'
-- echo >&2 'tarball, but you have not compiled it yet (or maybe the build has not'
-- echo >&2 'finished). You should run `make` in the Sage root directory first.'
-- echo >&2 'If you did not intend to build Sage from source, you should download'
-- echo >&2 'a binary tarball instead. Read README.txt for more information.'
-- echo >&2 '************************************************************************'
-- exit 1
-- fi
--
- # Display the startup banner (unless SAGE_BANNER is explictly "no")
- sage_banner
-