summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--LICENSE1
-rw-r--r--PKGBUILD33
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1622c3514359
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = salsapipe-git
+ pkgdesc = Encrypted network tunneling using salsa20 from libnettle and GPG from libgpgme
+ pkgver = 20140730.r25.51c5c6b
+ pkgrel = 1
+ url = https://github.com/0xcaca0/salsapipe
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ groups = archassault
+ groups = archassault-networking
+ license = GPL3
+ makedepends = git
+ depends = gpgme
+ depends = nettle
+ source = git://github.com/0xcaca0/salsapipe.git#branch=master
+ source = LICENSE
+ sha512sums = SKIP
+ sha512sums = 98cb62428d5dd50917a5ce69ad4e7508b5447b1aba83080e2d870f3b410db3747d0ff31b142b9d1c3b8dab10fba028fb78962b23d02cd47352bc2f2cd7dd8620
+
+pkgname = salsapipe-git
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..c6ce271da71a
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1 @@
+There's literally no licensing so I've no objection to it being taken, forked, edited, or copied. Do with it as you please. (source: https://github.com/0xcaca0/salsapipe/issues/1)
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9243ad4512b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Kevin MacMartin <prurigro at gmail dot com>
+
+_pkgname=salsapipe
+pkgname=${_pkgname}-git
+pkgver=20140730.r25.51c5c6b
+pkgrel=1
+pkgdesc="Encrypted network tunneling using salsa20 from libnettle and GPG from libgpgme"
+url="https://github.com/0xcaca0/${_pkgname}"
+license=('GPL3')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+groups=('archassault' 'archassault-networking')
+depends=('gpgme' 'nettle')
+makedepends=('git')
+
+source=("git://github.com/0xcaca0/${_pkgname}.git#branch=master"
+ "LICENSE")
+sha512sums=('SKIP' '98cb62428d5dd50917a5ce69ad4e7508b5447b1aba83080e2d870f3b410db3747d0ff31b142b9d1c3b8dab10fba028fb78962b23d02cd47352bc2f2cd7dd8620')
+
+pkgver() {
+ cd $_pkgname
+ printf "%s.r%s.%s" "$(git show -s --format=%ci master | sed 's/\ .*//g;s/-//g')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $_pkgname
+ make
+}
+
+package() {
+ install -Dm755 ${_pkgname}/salsamsg "${pkgdir}/usr/bin/salsamsg"
+ install -Dm644 ${_pkgname}/salsamsg.1 "${pkgdir}/usr/share/man/man1/salsamsg.1"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}