summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--0001-saltssh-py38.patch25
-rw-r--r--0002-pycryptodome.patch8
-rw-r--r--PKGBUILD18
4 files changed, 7 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e264c7d4bdcc..3c9c394fabd2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = salt-py3
pkgdesc = Central system and configuration manager
- pkgver = 3000.3
+ pkgver = 3001
pkgrel = 1
url = http://saltstack.org/
install = salt.install
@@ -28,14 +28,10 @@ pkgbase = salt-py3
backup = etc/logrotate.d/salt
backup = etc/salt/master
backup = etc/salt/minion
- source = https://pypi.io/packages/source/s/salt/salt-3000.3.tar.gz
+ source = https://pypi.io/packages/source/s/salt/salt-3001.tar.gz
source = salt.logrotate
- source = 0001-saltssh-py38.patch
- source = 0002-pycryptodome.patch
- sha256sums = fcca49985e697d914e5a7f34b2fd8bbd833bcf7779d30174a279a4de2294cea7
+ sha256sums = 5ca60d1b2cc8e63db50995bd8b117914eeaf57c48ce2b3a3731ee57163adf154
sha256sums = abecc3c1be124c4afffaaeb3ba32b60dfee8ba6dc32189edfa2ad154ecb7a215
- sha256sums = 8029d67585bab0b0858c3e2fb317b08bfbeee94d8c785c74472e9c9ecd4c0d3c
- sha256sums = e4e075506ccb8632415e0748d36e5f97ea7e3dad951024b11604ae3f5c36561b
pkgname = salt-py3
diff --git a/0001-saltssh-py38.patch b/0001-saltssh-py38.patch
deleted file mode 100644
index e099a04a5962..000000000000
--- a/0001-saltssh-py38.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-index a3be0b8a1c..ff548923f4 100644
---- "a/salt/grains/core.py"
-+++ "b/salt/grains/core.py"
-@@ -35,12 +35,6 @@ except ImportError:
- __proxyenabled__ = ['*']
- __FQDN__ = None
-
--# Extend the default list of supported distros. This will be used for the
--# /etc/DISTRO-release checking that is part of linux_distribution()
--from platform import _supported_dists
--_supported_dists += ('arch', 'mageia', 'meego', 'vmware', 'bluewhite64',
-- 'slamd64', 'ovs', 'system', 'mint', 'oracle', 'void')
--
- # linux_distribution deprecated in py3.7
- try:
- from platform import linux_distribution as _deprecated_linux_distribution
-@@ -1939,7 +1933,7 @@ def os_data():
- )
- (osname, osrelease, oscodename) = \
- [x.strip('"').strip("'") for x in
-- linux_distribution(supported_dists=_supported_dists)]
-+ linux_distribution()]
- # Try to assign these three names based on the lsb info, they tend to
- # be more accurate than what python gets from /etc/DISTRO-release.
- # It's worth noting that Ubuntu has patched their Python distribution
diff --git a/0002-pycryptodome.patch b/0002-pycryptodome.patch
deleted file mode 100644
index 640e59e0be01..000000000000
--- a/0002-pycryptodome.patch
+++ /dev/null
@@ -1,8 +0,0 @@
-diff --git a/requirements/crypto.txt b/requirements/crypto.txt
-index 9a62bb31f8..acdfd2028e 100644
---- a/requirements/crypto.txt
-+++ b/requirements/crypto.txt
-@@ -1,2 +1 @@
--pycrypto>=2.6.1; sys.platform not in 'win32,darwin'
--pycryptodomex; sys.platform == 'win32'
-+pycryptodomex
diff --git a/PKGBUILD b/PKGBUILD
index d09e6ef07168..ce3487fba9f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
# Contributor: Christer Edwards <christer.edwards@gmail.com>
pkgname=salt-py3
-pkgver=3000.3
+pkgver=3001
pkgrel=1
pkgdesc='Central system and configuration manager'
@@ -37,20 +37,10 @@ backup=('etc/logrotate.d/salt'
install=salt.install
source=("https://pypi.io/packages/source/s/salt/salt-$pkgver.tar.gz"
- "salt.logrotate"
- "0001-saltssh-py38.patch"
- "0002-pycryptodome.patch")
+ "salt.logrotate")
-sha256sums=('fcca49985e697d914e5a7f34b2fd8bbd833bcf7779d30174a279a4de2294cea7'
- 'abecc3c1be124c4afffaaeb3ba32b60dfee8ba6dc32189edfa2ad154ecb7a215'
- '8029d67585bab0b0858c3e2fb317b08bfbeee94d8c785c74472e9c9ecd4c0d3c'
- 'e4e075506ccb8632415e0748d36e5f97ea7e3dad951024b11604ae3f5c36561b')
-
-prepare() {
- cd salt-$pkgver
- patch -p1 < ../0001-saltssh-py38.patch
- patch -p1 < ../0002-pycryptodome.patch
-}
+sha256sums=('5ca60d1b2cc8e63db50995bd8b117914eeaf57c48ce2b3a3731ee57163adf154'
+ 'abecc3c1be124c4afffaaeb3ba32b60dfee8ba6dc32189edfa2ad154ecb7a215')
build() {
cd salt-$pkgver