summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore28
-rw-r--r--PKGBUILD25
3 files changed, 40 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c12b6c17274..89f9edfbada2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = salvador
- pkgdesc = A simple bash script that will help you manage your AUR packages
- pkgver = 0.1.2
+ pkgdesc = A bash script that will help you maintain your AUR packages
+ pkgver = 2.4.1
pkgrel = 1
url = https://gitlab.com/dpeukert/salvador
arch = any
- license = GPL3
+ license = GPL-3.0-or-later
depends = git
depends = pacman-contrib
depends = perl
- source = salvador-0.1.2-1.tar.gz::https://gitlab.com/dpeukert/salvador/-/archive/0.1.2/salvador-0.1.2.tar.gz
- sha256sums = 083920ea64d730d12d8d663f5bdf7ab9d6b47958a14a2dea62326670316278ba
+ optdepends = curl: nvchecker functionality
+ optdepends = jq: nvchecker functionality
+ optdepends = nvchecker: nvchecker functionality
+ source = salvador-2.4.1.tar.gz::https://gitlab.com/dpeukert/salvador/-/archive/2.4.1/salvador-2.4.1.tar.gz
+ sha512sums = b6c96946de9b1104652ed489ff200c6ac8185ae98ec516ca4ce583707b8e0cebbb1a8321bb4c81057bcc8103dc6cab8d41a5a7a2d774d60b1a8a0c4df48e29fe
pkgname = salvador
diff --git a/.gitignore b/.gitignore
index 82b3c183d5d4..076d904dd4ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,14 +1,14 @@
-# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
-*.tar
-*.tar.*
-*.rpm
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-*/
+# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
+# which causes the gitignore file to apply to them too, which breaks some builds
+# Based on https://github.com/github/gitignore/blob/main/ArchLinuxPackages.gitignore
+/*.tar
+/*.tar.*
+/*.rpm
+/*.jar
+/*.exe
+/*.msi
+/*.zip
+/*.tgz
+/*.log
+/*.log.*
+/*.sig
diff --git a/PKGBUILD b/PKGBUILD
index 12d815576357..3214d9d977d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,27 @@
-# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+# Maintainer: Daniel Peukert <daniel@peukert.cc>
pkgname='salvador'
-pkgver='0.1.2'
+pkgver='2.4.1'
pkgrel='1'
-pkgdesc='A simple bash script that will help you manage your AUR packages'
+pkgdesc='A bash script that will help you maintain your AUR packages'
arch=('any')
url="https://gitlab.com/dpeukert/$pkgname"
-license=('GPL3')
+license=('GPL-3.0-or-later')
depends=('git' 'pacman-contrib' 'perl')
-source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/-/archive/$pkgver/$pkgname-$pkgver.tar.gz")
-sha256sums=('083920ea64d730d12d8d663f5bdf7ab9d6b47958a14a2dea62326670316278ba')
+optdepends=(
+ 'curl: nvchecker functionality'
+ 'jq: nvchecker functionality'
+ 'nvchecker: nvchecker functionality'
+)
+source=("$pkgname-$pkgver.tar.gz::$url/-/archive/$pkgver/$pkgname-$pkgver.tar.gz")
+sha512sums=('b6c96946de9b1104652ed489ff200c6ac8185ae98ec516ca4ce583707b8e0cebbb1a8321bb4c81057bcc8103dc6cab8d41a5a7a2d774d60b1a8a0c4df48e29fe')
+
+_sourcedirectory="$pkgname-$pkgver"
+
+check() {
+ "$srcdir/$_sourcedirectory/$pkgname.sh" version | tee '/dev/stderr' | grep -q "^$pkgver$"
+}
package() {
- cd "$srcdir/$pkgname-$pkgver/"
+ cd "$srcdir/$_sourcedirectory/"
make install DESTDIR="$pkgdir" PREFIX='/usr'
}