summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
-rw-r--r--install10
-rwxr-xr-xsamorost23
-rw-r--r--samorost2.desktop7
5 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a131ed9feeb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = samorost2
+ pkgdesc = Samorost 2 is an award-winning point-and-click adventure/puzzle Flash game by Amanita Design
+ pkgver = 1.0
+ pkgrel = 6
+ url = http://amanita-design.net/samorost-2/
+ install = install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = xdg-utils
+ depends = flashplugin
+ source = samorost2
+ source = samorost2.desktop
+ sha256sums = 594dc311057d005bcc0d2b9989c0f095ed8f57c75d9003cc52978d2eb7c87829
+ sha256sums = 7af55922b26b62704645dc928464444361754e4f6e7e348e6ba55efb997be2af
+
+pkgname = samorost2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c415467dc7a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Vojtech Kral <vojtech_kral^hk>
+
+pkgname=samorost2
+pkgver=1.0
+pkgrel=6
+pkgdesc="Samorost 2 is an award-winning point-and-click adventure/puzzle Flash game by Amanita Design"
+arch=('i686' 'x86_64')
+url="http://amanita-design.net/samorost-2/"
+license=('unknown')
+depends=('xdg-utils' 'flashplugin')
+install=install
+
+source=(samorost2
+ samorost2.desktop)
+
+sha256sums=('594dc311057d005bcc0d2b9989c0f095ed8f57c75d9003cc52978d2eb7c87829'
+ '7af55922b26b62704645dc928464444361754e4f6e7e348e6ba55efb997be2af')
+
+_distname='samorost2_linux.zip'
+_distsum='1e6304b203cbe05e2e7d85b2f062142decb70084ebd7cfbee4475d91a048aad6'
+
+package()
+{
+ cd ..
+ if [ ! -f "${_distname}" ]
+ then
+ echo "${_distname} needs to be supplied by the user. Please place it in the directory alongside the PKGBUILD file."
+ exit 1
+ fi
+ echo "${_distsum} ${_distname}" | sha256sum -c || exit 1
+ mkdir -p ${pkgdir}/usr/share/samorost2
+ bsdtar -xf samorost2_linux.zip -C ${pkgdir}/usr/share/samorost2/
+ find ${pkgdir}/usr/share/samorost2/ -type d -exec chmod 755 '{}' \;
+ find ${pkgdir}/usr/share/samorost2/ -type f -exec chmod 644 '{}' \;
+ cd "${srcdir}"
+ install -D -m755 'samorost2' ${pkgdir}/usr/bin/samorost2
+ desktop-file-install --dir=${pkgdir}/usr/share/applications/ 'samorost2.desktop'
+}
diff --git a/install b/install
new file mode 100644
index 000000000000..a5622593e355
--- /dev/null
+++ b/install
@@ -0,0 +1,10 @@
+post_install()
+{
+ update-desktop-database
+}
+
+post_upgrade()
+{
+ find /usr/share/samorost2/ -type d -exec chmod 755 '{}' \;
+ post_install
+}
diff --git a/samorost2 b/samorost2
new file mode 100755
index 000000000000..24df373421ef
--- /dev/null
+++ b/samorost2
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+xdg-open /usr/share/samorost2/Samorost2.html &
diff --git a/samorost2.desktop b/samorost2.desktop
new file mode 100644
index 000000000000..c3e625a80053
--- /dev/null
+++ b/samorost2.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=Samorost 2
+Comment=A point-and-click puzzle Flash Game
+Exec=/usr/bin/samorost2
+Terminal=false
+Type=Application
+Categories=Game;LogicGame;