summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
-rw-r--r--makefile-system-htslib.patch13
3 files changed, 21 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63196eaf38cf..f3232a7ca5b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun Jan 10 10:05:21 UTC 2016
pkgbase = samtools
pkgdesc = tools for manipulating next-generation sequencing data
- pkgver = 1.2
- pkgrel = 2
+ pkgver = 1.3
+ pkgrel = 1
url = http://www.htslib.org/
arch = i686
arch = x86_64
license = custom
- depends = perl
depends = htslib
+ depends = perl
optdepends = luajit: needed for r2plot.lua vcfutils.lua
optdepends = python2: needed for varfilter.py
options = staticlibs
- source = samtools-1.2.tar.gz::https://github.com/samtools/samtools/archive/1.2.tar.gz
- source = makefile-system-htslib.patch
- md5sums = 2748356ef392c0694ca1142de37cf2aa
- md5sums = 00f3b0b730f37cd7c8ff12376a9a0c6a
+ source = https://github.com/samtools/samtools/releases/download/1.3/samtools-1.3.tar.bz2
+ md5sums = 7ab98b5c988e254d9bb5d796bf9337c9
pkgname = samtools
diff --git a/PKGBUILD b/PKGBUILD
index 16372ea08a33..fbdf80b15447 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,24 @@
# Contributor: Markus Heuser <markus.heuser@web.de>
pkgname=samtools
-pkgver=1.2
-pkgrel=2
+pkgver=1.3
+pkgrel=1
pkgdesc="tools for manipulating next-generation sequencing data"
arch=('i686' 'x86_64')
url="http://www.htslib.org/"
license=('custom')
-depends=('perl' 'htslib')
+depends=('htslib' 'perl')
optdepends=('luajit: needed for r2plot.lua vcfutils.lua'
'python2: needed for varfilter.py')
options=('staticlibs')
-source=($pkgname-$pkgver.tar.gz::https://github.com/samtools/samtools/archive/$pkgver.tar.gz
- makefile-system-htslib.patch)
-md5sums=('2748356ef392c0694ca1142de37cf2aa'
- '00f3b0b730f37cd7c8ff12376a9a0c6a')
+source=(https://github.com/samtools/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.bz2)
+md5sums=('7ab98b5c988e254d9bb5d796bf9337c9')
prepare() {
cd $srcdir/$pkgname-$pkgver
- # patch Makefile to make it work with a system-provided htslib
- patch -Np1 -i $srcdir/makefile-system-htslib.patch
+ # prevent shipped htslib to be used
+ rm -rf htslib-1.3
sed -e 's|#!/usr/bin/env python|#!/usr/bin/env python2|' \
-i misc/varfilter.py
@@ -30,19 +28,23 @@ prepare() {
build() {
cd $srcdir/$pkgname-$pkgver
- make HTSDIR=/usr/include HTSLIB= BGZIP= LDLIBS=-lhts
+ ./configure \
+ --prefix=/usr \
+ --with-htslib=system
+
+ make
}
check() {
cd $srcdir/$pkgname-$pkgver
- make HTSDIR=/usr/include HTSLIB= BGZIP= LDLIBS=-lhts check
+ make check
}
package() {
cd $srcdir/$pkgname-$pkgver
- make HTSDIR=/usr/include HTSLIB= BGZIP= LDLIBS=-lhts DESTDIR=$pkgdir prefix=/usr install
+ make DESTDIR=$pkgdir install
for file in misc/*.lua ; do
install -Dm755 $file $pkgdir/usr/bin/$(basename $file)
diff --git a/makefile-system-htslib.patch b/makefile-system-htslib.patch
deleted file mode 100644
index bd46ac328d44..000000000000
--- a/makefile-system-htslib.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -aur samtools-1.2/Makefile samtools-1.2-patched/Makefile
---- samtools-1.2/Makefile 2015-02-02 16:18:41.000000000 +0100
-+++ samtools-1.2-patched/Makefile 2015-06-30 15:48:41.006563956 +0200
-@@ -83,7 +83,9 @@
-
- # Adjust $(HTSDIR) to point to your top-level htslib directory
- HTSDIR = ../htslib
-+ifneq ("$(wildcard $(HTSDIR)/htslib.mk)","")
- include $(HTSDIR)/htslib.mk
-+endif
- HTSLIB = $(HTSDIR)/libhts.a
- BGZIP = $(HTSDIR)/bgzip
-