summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de4724bf90f..4c56a1367df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Dec 18 02:54:23 UTC 2018
+# Wed Dec 26 04:00:09 UTC 2018
pkgbase = sasm
pkgdesc = Simple crossplatform IDE for NASM, GAS, FASM assembly languages
pkgver = 3.10.1
- pkgrel = 1
+ pkgrel = 2
url = http://dman95.github.io/SASM/english.html
arch = i686
arch = x86_64
@@ -12,7 +12,7 @@ pkgbase = sasm
depends = nasm
depends = gdb
depends = gcc
- conflicts = fasm
+ depends = fasm
source = sasm-3.10.1.tar.gz::https://github.com/Dman95/SASM/archive/v3.10.1.tar.gz
sha256sums = 7bd7f3a01f217026362024b53505688fd3757a7dd8cc4e163b55d81a01c078d3
diff --git a/PKGBUILD b/PKGBUILD
index d07fc764003..3454d1ba8a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,12 @@
pkgname=sasm
pkgver=3.10.1
-pkgrel=1
+pkgrel=2
pkgdesc="Simple crossplatform IDE for NASM, GAS, FASM assembly languages"
arch=('i686' 'x86_64')
url="http://dman95.github.io/SASM/english.html"
license=('GPL3')
-depends=('qt5-base' 'nasm' 'gdb' 'gcc')
-conflicts=('fasm')
+depends=('qt5-base' 'nasm' 'gdb' 'gcc' 'fasm')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Dman95/SASM/archive/v${pkgver}.tar.gz")
sha256sums=('7bd7f3a01f217026362024b53505688fd3757a7dd8cc4e163b55d81a01c078d3')
@@ -24,4 +23,6 @@ build() {
package() {
cd "${srcdir}/${pkgname^^}-${pkgver}"
make INSTALL_ROOT="${pkgdir}" install
+ # Don't provide fasm in the package, require it instead
+ rm "${pkgdir}"/usr/bin/fasm
}