summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD22
-rw-r--r--readme.md9
4 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5da62538c785
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = sauceconnect
+ pkgdesc = Sauce Connect untility for Sauce Labs testing
+ pkgver = 4.1
+ pkgrel = 1
+ url = https://saucelabs.com/docs/connect
+ arch = i686
+ arch = x86_64
+ license = unknown
+ source = https://saucelabs.com/downloads/sc-4.1-linux.tar.gz
+ md5sums = f087925c62220d7e450d4181362fe05d
+
+pkgname = sauceconnect
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bb607eea1093
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.swp
+src/
+pkg/
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b3f97dc57308
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Jason Staten <jstaten07 gmail>
+pkgname=sauceconnect
+pkgver=4.1
+pkgrel=1
+pkgdesc='Sauce Connect untility for Sauce Labs testing'
+url='https://saucelabs.com/docs/connect'
+license=('unknown')
+arch=('i686' 'x86_64')
+depends=()
+makedepends=()
+optdepends=()
+source=("https://saucelabs.com/downloads/sc-${pkgver}-linux.tar.gz")
+md5sums=('f087925c62220d7e450d4181362fe05d')
+
+package() {
+ cd "${srcdir}/sc-${pkgver}-linux/"
+ install -D -m755 "bin/sc" "${pkgdir}/usr/bin/sc"
+
+ # License
+ install -D -m644 "license.html" "${pkgdir}/usr/share/licenses/sauceconnect/license.html"
+
+}
diff --git a/readme.md b/readme.md
new file mode 100644
index 000000000000..739cb3eec38e
--- /dev/null
+++ b/readme.md
@@ -0,0 +1,9 @@
+#sauceconnect
+
+AUR PKGBUILD for `sauceconnect`
+
+Sauce Connect is a secure tunneling app which allows you to execute tests
+securely when testing behind firewalls via a secure connection between Sauce
+Labs’ client cloud and your environment.
+
+Documentation available at https://saucelabs.com/docs/connect