summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD86
-rw-r--r--s2editor.desktop16
-rw-r--r--s2game.desktop11
-rw-r--r--s2mviewer.desktop16
-rw-r--r--savage2.desktop11
-rw-r--r--savage2.install15
-rw-r--r--savage2.launcher6
8 files changed, 96 insertions, 93 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ab81efa9416..ecf84675d1e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,29 @@
pkgbase = savage2
- pkgdesc = Savage 2 is a fantasy themed action RPG, that combines elements of FPS and RTS.
- pkgver = 2.1.0
- pkgrel = 3
- url = http://savage2.com/en/main.php
+ pkgdesc = Savage 2: A Tortured Soul is an fantasy themed online multiplayer team-based FPS/RTS/RPG hybrid. Completely free as of December 2008.
+ pkgver = 2.1.0.1
+ pkgrel = 1
+ url = http://savage2.com/
install = savage2.install
arch = i686
arch = x86_64
- license = custom
+ license = custom: "Savage 2"
makedepends = unzip
+ depends = curl
depends = mesa
- depends = libjpeg
depends = libjpeg6
+ depends = libpng
depends = libxml2
- source = http://savage.s2galactica.com/Savage2Install-2.1.0-.bin
- source = s2game.desktop
+ depends = speex
+ source = http://dl.heroesofnewerth.com/Savage2Install-2.1.0.1-.bin
+ source = savage2.launcher
+ source = savage2.desktop
source = s2editor.desktop
source = s2mviewer.desktop
- md5sums = 85b76a8e1ab22f147bb6eef98465c0ba
- md5sums = e599528405e47b699cdf8ca5ea09be6e
- md5sums = 0b1bcd48feb45e5e155d2cdcedc18a2d
- md5sums = 74703e46ace651f5a668568b5f7b1ea0
+ md5sums = 1ff815b9e864862d6d2cf6c635278b80
+ md5sums = fb03853628775f66689852a4125044e8
+ md5sums = a6957bb87da35d58df86d84a6dca1479
+ md5sums = b082a33fd1a580d3c70d80bbbfb0bffe
+ md5sums = 177155e2c2c4e1382ce9b1343e26b5c7
pkgname = savage2
diff --git a/PKGBUILD b/PKGBUILD
index 860ddc491894..90ffa238bec2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,61 +1,59 @@
-# Maintainer: Ali H. Caliskan <ali.h.caliskan@gmail.com>
-# Contributor: Slash <demodevil5[at]yahoo[dot]com>
+# Contributor: Slash <demodevil5 [at] yahoo [dot] com>
+# Contributor: Ali H. Caliskan <ali.h.caliskan@gmail.com>
# Contributor: Xavier <shiningxc[at]gmail[dot]com>
pkgname=savage2
-pkgver=2.1.0
-pkgrel=3
-pkgdesc="Savage 2 is a fantasy themed action RPG, that combines elements of FPS and RTS."
+pkgver=2.1.0.1
+pkgrel=1
+pkgdesc="Savage 2: A Tortured Soul is an fantasy themed online multiplayer team-based FPS/RTS/RPG hybrid. Completely free as of December 2008."
arch=('i686' 'x86_64')
-url="http://savage2.com/en/main.php"
-license=('custom')
-depends=('mesa' 'libjpeg' 'libjpeg6' 'libxml2')
+url='http://savage2.com/'
+license=('custom: "Savage 2"')
+depends=('curl' 'mesa' 'libjpeg6' 'libpng' 'libxml2' 'speex')
makedepends=('unzip')
-install=('savage2.install')
-source=("http://savage.s2galactica.com/Savage2Install-$pkgver-$CARCH.bin"
- 's2game.desktop'
- 's2editor.desktop'
- 's2mviewer.desktop')
-md5sums=('85b76a8e1ab22f147bb6eef98465c0ba'
- 'e599528405e47b699cdf8ca5ea09be6e'
- '0b1bcd48feb45e5e155d2cdcedc18a2d'
- '74703e46ace651f5a668568b5f7b1ea0')
-[ "$CARCH" = "x86_64" ] && md5sums[0]='134814532db8a7aadc0ec56def5e924c'
+install=savage2.install
+source=("http://dl.heroesofnewerth.com/Savage2Install-$pkgver-$CARCH.bin" \
+'savage2.launcher' 'savage2.desktop' 's2editor.desktop' 's2mviewer.desktop')
+md5sums=('1ff815b9e864862d6d2cf6c635278b80'
+ 'fb03853628775f66689852a4125044e8'
+ 'a6957bb87da35d58df86d84a6dca1479'
+ 'b082a33fd1a580d3c70d80bbbfb0bffe'
+ '177155e2c2c4e1382ce9b1343e26b5c7')
+[ "$CARCH" = "x86_64" ] && md5sums[0]='78a5df8adc008e2c7493bab9f66a3092'
build() {
+ cd $srcdir
- cd $srcdir/
+ # Create Destination Directory
+ install -d $pkgdir/opt/savage2
- # Extract the binary file
- unzip -q -o Savage2Install-$pkgver-$CARCH.bin
+ # Extract Game Data from Installer
+ unzip -o $srcdir/Savage2Install-$pkgver-$CARCH.bin
- # Install Savage2
- install -d $pkgdir/opt/Savage2
- cp -r data/* $pkgdir/opt/Savage2
+ # Install Savage 2 Data
+ cp -r $srcdir/data/* $pkgdir/opt/savage2
- # Install Desktop Files
- install -d $pkgdir/usr/share/applications
- install -Dm644 *.desktop $pkgdir/usr/share/applications/
+ # Install Game Launcher
+ install -D -m 755 $srcdir/savage2.launcher \
+ $pkgdir/usr/bin/savage2
- # Install Icon and License
- install -Dm644 data/s2icon.png $pkgdir/usr/share/pixmaps/s2icon.png
- install -Dm644 data/license.txt $pkgdir/usr/share/licenses/$pkgname/license.txt
+ # Install Desktop File (Game Client)
+ install -D -m 644 $srcdir/savage2.desktop \
+ $pkgdir/usr/share/applications/savage2.desktop
- # Install Launcher Script
- mkdir -p $pkgdir/usr/bin
- cat > $pkgdir/usr/bin/savage2 << "EOF"
-#!/bin/bash
+ # Install Desktop File (Map Editor)
+ install -D -m 644 $srcdir/s2editor.desktop \
+ $pkgdir/usr/share/applications/s2editor.desktop
-cd /opt/Savage2
-./savage2.bin
-EOF
+ # Install Desktop File (Model Viewer)
+ install -D -m 644 $srcdir/s2mviewer.desktop \
+ $pkgdir/usr/share/applications/s2mviewer.desktop
- chmod 755 $pkgdir/usr/bin/savage2
+ # Install Icon
+ install -D -m 644 $srcdir/data/s2icon.png \
+ $pkgdir/usr/share/pixmaps/savage2.png
- # Set group permission to root:games
- chown -R root:games $pkgdir/opt/Savage2
-
- # Set permission to 4755
- chmod 4755 $pkgdir/opt/Savage2/savage2.bin
- chmod 4755 $pkgdir/opt/Savage2/savage2_update.bin
+ # Install License
+ install -D -m 644 $srcdir/data/license.txt \
+ $pkgdir/usr/share/licenses/$pkgname/license.txt
}
diff --git a/s2editor.desktop b/s2editor.desktop
index 6d64e6cb7db2..542b862f5b43 100644
--- a/s2editor.desktop
+++ b/s2editor.desktop
@@ -1,11 +1,11 @@
[Desktop Entry]
Encoding=UTF-8
-Version=1.0
+Name=Savage 2 Map Editor
+GenericName=Savage 2 Map Editor
+Comment=Map Editor for Savage 2: A Tortured Soul
+Exec=/usr/bin/savage2 "PushMod editor; Set host_autoExec StartClient"
+Icon=/usr/share/pixmaps/savage2.png
+StartupNotify=true
+Terminal=false
Type=Application
-Name=Savage 2 Editor
-GenericName=Map Editor
-Comment=Map editor for Savage 2 - A Tortured Soul
-Icon=/usr/share/pixmaps/s2icon.png
-Exec=/opt/Savage2/savage2.bin "PushMod editor; Set host_autoExec StartClient"
-Categories=Game
-
+Categories=Application;Game
diff --git a/s2game.desktop b/s2game.desktop
deleted file mode 100644
index c6d9a3238a28..000000000000
--- a/s2game.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-[Desktop Entry]
-Encoding=UTF-8
-Version=1.0
-Type=Application
-Name=Savage 2
-GenericName=Multiplayer Game
-Comment=Savage 2 - A Tortured Soul
-Icon=/usr/share/pixmaps/s2icon.png
-Exec=/usr/bin/savage2
-Categories=Game
-
diff --git a/s2mviewer.desktop b/s2mviewer.desktop
index 85b2efe47c22..fda681596fa6 100644
--- a/s2mviewer.desktop
+++ b/s2mviewer.desktop
@@ -1,11 +1,11 @@
[Desktop Entry]
Encoding=UTF-8
-Version=1.0
-Type=Application
Name=Savage 2 Model Viewer
-GenericName=Model Viewer
-Comment=Model viewer for Savage 2 - A Tortured Soul
-Icon=/usr/share/pixmaps/s2icon.png
-Exec=/opt/Savage2/savage2.bin "PushMod modelviewer; Set host_autoExec StartClient"
-Categories=Game
-
+GenericName=Savage 2 Model Viewer
+Comment=Model Viewer for Savage 2: A Tortured Soul
+Exec=/usr/bin/savage2 "PushMod modelviewer; Set host_autoExec StartClient"
+Icon=/usr/share/pixmaps/savage2.png
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Application;Game
diff --git a/savage2.desktop b/savage2.desktop
new file mode 100644
index 000000000000..e4e6094e2b81
--- /dev/null
+++ b/savage2.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Savage 2
+GenericName=Savage 2
+Comment=Savage 2: A Tortured Soul
+Exec=/usr/bin/savage2
+Icon=/usr/share/pixmaps/savage2.png
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Application;Game
diff --git a/savage2.install b/savage2.install
index 06262eea850a..5182e85ff6f9 100644
--- a/savage2.install
+++ b/savage2.install
@@ -1,21 +1,16 @@
post_install() {
-# Update runpath
- cd /opt/Savage2
- ./savage2_update.bin --update-runpath
-
+ # Update runpath
+ cd /opt/savage2
+ ./savage2_update.bin --update-runpath
}
post_upgrade() {
post_install $1
-
}
post_remove() {
-# Remove updates
-if [ -d /opt/Savage2 ]; then
- rm -r /opt/Savage2
-fi
-
+ echo "==> To completely remove Savage 2, you will need to manually remove"
+ echo "==> /opt/savage2/ as root"
}
op=$1
diff --git a/savage2.launcher b/savage2.launcher
new file mode 100644
index 000000000000..2e0936382edf
--- /dev/null
+++ b/savage2.launcher
@@ -0,0 +1,6 @@
+#!/bin/bash
+
+cd "/opt/savage2"
+./savage2.bin $*
+exit $?
+