summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD61
-rw-r--r--s2editor.desktop11
-rw-r--r--s2game.desktop11
-rw-r--r--s2mviewer.desktop11
-rw-r--r--savage2.install23
7 files changed, 147 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ab81efa9416
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = savage2
+ pkgdesc = Savage 2 is a fantasy themed action RPG, that combines elements of FPS and RTS.
+ pkgver = 2.1.0
+ pkgrel = 3
+ url = http://savage2.com/en/main.php
+ install = savage2.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = unzip
+ depends = mesa
+ depends = libjpeg
+ depends = libjpeg6
+ depends = libxml2
+ source = http://savage.s2galactica.com/Savage2Install-2.1.0-.bin
+ source = s2game.desktop
+ source = s2editor.desktop
+ source = s2mviewer.desktop
+ md5sums = 85b76a8e1ab22f147bb6eef98465c0ba
+ md5sums = e599528405e47b699cdf8ca5ea09be6e
+ md5sums = 0b1bcd48feb45e5e155d2cdcedc18a2d
+ md5sums = 74703e46ace651f5a668568b5f7b1ea0
+
+pkgname = savage2
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e4f398dc5b3a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+*.pkg.tar.xz
+*.pkg.tar
+*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..860ddc491894
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Ali H. Caliskan <ali.h.caliskan@gmail.com>
+# Contributor: Slash <demodevil5[at]yahoo[dot]com>
+# Contributor: Xavier <shiningxc[at]gmail[dot]com>
+
+pkgname=savage2
+pkgver=2.1.0
+pkgrel=3
+pkgdesc="Savage 2 is a fantasy themed action RPG, that combines elements of FPS and RTS."
+arch=('i686' 'x86_64')
+url="http://savage2.com/en/main.php"
+license=('custom')
+depends=('mesa' 'libjpeg' 'libjpeg6' 'libxml2')
+makedepends=('unzip')
+install=('savage2.install')
+source=("http://savage.s2galactica.com/Savage2Install-$pkgver-$CARCH.bin"
+ 's2game.desktop'
+ 's2editor.desktop'
+ 's2mviewer.desktop')
+md5sums=('85b76a8e1ab22f147bb6eef98465c0ba'
+ 'e599528405e47b699cdf8ca5ea09be6e'
+ '0b1bcd48feb45e5e155d2cdcedc18a2d'
+ '74703e46ace651f5a668568b5f7b1ea0')
+[ "$CARCH" = "x86_64" ] && md5sums[0]='134814532db8a7aadc0ec56def5e924c'
+
+build() {
+
+ cd $srcdir/
+
+ # Extract the binary file
+ unzip -q -o Savage2Install-$pkgver-$CARCH.bin
+
+ # Install Savage2
+ install -d $pkgdir/opt/Savage2
+ cp -r data/* $pkgdir/opt/Savage2
+
+ # Install Desktop Files
+ install -d $pkgdir/usr/share/applications
+ install -Dm644 *.desktop $pkgdir/usr/share/applications/
+
+ # Install Icon and License
+ install -Dm644 data/s2icon.png $pkgdir/usr/share/pixmaps/s2icon.png
+ install -Dm644 data/license.txt $pkgdir/usr/share/licenses/$pkgname/license.txt
+
+ # Install Launcher Script
+ mkdir -p $pkgdir/usr/bin
+ cat > $pkgdir/usr/bin/savage2 << "EOF"
+#!/bin/bash
+
+cd /opt/Savage2
+./savage2.bin
+EOF
+
+ chmod 755 $pkgdir/usr/bin/savage2
+
+ # Set group permission to root:games
+ chown -R root:games $pkgdir/opt/Savage2
+
+ # Set permission to 4755
+ chmod 4755 $pkgdir/opt/Savage2/savage2.bin
+ chmod 4755 $pkgdir/opt/Savage2/savage2_update.bin
+}
diff --git a/s2editor.desktop b/s2editor.desktop
new file mode 100644
index 000000000000..6d64e6cb7db2
--- /dev/null
+++ b/s2editor.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Version=1.0
+Type=Application
+Name=Savage 2 Editor
+GenericName=Map Editor
+Comment=Map editor for Savage 2 - A Tortured Soul
+Icon=/usr/share/pixmaps/s2icon.png
+Exec=/opt/Savage2/savage2.bin "PushMod editor; Set host_autoExec StartClient"
+Categories=Game
+
diff --git a/s2game.desktop b/s2game.desktop
new file mode 100644
index 000000000000..c6d9a3238a28
--- /dev/null
+++ b/s2game.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Version=1.0
+Type=Application
+Name=Savage 2
+GenericName=Multiplayer Game
+Comment=Savage 2 - A Tortured Soul
+Icon=/usr/share/pixmaps/s2icon.png
+Exec=/usr/bin/savage2
+Categories=Game
+
diff --git a/s2mviewer.desktop b/s2mviewer.desktop
new file mode 100644
index 000000000000..85b2efe47c22
--- /dev/null
+++ b/s2mviewer.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Version=1.0
+Type=Application
+Name=Savage 2 Model Viewer
+GenericName=Model Viewer
+Comment=Model viewer for Savage 2 - A Tortured Soul
+Icon=/usr/share/pixmaps/s2icon.png
+Exec=/opt/Savage2/savage2.bin "PushMod modelviewer; Set host_autoExec StartClient"
+Categories=Game
+
diff --git a/savage2.install b/savage2.install
new file mode 100644
index 000000000000..06262eea850a
--- /dev/null
+++ b/savage2.install
@@ -0,0 +1,23 @@
+post_install() {
+# Update runpath
+ cd /opt/Savage2
+ ./savage2_update.bin --update-runpath
+
+}
+
+post_upgrade() {
+ post_install $1
+
+}
+
+post_remove() {
+# Remove updates
+if [ -d /opt/Savage2 ]; then
+ rm -r /opt/Savage2
+fi
+
+}
+
+op=$1
+shift
+$op $*