summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--arch_poweroff_defaults.patch40
3 files changed, 53 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 831ea763b076..6e4d15233c5f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Jan 9 14:59:40 UTC 2016
+# Sun Feb 14 18:55:59 UTC 2016
pkgbase = sawfish
pkgdesc = An extensible window manager using a Lisp-based scripting language
pkgver = 1.11.90
- pkgrel = 1
+ pkgrel = 2
url = http://sawfish.wikia.com/wiki/Main_Page
install = sawfish.install
arch = i686
@@ -14,7 +14,9 @@ pkgbase = sawfish
depends = hicolor-icon-theme
options = !libtool
source = http://download.tuxfamily.org/sawfish/sawfish_1.11.90.tar.xz
+ source = arch_poweroff_defaults.patch
sha1sums = 092c088f0af8efe6fd603bd6e9b10f005615a65f
+ sha1sums = 73dbf5f93c0124c11f0254267d662f86be1f2767
pkgname = sawfish
diff --git a/PKGBUILD b/PKGBUILD
index 942063daf878..03ad61e7a001 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,16 @@
pkgname=sawfish
pkgver=1.11.90
-pkgrel=1
+pkgrel=2
pkgdesc="An extensible window manager using a Lisp-based scripting language"
arch=('i686' 'x86_64')
url="http://sawfish.wikia.com/wiki/Main_Page"
license=('GPL')
depends=('libsm' 'rep-gtk' 'hicolor-icon-theme')
install=${pkgname}.install
-source=(http://download.tuxfamily.org/${pkgname}/${pkgname}_${pkgver}.tar.xz)
-sha1sums=('092c088f0af8efe6fd603bd6e9b10f005615a65f')
+source=(http://download.tuxfamily.org/${pkgname}/${pkgname}_${pkgver}.tar.xz arch_poweroff_defaults.patch)
+sha1sums=('092c088f0af8efe6fd603bd6e9b10f005615a65f'
+ '73dbf5f93c0124c11f0254267d662f86be1f2767')
options=('!libtool')
build() {
@@ -21,6 +22,11 @@ build() {
make
}
+prepare() {
+ cd "${srcdir}/${pkgname}_${pkgver}"
+ patch -p1 < "$srcdir"/arch_poweroff_defaults.patch
+}
+
package() {
cd "${srcdir}/${pkgname}_${pkgver}"
make DESTDIR="${pkgdir}" install
diff --git a/arch_poweroff_defaults.patch b/arch_poweroff_defaults.patch
new file mode 100644
index 000000000000..a73e3b7811cb
--- /dev/null
+++ b/arch_poweroff_defaults.patch
@@ -0,0 +1,40 @@
+diff --git a/lisp/sawfish/wm/commands/poweroff.jl b/lisp/sawfish/wm/commands/poweroff.jl
+index 97b40c8..c88386f 100644
+--- a/lisp/sawfish/wm/commands/poweroff.jl
++++ b/lisp/sawfish/wm/commands/poweroff.jl
+@@ -36,22 +36,22 @@
+
+ (define-structure-alias poweroff sawfish.wm.commands.poweroff)
+
+- (defcustom reboot-command "ssd --reboot"
++ (defcustom reboot-command "systemctl reboot"
+ "The command used to reboot the computer."
+ :type string
+ :group (misc apps))
+
+- (defcustom halt-command "ssd --shutdown"
++ (defcustom halt-command "systemctl halt"
+ "The command used to halt the computer."
+ :type string
+ :group (misc apps))
+
+- (defcustom suspend-command "ssd --suspend"
++ (defcustom suspend-command "systemctl suspend"
+ "The command used to suspend the computer."
+ :type string
+ :group (misc apps))
+
+- (defcustom hibernate-command "ssd --hibernate"
++ (defcustom hibernate-command "systemctl hibernate"
+ "The command used to hibernate the computer."
+ :type string
+ :group (misc apps))
+@@ -61,7 +61,7 @@
+ :type string
+ :group (misc apps))
+
+- (defcustom lockdown-command "ssd --lockdown"
++ (defcustom lockdown-command "xscreensaver-command --lock"
+ "The command used to lockdown the display."
+ :type string
+ :group (misc apps))