summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
-rw-r--r--arch_poweroff_defaults.patch40
3 files changed, 56 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd0996612b94..b6ed9dcb48fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Feb 6 19:13:18 UTC 2016
+# Sun Feb 14 19:03:10 UTC 2016
pkgbase = sawfish-git
pkgdesc = A window manager extensible using a Lisp-based scripting language.
pkgver = 1.11.90.6.gba51040
- pkgrel = 1
+ pkgrel = 2
url = http://sawfish.wikia.com
install = sawfish.install
arch = i686
@@ -23,7 +23,9 @@ pkgbase = sawfish-git
conflicts = sawfish
options = !libtool
source = git://github.com/SawfishWM/sawfish.git
- md5sums = SKIP
+ source = arch_poweroff_defaults.patch
+ sha1sums = SKIP
+ sha1sums = 73dbf5f93c0124c11f0254267d662f86be1f2767
pkgname = sawfish-git
diff --git a/PKGBUILD b/PKGBUILD
index 12d1aba8170e..aacacfafc1e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=sawfish-git
pkgver=1.11.90.6.gba51040
-pkgrel=1
+pkgrel=2
pkgdesc='A window manager extensible using a Lisp-based scripting language.'
arch=('i686' 'x86_64')
url='http://sawfish.wikia.com'
@@ -14,18 +14,23 @@ optdepends=('emacs: for using sawfish.el')
provides=('sawfish=1.11')
conflicts=('sawfish')
install=sawfish.install
-source=('git://github.com/SawfishWM/sawfish.git')
+source=('git://github.com/SawfishWM/sawfish.git' arch_poweroff_defaults.patch)
options=('!libtool')
-md5sums=('SKIP')
+sha1sums=('SKIP' '73dbf5f93c0124c11f0254267d662f86be1f2767')
_gitname=sawfish
pkgver() {
- cd $_gitname
+ cd "$_gitname"
git describe --tags|sed 's/-/./g'|cut -c9-
}
+prepare() {
+ cd "$_gitname"
+ patch -p1 < "$srcdir"/arch_poweroff_defaults.patch
+}
+
build() {
- cd $_gitname
+ cd "$_gitname"
./autogen.sh
./configure --prefix=/usr --with-nls
make
@@ -33,7 +38,7 @@ build() {
}
package() {
- cd $_gitname
+ cd "$_gitname"
make DESTDIR="$pkgdir" install
install -Dm644 sawfish.el $pkgdir/usr/share/emacs/site-lisp/sawfish.el
install -Dm644 sawfish.elc $pkgdir/usr/share/emacs/site-lisp/sawfish.elc
diff --git a/arch_poweroff_defaults.patch b/arch_poweroff_defaults.patch
new file mode 100644
index 000000000000..a73e3b7811cb
--- /dev/null
+++ b/arch_poweroff_defaults.patch
@@ -0,0 +1,40 @@
+diff --git a/lisp/sawfish/wm/commands/poweroff.jl b/lisp/sawfish/wm/commands/poweroff.jl
+index 97b40c8..c88386f 100644
+--- a/lisp/sawfish/wm/commands/poweroff.jl
++++ b/lisp/sawfish/wm/commands/poweroff.jl
+@@ -36,22 +36,22 @@
+
+ (define-structure-alias poweroff sawfish.wm.commands.poweroff)
+
+- (defcustom reboot-command "ssd --reboot"
++ (defcustom reboot-command "systemctl reboot"
+ "The command used to reboot the computer."
+ :type string
+ :group (misc apps))
+
+- (defcustom halt-command "ssd --shutdown"
++ (defcustom halt-command "systemctl halt"
+ "The command used to halt the computer."
+ :type string
+ :group (misc apps))
+
+- (defcustom suspend-command "ssd --suspend"
++ (defcustom suspend-command "systemctl suspend"
+ "The command used to suspend the computer."
+ :type string
+ :group (misc apps))
+
+- (defcustom hibernate-command "ssd --hibernate"
++ (defcustom hibernate-command "systemctl hibernate"
+ "The command used to hibernate the computer."
+ :type string
+ :group (misc apps))
+@@ -61,7 +61,7 @@
+ :type string
+ :group (misc apps))
+
+- (defcustom lockdown-command "ssd --lockdown"
++ (defcustom lockdown-command "xscreensaver-command --lock"
+ "The command used to lockdown the display."
+ :type string
+ :group (misc apps))