summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD25
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27e43ebb7c6e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = scantools
+ pkgdesc = scantools is a library and a matching set of command line applications for graphics manipulation, written with a view towards the handling of scanned documents and generation of high-quality PDF files.
+ pkgver = 0.6.4
+ pkgrel = 1
+ url = https://cplx.vm.uni-freiburg.de/scantools/
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = doxygen
+ makedepends = gcc
+ makedepends = git
+ makedepends = graphviz
+ makedepends = jbig2dec
+ makedepends = libjpeg-turbo
+ makedepends = libtiff
+ makedepends = openjpeg2
+ makedepends = tesseract
+ makedepends = qpdf
+ makedepends = qt5-base
+ makedepends = zlib
+ depends = qt5-imageformats
+ source = https://gitlab.com/kebekus/scantools/-/archive/0.6.4/scantools-0.6.4.tar.gz
+ sha256sums = 154b9c4da5f4d08bdaac5bf740f07fcb20e19028fd0c429d85636cbba7ed4071
+
+pkgname = scantools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26822f3d73c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Tobias Bachmann <tobachmann@gmx.de>
+pkgname=scantools
+pkgver=0.6.4
+pkgrel=1
+pkgdesc="scantools is a library and a matching set of command line applications for graphics manipulation, written with a view towards the handling of scanned documents and generation of high-quality PDF files."
+arch=('x86_64')
+url="https://cplx.vm.uni-freiburg.de/scantools/"
+license=('GPL')
+depends=('qt5-imageformats')
+makedepends=('cmake' 'doxygen' 'gcc' 'git' 'graphviz' 'jbig2dec' 'libjpeg-turbo' 'libtiff' 'openjpeg2' 'tesseract' 'qpdf' 'qt5-base' 'zlib')
+source=("https://gitlab.com/kebekus/scantools/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('154b9c4da5f4d08bdaac5bf740f07fcb20e19028fd0c429d85636cbba7ed4071')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ mkdir build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=release -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=/usr/lib ../src
+ make -j $(nproc)
+}
+
+package() {
+ cd ${pkgname}-${pkgver}/build
+ make DESTDIR="${pkgdir}/" install
+}