summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD35
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db400307733f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = scap-workbench-git
+ pkgdesc = Security Content Automation Protocol GUI
+ pkgver = 1.2.1.r67.10c1929
+ pkgrel = 1
+ url = https://www.open-scap.org/tools/scap-workbench/
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = asciidoc
+ depends = openscap
+ depends = openssh
+ depends = qt5-base
+ depends = qt5-xmlpatterns
+ depends = scap-security-guide
+ provides = scap-workbench
+ conflicts = scap-workbench
+ source = git+https://github.com/OpenSCAP/scap-workbench.git
+ sha256sums = SKIP
+
+pkgname = scap-workbench-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..abe926fa83fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Alex Henrie <alexhenrie24@gmail.com>
+pkgname=scap-workbench-git
+pkgver=1.2.1.r67.10c1929
+pkgrel=1
+pkgdesc='Security Content Automation Protocol GUI'
+arch=('x86_64')
+url='https://www.open-scap.org/tools/scap-workbench/'
+license=('BSD')
+depends=('asciidoc' 'openscap' 'openssh' 'qt5-base' 'qt5-xmlpatterns' 'scap-security-guide')
+makedepends=('git')
+provides=('scap-workbench')
+conflicts=('scap-workbench')
+source=('git+https://github.com/OpenSCAP/scap-workbench.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd scap-workbench
+ printf "%s" "$(git describe --tags --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd scap-workbench
+ mkdir -p build
+ cd build
+ cmake \
+ --install-prefix=/usr \
+ -DCMAKE_CXX_FLAGS='-std=c++11 -Wno-error=c++20-compat -Wno-error=range-loop-construct -Wno-error=deprecated-declarations' \
+ ..
+ make
+}
+
+package() {
+ cd scap-workbench/build
+ make DESTDIR="$pkgdir/" install
+}