summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD31
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f5e84c2ae515
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Fri Dec 16 13:41:12 UTC 2016
+pkgbase = scenic-git
+ pkgdesc = wallpaper browser/cycler for fluxbox, etc, and batch image-processing frontend for CLI programs such as feh and imagemagick
+ pkgver = r23.599d0a6
+ pkgrel = 2
+ url = https://github.com/balinbob/scenic
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python2
+ depends = gtk2
+ depends = pygtk
+ depends = python2-keybinder2
+ depends = python2-gobject
+ depends = python2-dbus
+ optdepends = feh
+ optdepends = imagemagick
+ options = !emptydirs
+ source = git+https://github.com/balinbob/scenic
+ md5sums = SKIP
+
+pkgname = scenic-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6313e9f88740
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Bob Allred <balinbob@gmail.com>
+pkgname=scenic-git
+pkgver=r23.599d0a6
+pkgrel=2
+pkgdesc="wallpaper browser/cycler for fluxbox, etc, and batch image-processing frontend for CLI programs such as feh and imagemagick"
+arch=('any')
+url="https://github.com/balinbob/scenic"
+license=('GPL3')
+depends=('python2' 'gtk2' 'pygtk' 'python2-keybinder2' 'python2-gobject' 'python2-dbus')
+makedepends=('git')
+optdepends=('feh' 'imagemagick')
+options=(!emptydirs)
+source=('git+https://github.com/balinbob/scenic')
+_gitname='scenic'
+md5sums=('SKIP')
+pkgver () {
+ cd "${srcdir}/${_gitname}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+package() {
+ cd "$srcdir/$pkgname"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "resources/scenic-folder.svg" "$pkgdir/usr/share/${pkgname}/scenic-folder.svg"
+}
+
+# vim:set ts=2 sw=2 et:
+