summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--Makefile23
-rwxr-xr-xPKGBUILD4
3 files changed, 27 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2452298dc158..17cad431c9e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = scid_vs_pc
pkgdesc = Shane's Chess Information Database
pkgver = 4.20
- pkgrel = 1
+ pkgrel = 2
url = http://scidvspc.sourceforge.net/
install = scid_vs_pc.install
arch = i686
arch = x86_64
license = GPL2
depends = zlib
+ depends = tk
optdepends = snack
optdepends = tdom
conflicts = scid
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..d98ad5acca65
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,23 @@
+nam = $(shell sed -n 's/^pkgname=//p' PKGBUILD)
+src = PKGBUILD
+inf = .SRCINFO
+pkg = $(shell ls -v $(nam)*.pkg.tar* 2>/dev/null | tail -1)
+
+all: sum $(inf) check
+
+$(inf): $(src)
+ makepkg --printsrcinfo >$@
+
+check: $(src)
+ namcap $^
+ifneq ($(strip $(pkg)),)
+ namcap $(pkg)
+endif
+
+sum: $(src)
+ updpkgsums
+
+clean:
+ rm -rf $(inf) $(nam)-* *.tar.xz *.tar.gz pkg/ src/ *.part
+
+# vim: se ts=4:
diff --git a/PKGBUILD b/PKGBUILD
index 225dd6a0ff44..33b73cc82899 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=scid_vs_pc
pkgver=4.20
-pkgrel=1
+pkgrel=2
pkgdesc="Shane's Chess Information Database"
arch=('i686' 'x86_64')
url="http://scidvspc.sourceforge.net/"
license=('GPL2')
-depends=('zlib')
+depends=('zlib' 'tk')
optdepends=('snack' 'tdom')
install=$pkgname.install
conflicts=('scid')