summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD16
-rw-r--r--patch-2.0.10 (renamed from future_absolute.patch)80
-rw-r--r--sip_error.patch83
4 files changed, 84 insertions, 110 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4693249f4512..377402b89500 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = scidavis-qt5
pkgdesc = Application for Scientific Data Analysis and Visualization, fork of QtiPlot. Qt5 port
- pkgver = 1.26
- pkgrel = 3
+ pkgver = 2.0.10
+ pkgrel = 1
url = http://scidavis.sourceforge.net/
arch = x86_64
license = GPL
makedepends = boost
makedepends = cmake
makedepends = qt5-tools
- makedepends = sip
- makedepends = python-sip
+ makedepends = classdesc>=3.37
depends = gsl
depends = glu
depends = mesa
@@ -21,10 +20,10 @@ pkgbase = scidavis-qt5
depends = qwtplot3d-qt5
depends = python-pyqt5
conflicts = scidavis
- source = scidavis-1.26.zip::https://github.com/highperformancecoder/scidavis/archive/1.26.zip
- source = sip_error.patch
- sha512sums = c4ccd9ace46eeef5a184ea93bb48b338d6ae50cb06db33a95420370da3e5b9ff3b268e4f9da6d60c9b0c64dcc300cb46b4b9275736869cad039f74f4eee68211
- sha512sums = 8a57006842e416751d5f6ca6128ecdbba632e88c57f4b2dcb1558626f815c0682eff771697a068f5cbc583f588c6a41eab7bdc3c82f294cbafed1ce1cb04368e
+ source = scidavis-2.0.10.zip::https://github.com/highperformancecoder/scidavis/archive/2.0.10.zip
+ source = patch-2.0.10
+ sha512sums = b2f9c86c079ac72585f95ae1ced93b9e6be9e8fd0e84a43106b1a4f1138335d1f04424131fb8bf58585d4645b76e3b919da2221ec039385ad6a0ccce56c02db1
+ sha512sums = f9ae2f099cdead27f73222a5e6d72217e36d10fcd1f4edb6f23f9844b1a962d25ec873d1d676165ad4e45a550d0b65511246f4302c70a28ac2d3d12760df9eb4
pkgname = scidavis-qt5
diff --git a/PKGBUILD b/PKGBUILD
index 61e102b489f5..c08ed3b727ec 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,27 +9,27 @@
_pkgname=scidavis
pkgname=scidavis-qt5
-pkgver=1.26
-_commit=1.26
-pkgrel=3
+pkgver=2.0.10
+_commit=2.0.10
+pkgrel=1
pkgdesc="Application for Scientific Data Analysis and Visualization, fork of QtiPlot. Qt5 port"
arch=('x86_64')
url="http://scidavis.sourceforge.net/"
license=('GPL')
-makedepends=('boost' 'cmake' 'qt5-tools' 'sip' 'python-sip')
+makedepends=('boost' 'cmake' 'qt5-tools' 'classdesc>=3.37')
depends=('gsl' 'glu' 'mesa' 'muparser' 'shared-mime-info'
'desktop-file-utils' 'hicolor-icon-theme'
'qwt5-qt5' 'qwtplot3d-qt5'
'python-pyqt5')
conflicts=('scidavis')
source=("${_pkgname}-${pkgver}.zip::https://github.com/highperformancecoder/scidavis/archive/${_commit}.zip"
-'sip_error.patch')
-sha512sums=('c4ccd9ace46eeef5a184ea93bb48b338d6ae50cb06db33a95420370da3e5b9ff3b268e4f9da6d60c9b0c64dcc300cb46b4b9275736869cad039f74f4eee68211'
- '8a57006842e416751d5f6ca6128ecdbba632e88c57f4b2dcb1558626f815c0682eff771697a068f5cbc583f588c6a41eab7bdc3c82f294cbafed1ce1cb04368e')
+'patch-2.0.10')
+sha512sums=('b2f9c86c079ac72585f95ae1ced93b9e6be9e8fd0e84a43106b1a4f1138335d1f04424131fb8bf58585d4645b76e3b919da2221ec039385ad6a0ccce56c02db1'
+ 'f9ae2f099cdead27f73222a5e6d72217e36d10fcd1f4edb6f23f9844b1a962d25ec873d1d676165ad4e45a550d0b65511246f4302c70a28ac2d3d12760df9eb4')
prepare() {
cd "${_pkgname}-${_commit}"
- patch --forward --strip=1 --input="${srcdir}/sip_error.patch"
+ patch --forward --strip=1 --input="${srcdir}/patch-2.0.10"
}
build() {
diff --git a/future_absolute.patch b/patch-2.0.10
index af1ec4f39e8a..c6430b1e7a42 100644
--- a/future_absolute.patch
+++ b/patch-2.0.10
@@ -1,7 +1,37 @@
-diff -u10 -r scidavis-0f3383dc57bc9b756a65d90e88da91952eeb6173-orig/libscidavis/src/ApplicationWindow.cpp scidavis-0f3383dc57bc9b756a65d90e88da91952eeb6173/libscidavis/src/ApplicationWindow.cpp
---- scidavis-0f3383dc57bc9b756a65d90e88da91952eeb6173-orig/libscidavis/src/ApplicationWindow.cpp 2019-08-25 03:42:25.000000000 +0200
-+++ scidavis-0f3383dc57bc9b756a65d90e88da91952eeb6173/libscidavis/src/ApplicationWindow.cpp 2019-09-23 10:56:20.353098330 +0200
-@@ -2599,21 +2599,21 @@
+diff --git a/config.pri b/config.pri
+index 48273f9e..28d46105 100644
+--- a/config.pri
++++ b/config.pri
+@@ -327,23 +327,21 @@ contains(PRESET, linux_package) {
+ }
+ }
+
+ system (ls /usr/lib*/libqwtplot3d-qt4.so) {
+ LIBS+=-lqwtplot3d-qt4
+ } else {
+ LIBS+=-lqwtplot3d
+ }
+ }
+
+- INCLUDEPATH = "$(HOME)/usr/include" $$INCLUDEPATH
+- QMAKE_LIBDIR = "$(HOME)/usr/lib" $$QMAKE_LIBDIR
+-
++ INCLUDEPATH = "/usr/include/classdesc" $$INCLUDEPATH
+
+ LIBS += -lz -lGLU
+
+ INCLUDEPATH += /usr/include/muParser
+ LIBS += -lgsl -lgslcblas
+ LIBS += -lmuparser
+
+ # disable this warning because StringList has a user defined constructor, but hasn't bother to declare an assignment operator
+ QMAKE_CXXFLAGS+="-Wno-deprecated-copy"
+
+diff --git a/libscidavis/src/ApplicationWindow.cpp b/libscidavis/src/ApplicationWindow.cpp
+index ccb84a07..4b60716b 100644
+--- a/libscidavis/src/ApplicationWindow.cpp
++++ b/libscidavis/src/ApplicationWindow.cpp
+@@ -2648,21 +2648,21 @@ TableStatistics *ApplicationWindow::newTableStatistics(Table *base, int type, QL
connect(base, SIGNAL(modifiedData(Table*,const QString&)), s, SLOT(update(Table*,const QString&)));
connect(base, SIGNAL(changedColHeader(const QString&, const QString&)), s, SLOT(renameCol(const QString&, const QString&)));
connect(base, SIGNAL(removedCol(const QString&)), s, SLOT(removeCol(const QString&)));
@@ -24,7 +54,7 @@ diff -u10 -r scidavis-0f3383dc57bc9b756a65d90e88da91952eeb6173-orig/libscidavis/
if (!table) continue;
if (table_stat->base() == table)
d_project->removeChild(table_stat->d_future_table);
-@@ -13884,44 +13884,44 @@
+@@ -13977,44 +13977,44 @@ void ApplicationWindow::selectPlotType(int type)
if (ml) {
Graph *g = ml->activeGraph();
if(g->curves() > 0)
@@ -73,7 +103,7 @@ diff -u10 -r scidavis-0f3383dc57bc9b756a65d90e88da91952eeb6173-orig/libscidavis/
void ApplicationWindow::showHistory()
{
if (!d_project->undoStack()) return;
-@@ -13942,16 +13942,16 @@
+@@ -14035,16 +14035,16 @@ void ApplicationWindow::showHistory()
dialog.setWindowTitle(tr("Undo/Redo History"));
if (dialog.exec() == QDialog::Accepted)
@@ -88,12 +118,13 @@ diff -u10 -r scidavis-0f3383dc57bc9b756a65d90e88da91952eeb6173-orig/libscidavis/
+ QList<AbstractAspect *> tables = d_project->descendantsThatInherit("::future::Table");
QStringList result;
foreach(AbstractAspect *aspect, tables)
- result.append(aspect->name());
+ result.append(aspect->name().c_str());
return result;
}
-diff -u10 -r scidavis-0f3383dc57bc9b756a65d90e88da91952eeb6173-orig/libscidavis/src/future/core/Project.h scidavis-0f3383dc57bc9b756a65d90e88da91952eeb6173/libscidavis/src/future/core/Project.h
---- scidavis-0f3383dc57bc9b756a65d90e88da91952eeb6173-orig/libscidavis/src/future/core/Project.h 2019-08-25 03:42:25.000000000 +0200
-+++ scidavis-0f3383dc57bc9b756a65d90e88da91952eeb6173/libscidavis/src/future/core/Project.h 2019-09-23 10:56:20.353098330 +0200
+diff --git a/libscidavis/src/future/core/Project.h b/libscidavis/src/future/core/Project.h
+index 985e8c37..d0ef2e68 100644
+--- a/libscidavis/src/future/core/Project.h
++++ b/libscidavis/src/future/core/Project.h
@@ -36,21 +36,21 @@
class QString;
class ProjectWindow;
@@ -117,7 +148,7 @@ diff -u10 -r scidavis-0f3383dc57bc9b756a65d90e88da91952eeb6173-orig/libscidavis/
folderOnly,
folderAndSubfolders,
allMdiWindows
-@@ -66,21 +66,21 @@
+@@ -66,21 +66,21 @@ class Project : public future::Folder
virtual Project *project() { return this; }
virtual QUndoStack *undoStack() const;
virtual QString path() const { return ""; }
@@ -140,3 +171,30 @@ diff -u10 -r scidavis-0f3383dc57bc9b756a65d90e88da91952eeb6173-orig/libscidavis/
static ConfigPageWidget * makeConfigPage();
static QString configPageLabel();
+diff --git a/scidavis/scidavis.pro b/scidavis/scidavis.pro
+index 2e642cab..abfbef17 100644
+--- a/scidavis/scidavis.pro
++++ b/scidavis/scidavis.pro
+@@ -10,21 +10,21 @@ POST_TARGETDEPS=../libscidavis/libscidavis.a
+
+ include(../config.pri)
+ include( basic.pri )
+ python {
+ PYTHONBIN = $$(PYTHON)
+ isEmpty( PYTHONBIN ) {
+ PYTHONBIN = python3
+ }
+ unix: {
+ LIBS+=$$system($$PYTHONBIN findBoostPythonLib.py)
+- LIBS+=$$system($$PYTHONBIN-config --ldflags)
++ LIBS+=$$system($$PYTHONBIN-config --libs --embed)
+ }
+ message($$LIBS)
+
+ compiledScidavisrc.target = scidavisrc.pyc
+ compiledScidavisrc.depends = scidavisrc.py
+ compiledScidavisrc.commands = $$PYTHONBIN -m py_compile scidavisrc.py
+ compiledScidavisUtil.target = scidavisUtil.pyc
+ compiledScidavisUtil.depends = scidavisUtil.py
+ compiledScidavisUtil.commands = $$PYTHONBIN -m py_compile scidavisUtil.py
+ QMAKE_EXTRA_TARGETS += compiledScidavisrc compiledScidavisUtil
diff --git a/sip_error.patch b/sip_error.patch
deleted file mode 100644
index 397d04f1ecf7..000000000000
--- a/sip_error.patch
+++ /dev/null
@@ -1,83 +0,0 @@
-diff -u10 -r scidavis-1.26.old/libscidavis/python-sipcmd.py scidavis-1.26.new/libscidavis/python-sipcmd.py
---- scidavis-1.26.old/libscidavis/python-sipcmd.py 2019-12-06 07:14:18.000000000 +0100
-+++ scidavis-1.26.new/libscidavis/python-sipcmd.py 2020-01-29 14:00:22.190518028 +0100
-@@ -19,37 +19,48 @@
- # GNU General Public License for more details. #
- # #
- # You should have received a copy of the GNU General Public License #
- # along with this program; if not, write to the Free Software #
- # Foundation, Inc., 51 Franklin Street, Fifth Floor, #
- # Boston, MA 02110-1301 USA #
- # #
- ############################################################################
-
-
-+import os
-+import warnings
- import sys, sipconfig
- config = sipconfig.Configuration()
-
- try:
- pyqt = sys.argv[1]
- except IndexError:
- pyqt = 'PyQt4'
-
- if (pyqt not in ['PyQt4','PyQt5']):
- pyqt = 'PyQt4'
-
- try:
- exec("from "+pyqt+".QtCore import PYQT_CONFIGURATION")
- except ImportError:
- pass
-
- sipBin = config.sip_bin
- sipDir = config.default_sip_dir+'/'+pyqt
-+if sys.version_info[0] >= 3 and sys.version_info[1] >= 7 and pyqt == 'PyQt5':
-+ from importlib.metadata import distribution
-+ dist = distribution(pyqt)
-+ sip = [p for p in dist.files if p.name == 'QtCoremod.sip']
-+ assert len(sip) == 1
-+ sipDir = str(dist.locate_file(sip[0]).parent.parent)
-+else:
-+ if not os.path.exists(sipDir):
-+ warnings.warn('sipDir does not exists, %s' % sipDir)
-
- sipFlags = PYQT_CONFIGURATION['sip_flags']
-
- flags = ["-I ../scidavis"]
- if config.sip_version >= 0x040a00:
- # make use of docstring generation feature in SIP >= 4.10
- flags.append("-o")
-
- sys.stdout.write(" ".join([sipBin, '-I', sipDir, sipFlags]+flags))
-diff -u10 -r scidavis-1.26.old/libscidavis/python.pri scidavis-1.26.new/libscidavis/python.pri
---- scidavis-1.26.old/libscidavis/python.pri 2019-12-06 07:14:18.000000000 +0100
-+++ scidavis-1.26.new/libscidavis/python.pri 2020-01-29 13:13:02.288687994 +0100
-@@ -19,22 +19,26 @@
- PYTHONBIN = $$(PYTHON)
- isEmpty( PYTHONBIN ) {
- PYTHONBIN = python
- }
-
- unix {
- INCLUDEPATH += $$system($$PYTHONBIN-config --includes|sed -e 's/-I//g')
- osx_dist {
- DEFINES += PYTHONHOME=/Applications/scidavis.app/Contents/Resources
- }
-+ SIP_FAILURE = TRUE
- system(mkdir -p $${SIP_DIR})
-- system($$system($$PYTHONBIN python-sipcmd.py PyQt$$QT_MAJOR_VERSION) $$system($$PYTHONBIN-config --includes) -c $${SIP_DIR} src/scidavis.sip)
-+ system($$system($$PYTHONBIN python-sipcmd.py PyQt$$QT_MAJOR_VERSION) $$system($$PYTHONBIN-config --includes) -c $${SIP_DIR} src/scidavis.sip): SIP_FAILURE = FALSE
-+ equals(SIP_FAILURE, "TRUE") {
-+ error(`$$PYTHONBIN python-sipcmd.py PyQt$$QT_MAJOR_VERSION` `$$PYTHONBIN-config --includes` -c $${SIP_DIR} src/scidavis.sip FAILED in $$PWD)
-+ }
- }
-
- win32 {
- mxe {
- DEFINES += SIP_STATIC_MODULE
- system($$system($$PYTHONBIN python-sipcmd.py PyQt$$QT_MAJOR_VERSION) -c $${SIP_DIR} src/scidavis.sip)
- } else {
- INCLUDEPATH += $$system(call ../python-includepath.py)
- # TODO: fix the command below (only really necessary if SIP_DIR != MOC/OBJECTS_DIR)
- system($$system(call python-sipcmd.py) -c $${SIP_DIR} src/scidavis.sip)