summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD26
-rw-r--r--patch-2.0.10200
-rw-r--r--patch-linking49
4 files changed, 75 insertions, 221 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e182a62fd3aa..ddf178b48a22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = scidavis-qt5
pkgdesc = Application for Scientific Data Analysis and Visualization, fork of QtiPlot. Qt5 port
- pkgver = 2.0.10
- pkgrel = 3
+ pkgver = 2.1.4
+ pkgrel = 1
url = http://scidavis.sourceforge.net/
arch = x86_64
license = GPL
makedepends = boost
makedepends = cmake
makedepends = qt5-tools
- makedepends = classdesc>=3.37
+ makedepends = qwt5-qt5>=5.2.3.1-2
+ makedepends = qwtplot3d-qt5>=0.2.7-3
depends = gsl
depends = glu
depends = mesa
@@ -16,16 +17,16 @@ pkgbase = scidavis-qt5
depends = shared-mime-info
depends = desktop-file-utils
depends = hicolor-icon-theme
- depends = qwt5-qt5
- depends = qwtplot3d-qt5
- depends = boost-libs
+ depends = sip
+ depends = python-sip
+ depends = python-pyqt5
depends = python
depends = python-scipy
conflicts = scidavis
- source = scidavis-2.0.10.zip::https://github.com/highperformancecoder/scidavis/archive/2.0.10.zip
- source = patch-2.0.10
- sha512sums = b2f9c86c079ac72585f95ae1ced93b9e6be9e8fd0e84a43106b1a4f1138335d1f04424131fb8bf58585d4645b76e3b919da2221ec039385ad6a0ccce56c02db1
- sha512sums = 06709b1c5f6e9e30098f1dc5471bd4276e547bd7d1b05c73a08603fd56b5b1c0b63914e51190267ce33339e025575660f6b1dc01a9536a6744f1f13bc375884a
+ source = scidavis-2.1.4.zip::https://github.com/highperformancecoder/scidavis/archive/2.1.4.zip
+ source = patch-linking
+ sha512sums = 026c8bef87573e5ea42feab62efcaefd3deeb1d74dc86cdbdec17fd28e97914e785fb70f84addc582f3326d4d3bbe25fa399e85918b720019815f7bf84e0cc51
+ sha512sums = 69f04800343935141ad224510a915a8cbdbd0e07401a61530a52e18ea5d02b85f7e579f70b6bb32b37e085c07f61a8ce3f9c83f7b7b9cfe0553624b8ff9ff5db
pkgname = scidavis-qt5
diff --git a/PKGBUILD b/PKGBUILD
index 430e4855a1fb..3d39bcece320 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,27 +9,31 @@
_pkgname=scidavis
pkgname=scidavis-qt5
-pkgver=2.0.10
-_commit=2.0.10
-pkgrel=3
+pkgver=2.1.4
+_commit=2.1.4
+pkgrel=1
pkgdesc="Application for Scientific Data Analysis and Visualization, fork of QtiPlot. Qt5 port"
arch=('x86_64')
url="http://scidavis.sourceforge.net/"
license=('GPL')
-makedepends=('boost' 'cmake' 'qt5-tools' 'classdesc>=3.37')
+makedepends=('boost' 'cmake' 'qt5-tools'
+'qwt5-qt5>=5.2.3.1-2'
+'qwtplot3d-qt5>=0.2.7-3'
+)
depends=('gsl' 'glu' 'mesa' 'muparser' 'shared-mime-info'
- 'desktop-file-utils' 'hicolor-icon-theme'
- 'qwt5-qt5' 'qwtplot3d-qt5' 'boost-libs'
- 'python' 'python-scipy')
+'desktop-file-utils' 'hicolor-icon-theme'
+'sip' 'python-sip' 'python-pyqt5'
+'python' 'python-scipy')
conflicts=('scidavis')
source=("${_pkgname}-${pkgver}.zip::https://github.com/highperformancecoder/scidavis/archive/${_commit}.zip"
-'patch-2.0.10')
-sha512sums=('b2f9c86c079ac72585f95ae1ced93b9e6be9e8fd0e84a43106b1a4f1138335d1f04424131fb8bf58585d4645b76e3b919da2221ec039385ad6a0ccce56c02db1'
- '06709b1c5f6e9e30098f1dc5471bd4276e547bd7d1b05c73a08603fd56b5b1c0b63914e51190267ce33339e025575660f6b1dc01a9536a6744f1f13bc375884a')
+'patch-linking'
+)
+sha512sums=('026c8bef87573e5ea42feab62efcaefd3deeb1d74dc86cdbdec17fd28e97914e785fb70f84addc582f3326d4d3bbe25fa399e85918b720019815f7bf84e0cc51'
+ '69f04800343935141ad224510a915a8cbdbd0e07401a61530a52e18ea5d02b85f7e579f70b6bb32b37e085c07f61a8ce3f9c83f7b7b9cfe0553624b8ff9ff5db')
prepare() {
cd "${_pkgname}-${_commit}"
- patch --forward --strip=1 --input="${srcdir}/patch-2.0.10"
+ patch --forward --strip=1 --input="${srcdir}/patch-linking"
}
build() {
diff --git a/patch-2.0.10 b/patch-2.0.10
deleted file mode 100644
index b565e682a44d..000000000000
--- a/patch-2.0.10
+++ /dev/null
@@ -1,200 +0,0 @@
-diff -u10 -r scidavis-2.0.10-original/config.pri scidavis-2.0.10/config.pri
---- scidavis-2.0.10-original/config.pri 2020-02-17 07:54:00.000000000 +0100
-+++ scidavis-2.0.10/config.pri 2020-03-07 11:25:37.598054844 +0100
-@@ -327,23 +327,21 @@
- }
- }
-
- system (ls /usr/lib*/libqwtplot3d-qt4.so) {
- LIBS+=-lqwtplot3d-qt4
- } else {
- LIBS+=-lqwtplot3d
- }
- }
-
-- INCLUDEPATH = "$(HOME)/usr/include" $$INCLUDEPATH
-- QMAKE_LIBDIR = "$(HOME)/usr/lib" $$QMAKE_LIBDIR
--
-+ INCLUDEPATH = "/usr/include/classdesc" $$INCLUDEPATH
-
- LIBS += -lz -lGLU
-
- INCLUDEPATH += /usr/include/muParser
- LIBS += -lgsl -lgslcblas
- LIBS += -lmuparser
-
- # disable this warning because StringList has a user defined constructor, but hasn't bother to declare an assignment operator
- QMAKE_CXXFLAGS+="-Wno-deprecated-copy"
-
-diff -u10 -r scidavis-2.0.10-original/libscidavis/src/ApplicationWindow.cpp scidavis-2.0.10/libscidavis/src/ApplicationWindow.cpp
---- scidavis-2.0.10-original/libscidavis/src/ApplicationWindow.cpp 2020-02-17 07:54:00.000000000 +0100
-+++ scidavis-2.0.10/libscidavis/src/ApplicationWindow.cpp 2020-03-07 11:25:37.602054850 +0100
-@@ -2648,21 +2648,21 @@
- connect(base, SIGNAL(modifiedData(Table*,const QString&)), s, SLOT(update(Table*,const QString&)));
- connect(base, SIGNAL(changedColHeader(const QString&, const QString&)), s, SLOT(renameCol(const QString&, const QString&)));
- connect(base, SIGNAL(removedCol(const QString&)), s, SLOT(removeCol(const QString&)));
- connect(base->d_future_table, SIGNAL(aspectAboutToBeRemoved(const AbstractAspect *)),
- this, SLOT(removeDependentTableStatistics(const AbstractAspect *)));
- return s;
- }
-
- void ApplicationWindow::removeDependentTableStatistics(const AbstractAspect *aspect)
- {
-- future::Table *future_table = qobject_cast<future::Table *>(const_cast<AbstractAspect *>(aspect));
-+ ::future::Table *future_table = qobject_cast<::future::Table *>(const_cast<AbstractAspect *>(aspect));
- if (!future_table) return;
- QList<MyWidget*> windows = windowsList();
- foreach(MyWidget *win, windows)
- {
- TableStatistics *table_stat = qobject_cast<TableStatistics *>(win);
- if (!table_stat) continue;
- Table *table = qobject_cast<Table *>(future_table->view());
- if (!table) continue;
- if (table_stat->base() == table)
- d_project->removeChild(table_stat->d_future_table);
-@@ -13977,44 +13977,44 @@
- if (ml) {
- Graph *g = ml->activeGraph();
- if(g->curves() > 0)
- g->setCurveType(g->curves()-1, (Graph::CurveType)type);
- }
- }
-
- void ApplicationWindow::handleAspectAdded(const AbstractAspect *parent, int index)
- {
- AbstractAspect * aspect = parent->child(index);
-- future::Matrix * matrix = qobject_cast<future::Matrix *>(aspect);
-+ ::future::Matrix * matrix = qobject_cast<::future::Matrix *>(aspect);
- if (matrix)
- {
- initMatrix(static_cast<Matrix *>(matrix->view()));
- return;
- }
-- future::Table * table = qobject_cast<future::Table *>(aspect);
-+ ::future::Table * table = qobject_cast<::future::Table *>(aspect);
- if (table)
- {
- initTable(static_cast<Table *>(table->view()));
- return;
- }
- }
-
- void ApplicationWindow::handleAspectAboutToBeRemoved(const AbstractAspect *parent, int index)
- {
- AbstractAspect * aspect = parent->child(index);
-- future::Matrix * matrix = qobject_cast<future::Matrix *>(aspect);
-+ ::future::Matrix * matrix = qobject_cast<::future::Matrix *>(aspect);
- if (matrix)
- {
- closeWindow(static_cast<Matrix *>(matrix->view()));
- return;
- }
-- future::Table * table = qobject_cast<future::Table *>(aspect);
-+ ::future::Table * table = qobject_cast<::future::Table *>(aspect);
- if (table)
- {
- closeWindow(static_cast<Table *>(table->view()));
- return;
- }
- }
-
- void ApplicationWindow::showHistory()
- {
- if (!d_project->undoStack()) return;
-@@ -14035,16 +14035,16 @@
-
- dialog.setWindowTitle(tr("Undo/Redo History"));
- if (dialog.exec() == QDialog::Accepted)
- return;
-
- d_project->undoStack()->setIndex(index);
- }
-
- QStringList ApplicationWindow::tableWindows()
- {
-- QList<AbstractAspect *> tables = d_project->descendantsThatInherit("future::Table");
-+ QList<AbstractAspect *> tables = d_project->descendantsThatInherit("future::Table");
- QStringList result;
- foreach(AbstractAspect *aspect, tables)
- result.append(aspect->name().c_str());
- return result;
- }
-diff -u10 -r scidavis-2.0.10-original/libscidavis/src/future/core/Project.h scidavis-2.0.10/libscidavis/src/future/core/Project.h
---- scidavis-2.0.10-original/libscidavis/src/future/core/Project.h 2020-02-17 07:54:00.000000000 +0100
-+++ scidavis-2.0.10/libscidavis/src/future/core/Project.h 2020-03-07 11:25:37.602054850 +0100
-@@ -36,21 +36,21 @@
- class QString;
- class ProjectWindow;
- class QAction;
- class AbstractScriptingEngine;
-
- //! Represents a SciDAVis project.
- /**
- * Project manages an undo stack and is responsible for creating ProjectWindow instances
- * as views on itself.
- */
--class Project : public future::Folder
-+class Project : public ::future::Folder
- {
- Q_OBJECT
-
- public:
- //! MDI subwindow visibility setting
- enum MdiWindowVisibility
- {
- folderOnly,
- folderAndSubfolders,
- allMdiWindows
-@@ -66,21 +66,21 @@
- virtual Project *project() { return this; }
- virtual QUndoStack *undoStack() const;
- virtual QString path() const { return ""; }
- #ifndef LEGACY_CODE_0_2_x
- virtual ProjectWindow *view();
- #else
- virtual void *view();
- #endif
- virtual QMenu *createContextMenu() const;
- //@}
-- virtual QMenu *createFolderContextMenu(const future::Folder * folder) const;
-+ virtual QMenu *createFolderContextMenu(const ::future::Folder * folder) const;
-
- AbstractScriptingEngine * scriptingEngine() const;
-
- void setMdiWindowVisibility(MdiWindowVisibility visibility);
- MdiWindowVisibility mdiWindowVisibility() const;
- void setFileName(const QString & file_name);
- QString fileName() const;
-
- static ConfigPageWidget * makeConfigPage();
- static QString configPageLabel();
-diff -u10 -r scidavis-2.0.10-original/scidavis/scidavis.pro scidavis-2.0.10/scidavis/scidavis.pro
---- scidavis-2.0.10-original/scidavis/scidavis.pro 2020-02-17 07:54:00.000000000 +0100
-+++ scidavis-2.0.10/scidavis/scidavis.pro 2020-03-07 11:27:31.630929748 +0100
-@@ -10,21 +10,25 @@
-
- include(../config.pri)
- include( basic.pri )
- python {
- PYTHONBIN = $$(PYTHON)
- isEmpty( PYTHONBIN ) {
- PYTHONBIN = python3
- }
- unix: {
- LIBS+=$$system($$PYTHONBIN findBoostPythonLib.py)
-- LIBS+=$$system($$PYTHONBIN-config --ldflags)
-+ system($$PYTHONBIN-config --embed) {
-+ LIBS+=$$system($$PYTHONBIN-config --libs --embed)
-+ } else {
-+ LIBS+=$$system($$PYTHONBIN-config --libs)
-+ }
- }
- message($$LIBS)
-
- compiledScidavisrc.target = scidavisrc.pyc
- compiledScidavisrc.depends = scidavisrc.py
- compiledScidavisrc.commands = $$PYTHONBIN -m py_compile scidavisrc.py
- compiledScidavisUtil.target = scidavisUtil.pyc
- compiledScidavisUtil.depends = scidavisUtil.py
- compiledScidavisUtil.commands = $$PYTHONBIN -m py_compile scidavisUtil.py
- QMAKE_EXTRA_TARGETS += compiledScidavisrc compiledScidavisUtil
diff --git a/patch-linking b/patch-linking
new file mode 100644
index 000000000000..fe97ba0ca66b
--- /dev/null
+++ b/patch-linking
@@ -0,0 +1,49 @@
+Only in scidavis-2.1.4a: .qmake.stash
+Only in scidavis-2.1.4a/3rdparty/liborigin: Makefile
+Only in scidavis-2.1.4a/3rdparty/liborigin: OriginFile.o
+Only in scidavis-2.1.4a/3rdparty/liborigin: OriginParser.o
+Only in scidavis-2.1.4a: Makefile
+diff -r -u10 scidavis-2.1.4/config.pri scidavis-2.1.4a/config.pri
+--- scidavis-2.1.4/config.pri 2020-05-02 02:52:57.000000000 +0200
++++ scidavis-2.1.4a/config.pri 2020-05-09 20:40:18.693721166 +0200
+@@ -277,38 +277,25 @@
+ }
+
+ contains(PRESET, linux_package) {
+ ### dynamically link against Qwt(3D) installed system-wide
+
+ exists(/usr/include/qt5/qwt5-qt5) {INCLUDEPATH+=/usr/include/qt5/qwt5-qt5}
+ exists(/usr/include/qt5/qwtplot3d-qt5) {INCLUDEPATH+=/usr/include/qt5/qwtplot3d-qt5}
+ exists(/usr/include/qwt5-qt5) {INCLUDEPATH+=/usr/include/qwt5-qt5}
+ exists(/usr/include/qwtplot3d) {INCLUDEPATH+=/usr/include/qwtplot3d}
+
+- system (ls /usr/lib*/libqwt5-qt5.so) {LIBS+=-lqwt5-qt5}
+- system (ls /usr/lib*/*/libqwt5-qt5.so) {LIBS+=-lqwt5-qt5}
+- system (ls /usr/lib*/libqwt-qt5.so) {LIBS+=-lqwt-qt5}
+- system (ls /usr/lib*/libqwtplot3d-qt5.so) {LIBS+=-lqwtplot3d-qt5}
+- system (ls /usr/lib*/*/libqwtplot3d-qt5.so) {LIBS+=-lqwtplot3d-qt5}
+-
+-
++ LIBS+=-lqwt5-qt5
++ LIBS+=-lqwtplot3d-qt5
+ LIBS += -lz -lGLU
+-
+- INCLUDEPATH += /usr/include/muParser
+ LIBS += -lgsl -lgslcblas
+ LIBS += -lmuparser
+-
+- # enable user installed packages
+- INCLUDEPATH = "$(HOME)/usr/include" $$INCLUDEPATH
+- QMAKE_LIBDIR = "$(HOME)/usr/lib" $$QMAKE_LIBDIR
+-
+-
+ }
+
+ contains(PRESET, self_contained) {
+ ### mostly static linking, for self-contained binaries
+
+ INCLUDEPATH += ../3rdparty/qwt/src
+ LIBS += ../3rdparty/qwt/lib/libqwt.a
+
+ INCLUDEPATH += ../3rdparty/qwtplot3d/include
+ LIBS += ../3rdparty/qwtplot3d/lib/libqwtplot3d.a