summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--scilab-batik-1.9.patch11
3 files changed, 20 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f505abad2d8..1146513b62e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Aug 15 12:56:40 UTC 2017
+# Wed Aug 30 12:17:31 UTC 2017
pkgbase = scilab
pkgdesc = A scientific software package for numerical computations.
pkgver = 6.0.0
- pkgrel = 9
+ pkgrel = 10
url = https://www.scilab.org
arch = i686
arch = x86_64
@@ -53,6 +53,7 @@ pkgbase = scilab
source = scilab-hdf5-type.patch
source = scilab-hdf5-1.8.10.patch
source = scilab-fix-ocaml-4.0.4.diff
+ source = scilab-batik-1.9.patch
source = scilab-type.patch
sha256sums = b71bde8e397173a713493159a5b559de2e049b493985663418c79b2de0f23137
sha256sums = f19f173e989f72bd55bda35e271b3c180ecef4e29da964df3f230fce8b1330fc
@@ -62,6 +63,7 @@ pkgbase = scilab
sha256sums = c992a4f230dac60c3e217efee04b678c58d856f2aafa6173f742d4c5b050ab9d
sha256sums = 2dee1346c240d09ce7870bbbeb3318e0ac5d78f249d855df313e9cb7a2ef7fc0
sha256sums = 4288f98e34d0351c21b79bfc5b9fddabdee143965420fd3187d133e5d53ee20e
+ sha256sums = cc9bde7008ef078af3382e09867700c0f98779b4af39e21bb96e4bf9e020084a
sha256sums = 93597034c6866c3a4aaa7ef92b4588d2753383545ed3366be6cdb404edf949bd
pkgname = scilab
diff --git a/PKGBUILD b/PKGBUILD
index 8a489bffb203..564ed5cf42ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=scilab
pkgver=6.0.0
-pkgrel=9
+pkgrel=10
pkgdesc='A scientific software package for numerical computations.'
arch=('i686' 'x86_64')
url='https://www.scilab.org'
@@ -29,6 +29,7 @@ source=("${url}/download/${pkgver}/${pkgname}-${pkgver}-src.tar.gz"
"${pkgname}-hdf5-type.patch"
"${pkgname}-hdf5-1.8.10.patch"
"${pkgname}-fix-ocaml-4.0.4.diff"
+ "${pkgname}-batik-1.9.patch"
"${pkgname}-type.patch")
sha256sums=('b71bde8e397173a713493159a5b559de2e049b493985663418c79b2de0f23137'
'f19f173e989f72bd55bda35e271b3c180ecef4e29da964df3f230fce8b1330fc'
@@ -38,6 +39,7 @@ sha256sums=('b71bde8e397173a713493159a5b559de2e049b493985663418c79b2de0f23137'
'c992a4f230dac60c3e217efee04b678c58d856f2aafa6173f742d4c5b050ab9d'
'2dee1346c240d09ce7870bbbeb3318e0ac5d78f249d855df313e9cb7a2ef7fc0'
'4288f98e34d0351c21b79bfc5b9fddabdee143965420fd3187d133e5d53ee20e'
+ 'cc9bde7008ef078af3382e09867700c0f98779b4af39e21bb96e4bf9e020084a'
'93597034c6866c3a4aaa7ef92b4588d2753383545ed3366be6cdb404edf949bd')
prepare(){
@@ -57,6 +59,8 @@ prepare(){
patch bin/scilab "${srcdir}"/${pkgname}-LD_LIBRARY_PATH.patch
# Fix build with ocaml 4.0.4, https://codereview.scilab.org/#/c/19232
patch -p2 < "${srcdir}"/${pkgname}-fix-ocaml-4.0.4.diff
+ # Fix version for batik
+ patch -p0 < "${srcdir}"/${pkgname}-batik-1.9.patch
# Fix type
patch -p0 < "${srcdir}"/${pkgname}-type.patch
}
diff --git a/scilab-batik-1.9.patch b/scilab-batik-1.9.patch
new file mode 100644
index 000000000000..226c3c5a26fd
--- /dev/null
+++ b/scilab-batik-1.9.patch
@@ -0,0 +1,11 @@
+--- modules/xcos/src/java/org/scilab/modules/xcos/Xcos.java.orig 2017-08-30 13:17:48.301380837 +0200
++++ modules/xcos/src/java/org/scilab/modules/xcos/Xcos.java 2017-08-30 13:16:58.934524972 +0200
+@@ -101,7 +101,7 @@
+ * Dependencies version
+ */
+ private static final List<String> MXGRAPH_VERSIONS = null;
+- private static final List<String> BATIK_VERSIONS = Arrays.asList("1.7", "1.8pre", "1.8");
++ private static final List<String> BATIK_VERSIONS = Arrays.asList("1.7", "1.8pre", "1.8", "1.9");
+
+ private static final String UNABLE_TO_LOAD_JGRAPHX = Messages.gettext("Unable to load the jgraphx library.\nExpecting version %s ; Getting version %s .");
+ private static final String UNABLE_TO_LOAD_BATIK = Messages.gettext("Unable to load the Batik library. \nExpecting version %s ; Getting version %s .");