summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD17
2 files changed, 21 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d80d2af4b90e..b7f506c73ae1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,11 +8,13 @@ pkgbase = scilab-git
license = BSD
license = custom:CeCILL
license = GPL2
- makedepends = apache-ant
- makedepends = git
- makedepends = ocaml
- makedepends = java-environment>=8
+ makedepends = java-environment=8
+ makedepends = ant>=1.9.0
+ makedepends = ocaml-findlib
+ makedepends = ocaml-num
makedepends = gcc-fortran
+ makedepends = time
+ makedepends = git
depends = suitesparse>=4.4.1
depends = arpack
depends = fftw
@@ -20,15 +22,16 @@ pkgbase = scilab-git
depends = hdf5
depends = libmatio
depends = tk
+ depends = bwidget
depends = curl
+ depends = inetutils
depends = java-runtime>=8
- depends = apache-lucene>=7
depends = beanshell
depends = eclipse-ecj
depends = java-flexdock>=1.2.4
depends = fop-hyph
depends = jeuclid-core
- depends = jgraphx>=2.0.0.1
+ depends = jgraphx-jre8
depends = javahelp2
depends = saxon-he
depends = jlatexmath-fop>=1.0.3
@@ -40,7 +43,9 @@ pkgbase = scilab-git
depends = xalan-java
depends = docbook-xsl
depends = jogl>=2.3.2
+ depends = apache-lucene>=7
depends = java-batik>=1.8
+ depends = java-xmlgraphics-commons>=2.0.1
provides = scilab
conflicts = scilab
source = git://git.scilab.org/scilab#branch=master
diff --git a/PKGBUILD b/PKGBUILD
index 38c256e68779..e7fd83daa6fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,17 +11,20 @@ pkgdesc='A scientific software package for numerical computations.'
arch=('i686' 'x86_64')
url='https://www.scilab.org'
license=('BSD' 'custom:CeCILL' 'GPL2')
-depends=('suitesparse>=4.4.1' 'arpack' 'fftw' 'eigen'
- 'hdf5'
- 'libmatio' 'tk' 'curl'
+depends=('suitesparse>=4.4.1' 'arpack' 'fftw' 'eigen'
+ 'hdf5' 'libmatio'
+ 'tk' 'bwidget'
+ 'curl' 'inetutils'
'java-runtime>=8'
- 'apache-lucene>=7'
'beanshell' 'eclipse-ecj' 'java-flexdock>=1.2.4' 'fop-hyph'
- 'jeuclid-core' 'jgraphx>=2.0.0.1' 'javahelp2'
+ 'jeuclid-core' 'jgraphx-jre8' 'javahelp2'
'saxon-he' 'jlatexmath-fop>=1.0.3' 'jrosetta>=1.0.4' 'jgoodies-looks' 'java-qdox'
'java-skinlf' 'java-testng' 'xalan-java' 'docbook-xsl'
- 'jogl>=2.3.2' 'java-batik>=1.8')
-makedepends=('apache-ant' 'git' 'ocaml' 'java-environment>=8' 'gcc-fortran')
+ 'jogl>=2.3.2' 'apache-lucene>=7'
+ 'java-batik>=1.8' 'java-xmlgraphics-commons>=2.0.1')
+makedepends=('java-environment=8' 'ant>=1.9.0'
+ 'ocaml-findlib' 'ocaml-num' 'gcc-fortran'
+ 'time' 'git')
provides=('scilab')
conflicts=('scilab')
source=("git://git.scilab.org/scilab${_fragment}"