summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--010-screencloud-fix-python-link-libraries.patch38
-rw-r--r--PKGBUILD39
3 files changed, 65 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6141a8b287c0..48ef30556519 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = screencloud
pkgdesc = An easy to use screenshot sharing application
- pkgver = 1.4.0
- pkgrel = 5
+ pkgver = 1.5.3
+ pkgrel = 1
url = https://github.com/olav-st/screencloud/
arch = x86_64
license = GPL
@@ -11,16 +11,18 @@ pkgbase = screencloud
makedepends = qt5-svg
makedepends = qt5-tools
depends = quazip
- depends = python2
+ depends = python
depends = libx11
depends = qt5-base
depends = qt5-x11extras
depends = qt5-multimedia
depends = hicolor-icon-theme
depends = pythonqt
- optdepends = python2-crypto: for SFTP support
- source = screencloud-1.4.0.tar.gz::https://github.com/olav-st/screencloud/archive/v1.4.0.tar.gz
- sha256sums = 2cc4b33227efdf74ea3803d7f4f29c75de37de376995346f35eb9ae0a9eaf212
+ optdepends = python-ssh2: for SFTP support
+ source = screencloud-1.5.3.tar.gz::https://github.com/olav-st/screencloud/archive/v1.5.3.tar.gz
+ source = 010-screencloud-fix-python-link-libraries.patch
+ sha256sums = cff8cf5f5afa5c7aee2d7dd3a8ce28a9808f703042e03dd635b255c5b5a12c27
+ sha256sums = bf9327568513852f02b87c7a72474b50ed323ed525098e790e190472f9b1fa8e
pkgname = screencloud
diff --git a/010-screencloud-fix-python-link-libraries.patch b/010-screencloud-fix-python-link-libraries.patch
new file mode 100644
index 000000000000..7dde6e125737
--- /dev/null
+++ b/010-screencloud-fix-python-link-libraries.patch
@@ -0,0 +1,38 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -263,17 +263,6 @@ set(REQUIRED_LIBS ${REQUIRED_LIBS}
+ ${QUAZIP_LIBRARY}
+ )
+
+-#Find Python
+-if(PYTHON_USE_PYTHON3)
+- find_package(PythonLibs 3.3 REQUIRED)
+-else(PYTHON_USE_PYTHON3)
+- find_package(PythonLibs 2.6 REQUIRED)
+-endif(PYTHON_USE_PYTHON3)
+-include_directories(${PYTHON_INCLUDE_DIR})
+-set(REQUIRED_LIBS ${REQUIRED_LIBS}
+- ${PYTHON_LIBRARIES}
+-)
+-
+ #Find PythonQt
+ find_package(PythonQt REQUIRED)
+ include_directories(${PYTHONQT_INCLUDE_DIR})
+@@ -293,6 +282,17 @@ else(PYTHONQT_QTALL_FOUND)
+ message(STATUS "Using PythonQt_QtBindings (old) for Qt bindings.")
+ endif(PYTHONQT_QTALL_FOUND)
+
++#Find Python
++if(PYTHON_USE_PYTHON3)
++ find_package(PythonLibs 3.3 REQUIRED)
++else(PYTHON_USE_PYTHON3)
++ find_package(PythonLibs 2.6 REQUIRED)
++endif(PYTHON_USE_PYTHON3)
++include_directories(${PYTHON_INCLUDE_DIR})
++set(REQUIRED_LIBS ${REQUIRED_LIBS}
++ ${PYTHON_LIBRARIES}
++)
++
+ #Platform specific libs
+ if(WIN32)
+ set(REQUIRED_LIBS ${REQUIRED_LIBS}
diff --git a/PKGBUILD b/PKGBUILD
index f331ae05d043..dca95d3ab13e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,45 @@
-# Maintainer : Daniel Bermond < gmail-com: danielbermond >
+# Maintainer : Daniel Bermond <dbermond@archlinux.org>
# Contributor: Lev Lybin <lev.lybin@gmail.com>
pkgname=screencloud
-pkgver=1.4.0
-pkgrel=5
+pkgver=1.5.3
+pkgrel=1
pkgdesc='An easy to use screenshot sharing application'
arch=('x86_64')
url='https://github.com/olav-st/screencloud/'
license=('GPL')
depends=(
# official repositories:
- 'quazip' 'python2' 'libx11' 'qt5-base' 'qt5-x11extras' 'qt5-multimedia'
+ 'quazip' 'python' 'libx11' 'qt5-base' 'qt5-x11extras' 'qt5-multimedia'
'hicolor-icon-theme'
# AUR:
'pythonqt'
)
makedepends=('cmake' 'zlib' 'openssl' 'qt5-svg' 'qt5-tools')
-optdepends=('python2-crypto: for SFTP support')
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/olav-st/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('2cc4b33227efdf74ea3803d7f4f29c75de37de376995346f35eb9ae0a9eaf212')
+optdepends=('python-ssh2: for SFTP support')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/olav-st/${pkgname}/archive/v${pkgver}.tar.gz"
+ '010-screencloud-fix-python-link-libraries.patch')
+sha256sums=('cff8cf5f5afa5c7aee2d7dd3a8ce28a9808f703042e03dd635b255c5b5a12c27'
+ 'bf9327568513852f02b87c7a72474b50ed323ed525098e790e190472f9b1fa8e')
prepare() {
- mkdir -p "${pkgname}-${pkgver}/build"
+ patch -d "${pkgname}-${pkgver}" -Np1 -i "${srcdir}/010-screencloud-fix-python-link-libraries.patch"
}
build() {
- cd "${pkgname}-${pkgver}/build"
+ local _quazip_include
+ _quazip_include="$(find /usr/include -type d -name 'QuaZip-Qt5*')/quazip"
- cmake \
+ cmake -B build -S "${pkgname}-${pkgver}" \
-DCMAKE_BUILD_TYPE:STRING='None' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
- -DCOLOR_OUTPUT:BOOL='ON' \
- -DPYTHON_USE_PYTHON3:BOOL='OFF' \
- -DQT_USE_QT5:BOOL='ON' \
- -Wno-dev \
- ..
-
- make
+ -DPYTHON_USE_PYTHON3:BOOL='ON' \
+ -DQUAZIP_INCLUDE_DIR:PATH="${_quazip_include}" \
+ -DQUAZIP_LIBRARY:FILEPATH='/usr/lib/libquazip1-qt5.so' \
+ -Wno-dev
+ make -C build
}
package() {
- cd "${pkgname}-${pkgver}/build"
-
- make DESTDIR="$pkgdir" install
+ make -C build DESTDIR="$pkgdir" install
}