summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--010-screencloud-fix-python-link-libraries.patch (renamed from 010-screencloud-1.5.0-fix-build.patch)8
-rw-r--r--PKGBUILD23
3 files changed, 20 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82061c17fc2f..268d15d4d409 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = screencloud
pkgdesc = An easy to use screenshot sharing application
- pkgver = 1.5.0
- pkgrel = 2
+ pkgver = 1.5.1
+ pkgrel = 1
url = https://github.com/olav-st/screencloud/
arch = x86_64
license = GPL
@@ -19,10 +19,10 @@ pkgbase = screencloud
depends = hicolor-icon-theme
depends = pythonqt
optdepends = python-pycryptodome: for SFTP support
- source = screencloud-1.5.0.tar.gz::https://github.com/olav-st/screencloud/archive/v1.5.0.tar.gz
- source = 010-screencloud-1.5.0-fix-build.patch
- sha256sums = 8903a79207926a22a059e70c8d71b3eb136ed08cf06c8a37a5afe888c3f8538c
- sha256sums = 3061f78ba26a9b9492fcf5e65ba015d4748c4aab8fb6d78c91fd3410e2c0909f
+ source = screencloud-1.5.1.tar.gz::https://github.com/olav-st/screencloud/archive/v1.5.1.tar.gz
+ source = 010-screencloud-fix-python-link-libraries.patch
+ sha256sums = 2a22ca06fc217574aee2204fdae4ba9c01cf6d5d78a63334ae95207bfbf0fc72
+ sha256sums = 5526080cd195127cc94f4c8d69ae3e55e6d3b24b6feeb23c1d5f8f885c87d7f4
pkgname = screencloud
diff --git a/010-screencloud-1.5.0-fix-build.patch b/010-screencloud-fix-python-link-libraries.patch
index e592ce627b37..68dfdd82676d 100644
--- a/010-screencloud-1.5.0-fix-build.patch
+++ b/010-screencloud-fix-python-link-libraries.patch
@@ -1,7 +1,7 @@
diff -Naurp a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2019-06-30 19:28:31.000000000 +0000
-+++ b/CMakeLists.txt 2019-11-24 17:39:45.214293986 +0000
-@@ -266,17 +266,6 @@ set(REQUIRED_LIBS ${REQUIRED_LIBS}
+--- a/CMakeLists.txt 2020-01-11 15:33:41.000000000 +0000
++++ b/CMakeLists.txt 2020-01-11 16:22:36.000000000 +0000
+@@ -272,17 +272,6 @@ set(REQUIRED_LIBS ${REQUIRED_LIBS}
${QUAZIP_LIBRARY}
)
@@ -19,7 +19,7 @@ diff -Naurp a/CMakeLists.txt b/CMakeLists.txt
#Find PythonQt
find_package(PythonQt REQUIRED)
include_directories(${PYTHONQT_INCLUDE_DIR})
-@@ -296,6 +285,17 @@ else(PYTHONQT_QTALL_FOUND)
+@@ -302,6 +291,17 @@ else(PYTHONQT_QTALL_FOUND)
message(STATUS "Using PythonQt_QtBindings (old) for Qt bindings.")
endif(PYTHONQT_QTALL_FOUND)
diff --git a/PKGBUILD b/PKGBUILD
index 643083b5a342..52d6d750ce75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Lev Lybin <lev.lybin@gmail.com>
pkgname=screencloud
-pkgver=1.5.0
-pkgrel=2
+pkgver=1.5.1
+pkgrel=1
pkgdesc='An easy to use screenshot sharing application'
arch=('x86_64')
url='https://github.com/olav-st/screencloud/'
@@ -18,28 +18,25 @@ depends=(
makedepends=('cmake' 'zlib' 'openssl' 'qt5-svg' 'qt5-tools')
optdepends=('python-pycryptodome: for SFTP support')
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/olav-st/${pkgname}/archive/v${pkgver}.tar.gz"
- '010-screencloud-1.5.0-fix-build.patch')
-sha256sums=('8903a79207926a22a059e70c8d71b3eb136ed08cf06c8a37a5afe888c3f8538c'
- '3061f78ba26a9b9492fcf5e65ba015d4748c4aab8fb6d78c91fd3410e2c0909f')
+ '010-screencloud-fix-python-link-libraries.patch')
+sha256sums=('2a22ca06fc217574aee2204fdae4ba9c01cf6d5d78a63334ae95207bfbf0fc72'
+ '5526080cd195127cc94f4c8d69ae3e55e6d3b24b6feeb23c1d5f8f885c87d7f4')
prepare() {
- mkdir -p "${pkgname}-${pkgver}/build"
- patch -d "${pkgname}-${pkgver}" -Np1 -i "${srcdir}/010-screencloud-1.5.0-fix-build.patch"
+ patch -d "${pkgname}-${pkgver}" -Np1 -i "${srcdir}/010-screencloud-fix-python-link-libraries.patch"
}
build() {
- cd "${pkgname}-${pkgver}/build"
- cmake \
+ cmake -B build -S "${pkgname}-${pkgver}" \
-DCMAKE_BUILD_TYPE:STRING='None' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
-DCOLOR_OUTPUT:BOOL='ON' \
-DPYTHON_USE_PYTHON3:BOOL='ON' \
-DQT_USE_QT5:BOOL='ON' \
- -Wno-dev \
- ..
- make
+ -Wno-dev
+ make -C build
}
package() {
- make -C "${pkgname}-${pkgver}/build" DESTDIR="$pkgdir" install
+ make -C build DESTDIR="$pkgdir" install
}