summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
-rw-r--r--screencloud-1.3.1-fix-pythonqt-detection.patch42
3 files changed, 10 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5eca8391247..3d26575e3cec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = screencloud
pkgdesc = An easy to use screenshot sharing application
- pkgver = 1.3.1
- pkgrel = 2
+ pkgver = 1.4.0
+ pkgrel = 1
url = https://github.com/olav-st/screencloud/
arch = i686
arch = x86_64
@@ -21,10 +21,8 @@ pkgbase = screencloud
depends = pythonqt
optdepends = python2-crypto: for SFTP support
conflicts = screencloud-git
- source = screencloud-1.3.1.tar.gz::https://github.com/olav-st/screencloud/archive/v1.3.1.tar.gz
- source = screencloud-1.3.1-fix-pythonqt-detection.patch
- sha256sums = c23d8efb955ea861920c548f7fd3255726e86409d7a2022952225c765cc3da52
- sha256sums = 9ec7c818fe5db23e72199946c25bd528b302e7b12ee29f9791c50ffc6dba2c1e
+ source = screencloud-1.4.0.tar.gz::https://github.com/olav-st/screencloud/archive/v1.4.0.tar.gz
+ sha256sums = 2cc4b33227efdf74ea3803d7f4f29c75de37de376995346f35eb9ae0a9eaf212
pkgname = screencloud
diff --git a/PKGBUILD b/PKGBUILD
index 061e21448a29..c93f18f8b8cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Lev Lybin <lev.lybin@gmail.com>
pkgname=screencloud
-pkgver=1.3.1
-pkgrel=2
+pkgver=1.4.0
+pkgrel=1
pkgdesc='An easy to use screenshot sharing application'
arch=('i686' 'x86_64')
url='https://github.com/olav-st/screencloud/'
@@ -18,21 +18,14 @@ depends=(
)
optdepends=('python2-crypto: for SFTP support')
conflicts=('screencloud-git')
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/olav-st/${pkgname}/archive/v${pkgver}.tar.gz"
- 'screencloud-1.3.1-fix-pythonqt-detection.patch')
-sha256sums=('c23d8efb955ea861920c548f7fd3255726e86409d7a2022952225c765cc3da52'
- '9ec7c818fe5db23e72199946c25bd528b302e7b12ee29f9791c50ffc6dba2c1e')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/olav-st/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('2cc4b33227efdf74ea3803d7f4f29c75de37de376995346f35eb9ae0a9eaf212')
-prepare() {
+build() {
cd "${pkgname}-${pkgver}"
mkdir -p build
-
- patch -Np1 -i "${srcdir}/screencloud-1.3.1-fix-pythonqt-detection.patch"
-}
-
-build() {
- cd "${pkgname}-${pkgver}/build"
+ cd build
cmake \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
diff --git a/screencloud-1.3.1-fix-pythonqt-detection.patch b/screencloud-1.3.1-fix-pythonqt-detection.patch
deleted file mode 100644
index f12bb01102c2..000000000000
--- a/screencloud-1.3.1-fix-pythonqt-detection.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 386bc72e6743e7cbbbf0a22f587458e6b18edb6c Mon Sep 17 00:00:00 2001
-From: olav-st <olav.s.th@gmail.com>
-Date: Thu, 8 Jun 2017 22:54:05 +0200
-Subject: [PATCH] apply (modified) patch from issue #281 to fix pythonqt
- detection
-
----
- cmake/modules/FindPythonQt.cmake | 4 +++-
- cmake/modules/FindPythonQt_QtAll.cmake | 5 ++++-
- 2 files changed, 7 insertions(+), 2 deletions(-)
-
-diff --git a/cmake/modules/FindPythonQt.cmake b/cmake/modules/FindPythonQt.cmake
-index 7165894..1ecd154 100644
---- a/cmake/modules/FindPythonQt.cmake
-+++ b/cmake/modules/FindPythonQt.cmake
-@@ -5,7 +5,9 @@
-
- find_path(PYTHONQT_INSTALL_DIR include/PythonQt/PythonQt.h DOC "Directory where PythonQt was installed.")
- find_path(PYTHONQT_INCLUDE_DIR PythonQt.h "${PYTHONQT_INSTALL_DIR}/include/PythonQt" DOC "Path to the PythonQt include directory")
--find_library(PYTHONQT_LIBRARY NAMES PythonQt QtPython PATHS "${PYTHONQT_INSTALL_DIR}/lib" DOC "The PythonQt library.")
-+file(GLOB PYTHONQT_LIB_FILE LIST_DIRECTORIES false RELATIVE "${PYTHONQT_INSTALL_DIR}/lib" "${PYTHONQT_INSTALL_DIR}/lib/*PythonQt-Qt[4-9]*.so")
-+string(REGEX REPLACE "^lib(.+)\\.so$" "\\1" PYTHONQT_LIB "${PYTHONQT_LIB_FILE}")
-+find_library(PYTHONQT_LIBRARY NAMES PythonQt QtPython "${PYTHONQT_LIB}" PATHS "${PYTHONQT_INSTALL_DIR}/lib" DOC "The PythonQt library.")
-
- mark_as_advanced(PYTHONQT_INSTALL_DIR)
- mark_as_advanced(PYTHONQT_INCLUDE_DIR)
-diff --git a/cmake/modules/FindPythonQt_QtAll.cmake b/cmake/modules/FindPythonQt_QtAll.cmake
-index f8c21c5..3c9ddc8 100644
---- a/cmake/modules/FindPythonQt_QtAll.cmake
-+++ b/cmake/modules/FindPythonQt_QtAll.cmake
-@@ -6,7 +6,10 @@
-
- find_path(PYTHONQT_QTALL_INSTALL_DIR NAMES include/PythonQt/PythonQt_QtAll.h include/PythonQt/extensions/PythonQt_QtAll/PythonQt_QtAll.h DOC "Directory where PythonQt_QtAll.h was installed.")
- find_path(PYTHONQT_QTALL_INCLUDE_DIR PythonQt_QtAll.h PATHS "${PYTHONQT_QTALL_INSTALL_DIR}/include/PythonQt" "${PYTHONQT_QTALL_INSTALL_DIR}/include/PythonQt/extensions/PythonQt_QtAll" ${CMAKE_INCLUDE_PATH} ${CMAKE_INSTALL_PREFIX}/include ${CMAKE_INSTALL_PREFIX}/include/PythonQt ${CMAKE_INSTALL_PREFIX}/include/PythonQt/extensions/PythonQt_QtAll DOC "Path to the PythonQt_QtAll include directory")
--find_library(PYTHONQT_QTALL_LIBRARY NAMES PythonQt_QtAll QtPython_QtAll PATHS "${PYTHONQT_QTALL_INSTALL_DIR}/extensions/PythonQt_QtAll" DOC "The PythonQt_QtAll library.")
-+file(GLOB PYTHONQT_QTALL_LIB_FILE LIST_DIRECTORIES false RELATIVE "${PYTHONQT_INSTALL_DIR}/lib" "${PYTHONQT_INSTALL_DIR}/lib/*PythonQt_QtAll-Qt[4-9]*.so")
-+string(REGEX REPLACE "^lib(.+)\\.so$" "\\1" PYTHONQT_QTALL_LIB "${PYTHONQT_QTALL_LIB_FILE}")
-+
-+find_library(PYTHONQT_QTALL_LIBRARY NAMES PythonQt_QtAll QtPython_QtAll "${PYTHONQT_QTALL_LIB}" PATHS "${PYTHONQT_QTALL_INSTALL_DIR}/extensions/PythonQt_QtAll" DOC "The PythonQt_QtAll library.")
-
- mark_as_advanced(PYTHONQT_QTALL_INSTALL_DIR)
- mark_as_advanced(PYTHONQT_QTALL_INCLUDE_DIR)