summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b51ed893058
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = screengrab-git
+ pkgdesc = Crossplatform tool for grabbing screenshots of your desktop.
+ pkgver = 1.95_pr1.19.g4650e76
+ pkgrel = 1
+ url = http://screengrab.doomer.org/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ makedepends = qt5-tools
+ depends = qt5-base
+ provides = screengrab
+ conflicts = screengrab
+ source = git+https://github.com/QtDesktop/screengrab
+ sha256sums = SKIP
+
+pkgname = screengrab-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a0953e201a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Jerome Leclanche <jerome@leclan.ch>
+
+_pkgname=screengrab
+pkgname=$_pkgname-git
+pkgver=1.95_pr1.19.g4650e76
+pkgrel=1
+pkgdesc="Crossplatform tool for grabbing screenshots of your desktop."
+arch=("i686" "x86_64")
+url="http://screengrab.doomer.org/"
+license=("GPL2")
+depends=("qt5-base")
+makedepends=("git" "cmake" "qt5-tools")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+https://github.com/QtDesktop/$_pkgname")
+sha256sums=("SKIP")
+
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --always | sed "s/-/./g"
+}
+
+build() {
+ mkdir -p build
+ cd build
+ cmake "$srcdir/$_pkgname" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+package() {
+ cd build
+ make install DESTDIR="$pkgdir"
+}