summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD36
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e757f6e0bd5a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = scrot-slabua-git
+ pkgdesc = Simple command-line screenshot utility for X - Slabua fork
+ pkgver = 0.8.26.r19.gd856d56
+ pkgrel = 1
+ url = https://github.com/slabua/scrot
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = giblib
+ provides = scrot
+ conflicts = scrot
+ source = scrot-slabua-git::git+https://github.com/slabua/scrot
+ sha256sums = SKIP
+
+pkgname = scrot-slabua-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6627dc0329d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Chris Lane <chris at chrislane dot com>
+
+pkgname=scrot-slabua-git
+pkgver=0.8.26.r19.gd856d56
+pkgrel=1
+pkgdesc='Simple command-line screenshot utility for X - Slabua fork'
+url='https://github.com/slabua/scrot'
+arch=('any')
+license=('MIT')
+depends=('giblib')
+makedepends=('git')
+conflicts=('scrot')
+provides=('scrot')
+source=("$pkgname"::"git+https://github.com/slabua/scrot")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --long | sed 's/^scrot-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR=${pkgdir} docsdir=/usr/share/doc/scrot install
+ install -Dm 644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim: ft=sh ts=2 sw=2 et