summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2821f25adf6f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = scythe-git
+ pkgdesc = A Bayesian adapter trimmer
+ pkgver = 133.20d3cff
+ pkgrel = 1
+ url = https://github.com/vsbuffalo/scythe
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = zlib
+ source = scythe-git::git+https://github.com/vsbuffalo/scythe.git
+ md5sums = SKIP
+
+pkgname = scythe-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..907e94930bc5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Sauliusl <luksaulius[at]gmail[dot]com>
+# Based on the pkgbuild for sickle
+pkgname=scythe-git
+pkgver='133.20d3cff' # At the time of packaging, overriden using the function below
+
+pkgrel=1
+pkgdesc="A Bayesian adapter trimmer"
+arch=('i686' 'x86_64')
+url="https://github.com/vsbuffalo/scythe"
+license=('custom')
+depends=('zlib')
+source=('scythe-git::git+https://github.com/vsbuffalo/scythe.git')
+md5sums=('SKIP')
+
+pkgver() {
+ # Based on awish-git
+ cd "${srcdir}/${pkgname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ make all;
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ install -Dm755 scythe "${pkgdir}/usr/bin/scythe"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 illumina_adapters.fa "${pkgdir}/usr/share/scythe/illumina_adapters.fa"
+} \ No newline at end of file