summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD37
2 files changed, 36 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 99b2caf0b578..0eebba56d417 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sdl2-git
pkgdesc = A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard (Version 2)
- pkgver = 2.0.20.r19.g9a2bbd8ac
+ pkgver = 2.0.22.r271.g6b4bd5a75
pkgrel = 1
url = https://www.libsdl.org
arch = x86_64
@@ -16,16 +16,27 @@ pkgbase = sdl2-git
makedepends = libxkbcommon
makedepends = wayland-protocols
makedepends = ibus
- makedepends = fcitx
+ makedepends = fcitx5
makedepends = libxss
+ makedepends = cmake
makedepends = jack
- makedepends = git
+ makedepends = ninja
+ makedepends = pipewire
+ makedepends = libdecor
+ depends = glibc
+ depends = libxext
+ depends = libxrender
+ depends = libx11
depends = libgl
- depends = libibus
+ depends = libxcursor
+ depends = hidapi
+ depends = libusb
optdepends = alsa-lib: ALSA audio driver
optdepends = libpulse: PulseAudio audio driver
optdepends = jack: JACK audio driver
- provides = sdl2=2.0.20.r19.g9a2bbd8ac
+ optdepends = pipewire: PipeWire audio driver
+ optdepends = libdecor: Wayland client decorations
+ provides = sdl2=2.0.22.r271.g6b4bd5a75
conflicts = sdl2
conflicts = sdl2-minimal-hg
source = git+https://github.com/libsdl-org/SDL
diff --git a/PKGBUILD b/PKGBUILD
index daaf2d664d0a..530d55c16668 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,21 @@
# Maintainer: Christer Solskogen <christer.solskogen@gmail.com>
pkgname=sdl2-git
-pkgver=2.0.20.r19.g9a2bbd8ac
+pkgver=2.0.22.r271.g6b4bd5a75
pkgrel=1
pkgdesc="A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard (Version 2)"
arch=('x86_64' 'aarch64' 'armv7h')
url="https://www.libsdl.org"
license=('MIT')
-depends=('libgl' 'libibus' )
+depends=('glibc' 'libxext' 'libxrender' 'libx11' 'libgl' 'libxcursor' 'hidapi' 'libusb')
makedepends=('alsa-lib' 'mesa' 'libpulse' 'libxrandr' 'libxinerama' 'wayland' 'libxkbcommon'
- 'wayland-protocols' 'ibus' 'fcitx' 'libxss' 'jack' 'git' )
+ 'wayland-protocols' 'ibus' 'fcitx5' 'libxss' 'cmake' 'jack' 'ninja' 'pipewire'
+ 'libdecor')
optdepends=('alsa-lib: ALSA audio driver'
'libpulse: PulseAudio audio driver'
- 'jack: JACK audio driver')
+ 'jack: JACK audio driver'
+ 'pipewire: PipeWire audio driver'
+ 'libdecor: Wayland client decorations')
source=("git+https://github.com/libsdl-org/SDL")
provides=("sdl2=$pkgver")
conflicts=(sdl2 sdl2-minimal-hg)
@@ -23,23 +26,23 @@ pkgver() {
git describe --long --tags | sed 's/^release-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- rm -rf build
- mkdir build
-}
-
build() {
- cd build
- ../SDL/configure --prefix=/usr \
- --disable-video-rpi \
- --enable-video-kmsdrm
- make
+ CFLAGS+=" -ffat-lto-objects"
+ cmake -S SDL -B build -G Ninja \
+ -D CMAKE_INSTALL_PREFIX=/usr \
+ -D SDL_RPI=OFF \
+ -D SDL_STATIC=OFF \
+ -D SDL_RPATH=OFF
+ cmake --build build
}
package() {
- cd build
- make install DESTDIR="$pkgdir"
- install -Dm644 ../SDL/LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ DESTDIR="${pkgdir}" cmake --install build
+ # For some reason, this isn't named correctly and we have to fix it to reflect the actual staticlib name.
+ sed -i "s/libSDL2\.a/libSDL2main.a/g" "$pkgdir"/usr/lib/cmake/SDL2/SDL2Targets-noconfig.cmake
+ pwd
+ read
+ install -Dm644 SDL/LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
chown -R root:root "$pkgdir"
}