summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 9 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 69bd31f7d0de..09e49bb1d17d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sdl2-nox
pkgdesc = A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard (Version 2) without X11 support
- pkgver = 2.0.12
+ pkgver = 2.0.14
pkgrel = 0
url = http://www.libsdl.org
arch = x86_64
@@ -16,8 +16,8 @@ pkgbase = sdl2-nox
optdepends = libpulse: PulseAudio audio driver
provides = sdl2
conflicts = sdl2
- source = https://www.libsdl.org/release/SDL2-2.0.12.tar.gz
- md5sums = 783b6f2df8ff02b19bb5ce492b99c8ff
+ source = https://www.libsdl.org/release/SDL2-2.0.14.tar.gz
+ sha512sums = ebc482585bd565bf3003fbcedd91058b2183e333b9ea566d2f386da0298ff970645d9d25c1aa4459c7c96e9ea839fd1c5f2da0242a56892865b2e456cdd027ee
pkgname = sdl2-nox
diff --git a/PKGBUILD b/PKGBUILD
index eb1e5f6a7a3f..ac8ffc127ef4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# In order to use this on the Raspberry PI, you must either use the kms or fkms driver.
pkgname=sdl2-nox
-pkgver=2.0.12
+pkgver=2.0.14
pkgrel=0
pkgdesc="A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard (Version 2) without X11 support"
arch=('x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
@@ -16,26 +16,21 @@ conflicts=('sdl2')
optdepends=('alsa-lib: ALSA audio driver'
'libpulse: PulseAudio audio driver')
source=("https://www.libsdl.org/release/SDL2-${pkgver}.tar.gz")
-md5sums=('783b6f2df8ff02b19bb5ce492b99c8ff')
-
-prepare() {
- mkdir build
-}
+sha512sums=('ebc482585bd565bf3003fbcedd91058b2183e333b9ea566d2f386da0298ff970645d9d25c1aa4459c7c96e9ea839fd1c5f2da0242a56892865b2e456cdd027ee')
build() {
- cd build
- ../SDL2-$pkgver/configure --prefix=/usr \
+ cd "SDL2-$pkgver"
+ ./configure --prefix=/usr \
--enable-sdl-dlopen --enable-video-kmsdrm \
--disable-arts --disable-esd --disable-nas \
--enable-alsa --enable-pulseaudio-shared \
- --disable-video-x11 --disable-video-opengl \
- --disable-input-tslib
+ --disable-video-x11 --disable-video-opengl
make
}
package() {
- cd build
+ cd "SDL2-$pkgver"
make DESTDIR="$pkgdir" install
install -Dm644 ../SDL2-$pkgver/COPYING.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}