summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 935238150e75..c308a0881d02 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sdl2-nox
pkgdesc = A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard (Version 2) without X11 support
- pkgver = 2.0.8
+ pkgver = 2.0.9
pkgrel = 1
url = http://www.libsdl.org
arch = x86_64
@@ -10,13 +10,14 @@ pkgbase = sdl2-nox
arch = aarch64
license = MIT
makedepends = alsa-lib
+ makedepends = mesa
depends = bash
optdepends = alsa-lib: ALSA audio driver
optdepends = libpulse: PulseAudio audio driver
provides = sdl2
conflicts = sdl2
- source = https://www.libsdl.org/release/SDL2-2.0.8.tar.gz
- sha512sums = 673c6058b8692a36b4a3594456b10ef6051efe79e4fb644421fc5c76b11fd68b895840a2c8b72413418c378733e2993d33f19767d0d7ed101eda6310bd70c869
+ source = https://www.libsdl.org/release/SDL2-2.0.9.tar.gz
+ sha512sums = a78a4708b2bb5b35a7c7b7501eb3bd60a9aa3bb95a3d84e57763df4a377185e7312a94b66321eef7ca0d17255e4b402fc950e83ef0dbbd08f14ff1194107dc10
pkgname = sdl2-nox
diff --git a/PKGBUILD b/PKGBUILD
index a71ca2363476..38d03e5421d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,22 @@
# Maintainer: Christer Solskogen <christer.solskogen@gmail.com>
+# In order to use this on the Raspberry PI, you must either use the kms or fkms driver.
+
pkgname=sdl2-nox
-pkgver=2.0.8
+pkgver=2.0.9
pkgrel=1
pkgdesc="A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard (Version 2) without X11 support"
arch=('x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="http://www.libsdl.org"
license=('MIT')
depends=('bash')
-makedepends=('alsa-lib')
+makedepends=('alsa-lib' 'mesa')
provides=('sdl2')
conflicts=('sdl2')
optdepends=('alsa-lib: ALSA audio driver'
'libpulse: PulseAudio audio driver')
source=("https://www.libsdl.org/release/SDL2-${pkgver}.tar.gz")
-sha512sums=('673c6058b8692a36b4a3594456b10ef6051efe79e4fb644421fc5c76b11fd68b895840a2c8b72413418c378733e2993d33f19767d0d7ed101eda6310bd70c869')
+sha512sums=('a78a4708b2bb5b35a7c7b7501eb3bd60a9aa3bb95a3d84e57763df4a377185e7312a94b66321eef7ca0d17255e4b402fc950e83ef0dbbd08f14ff1194107dc10')
prepare() {
mkdir build
@@ -23,10 +25,9 @@ prepare() {
build() {
cd build
../SDL2-$pkgver/configure --prefix=/usr \
- --enable-sdl-dlopen \
+ --enable-sdl-dlopen --enable-video-kmsdrm \
--disable-arts --disable-esd --disable-nas \
--enable-alsa --enable-pulseaudio-shared \
- --disable-video-mir --disable-video-wayland \
--disable-video-x11 --disable-video-opengl
make