summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD27
-rw-r--r--sdl_sound-renamed-physfs-export.patch (renamed from physfs-renamed-export.patch)0
3 files changed, 16 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fef69aab4ab7..06b9f6e8a8fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sdl_sound-hg
pkgdesc = A library to decode several popular sound file formats (development version)
- pkgver = r596.719dade41745
+ pkgver = 1.0.3.r48.719dade41745
pkgrel = 1
url = http://icculus.org/SDL_sound/
arch = i686
@@ -15,7 +15,7 @@ pkgbase = sdl_sound-hg
provides = sdl_sound
conflicts = sdl_sound
source = sdl_sound::hg+http://hg.icculus.org/icculus/SDL_sound
- source = physfs-renamed-export.patch
+ source = sdl_sound-renamed-physfs-export.patch
sha256sums = SKIP
sha256sums = d7bd96390d9bc877c0204922c7c4666cadfdccc5e6c0cfcf9477d113377f5d10
diff --git a/PKGBUILD b/PKGBUILD
index 34f869838a44..e648f0cc5c2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,8 @@
# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
-_name=sdl_sound
-pkgname=$_name-hg
-pkgver=r596.719dade41745
+pkgname=sdl_sound-hg
+pkgver=1.0.3.r48.719dade41745
pkgrel=1
pkgdesc="A library to decode several popular sound file formats (development version)"
arch=('i686' 'x86_64')
@@ -12,28 +11,30 @@ url="http://icculus.org/SDL_sound/"
license=('LGPL')
depends=('sdl' 'libmodplug' 'libvorbis' 'flac' 'speex')
makedepends=('mercurial')
-conflicts=("$_name")
-provides=("$_name")
-source=($_name::"hg+http://hg.icculus.org/icculus/SDL_sound"
- 'physfs-renamed-export.patch')
+conflicts=("${pkgname%-*}")
+provides=("${pkgname%-*}")
+source=(${pkgname%-*}::"hg+http://hg.icculus.org/icculus/SDL_sound"
+ "${pkgname%-*}-renamed-physfs-export.patch")
sha256sums=('SKIP'
'd7bd96390d9bc877c0204922c7c4666cadfdccc5e6c0cfcf9477d113377f5d10')
pkgver() {
- cd $_name
+ cd ${pkgname%-*}
- printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+ _lasttag=$(hg tags -q | sort -r | grep release- | head -n1)
+ _commits=$(hg log --template "{node}\n" -r $_lasttag:tip | wc -l)
+ printf "%s.r%s.%s" "${_lasttag/release-}" "$_commits" "$(hg identify -i)"
}
prepare() {
- cd $_name
+ cd ${pkgname%-*}
# fix deprecated physfs declaration
- patch -Np1 < ../physfs-renamed-export.patch
+ patch -Np1 < ../${pkgname%-*}-renamed-physfs-export.patch
}
build() {
- cd $_name
+ cd ${pkgname%-*}
./bootstrap
./configure --prefix=/usr --disable-static --disable-mikmod
@@ -41,5 +42,5 @@ build() {
}
package() {
- make -C $_name DESTDIR="$pkgdir/" install
+ make -C ${pkgname%-*} DESTDIR="$pkgdir/" install
}
diff --git a/physfs-renamed-export.patch b/sdl_sound-renamed-physfs-export.patch
index 316d165c71df..316d165c71df 100644
--- a/physfs-renamed-export.patch
+++ b/sdl_sound-renamed-physfs-export.patch