summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD59
-rw-r--r--mame.sh31
3 files changed, 72 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5df510901b29..1cece1371c6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sdlmame-wout-toolkits
pkgdesc = A port of the popular Multiple Arcade Machine Emulator using SDL with OpenGL support. Without Qt toolkit
- pkgver = 0.218
+ pkgver = 0.240
pkgrel = 1
url = http://mamedev.org
install = sdlmame-wout-toolkits.install
@@ -11,31 +11,38 @@ pkgbase = sdlmame-wout-toolkits
makedepends = glu
makedepends = glm
makedepends = wget
+ makedepends = asio
+ makedepends = libpulse
+ makedepends = portmidi
+ makedepends = portaudio
+ makedepends = libjpeg-turbo
+ makedepends = flac
makedepends = python-sphinxcontrib-svg2pdfconverter
makedepends = rapidjson
depends = sdl2_ttf
- depends = lua
- depends = flac
- depends = portmidi
- depends = portaudio
- depends = libjpeg-turbo
+ depends = lua53
+ depends = libxi
+ depends = libpulse.so
+ depends = libportaudio.so
+ depends = libportmidi.so
+ depends = libjpeg.so
+ depends = libFLAC.so
depends = fontconfig
depends = sqlite
depends = libutf8proc
depends = pugixml
+ depends = hicolor-icon-theme
+ provides = sdlmame
conflicts = sdlmame
conflicts = sdlmamefamily-tools
conflicts = mame
- source = https://github.com/mamedev/mame/archive/mame0218.tar.gz
+ source = https://github.com/mamedev/mame/archive/mame0240.tar.gz
source = mame.sh
- source = https://patch-diff.githubusercontent.com/raw/bkaradzic/GENie/pull/493.diff
- source = mame.desktop::https://git.archlinux.org/svntogit/community.git/plain/trunk/mame.desktop?h=packages/mame
- source = mame.svg::https://git.archlinux.org/svntogit/community.git/plain/trunk/mame.svg?h=packages/mame
- sha256sums = c855d2a53956d7ecc6b2d029747495278cd701dc785c50548f0f20ffa673b91f
- sha256sums = 441ecf30fa03c13945947f56bb577b7e12c9a6cc287097fd969eb71be0f3ae85
- sha256sums = SKIP
- sha256sums = 6beb883c8efed5b7466d43d0658b47c3e4a9928b5d0245ed56446b230e28306b
+ source = https://raw.githubusercontent.com/archlinux/svntogit-community/packages/mame/trunk/mame.desktop
+ source = https://raw.githubusercontent.com/archlinux/svntogit-community/packages/mame/trunk/mame.svg
+ sha256sums = f5228ccd7e561e8ee6e42d85f1f1be3432f4869169a4d692e646a6959c5c8f75
+ sha256sums = 4447b80208ac512764f78fce52aef159ba494db2762c04c6fd79e2aceed5307b
+ sha256sums = 0e5e93f84673c2d17a1bf7a6b256cfa54ef89a086a828df19bc054c12776d821
sha256sums = 17c442c933d764175e4ce1de50a80c0c2ddd5d733caf09c3cd5e6ba697ac43f4
pkgname = sdlmame-wout-toolkits
-
diff --git a/PKGBUILD b/PKGBUILD
index 7eb545d1de4b..0f1f8c81664d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Based On: Sergej Pupykin <pupykin.s+arch@gmail.com>
pkgname=sdlmame-wout-toolkits
-pkgver=0.218
+pkgver=0.240
pkgrel=1
pkgdesc="A port of the popular Multiple Arcade Machine Emulator using SDL with OpenGL support. Without Qt toolkit"
url='http://mamedev.org'
@@ -12,49 +12,59 @@ conflicts=('sdlmame'
'sdlmamefamily-tools'
'mame'
)
+provides=('sdlmame')
depends=('sdl2_ttf'
- 'lua'
- 'flac'
- 'portmidi'
- 'portaudio'
- 'libjpeg-turbo'
+ 'lua53'
+ 'libxi'
+ 'libpulse.so'
+ 'libportaudio.so'
+ 'libportmidi.so'
+ 'libjpeg.so'
+ 'libFLAC.so'
'fontconfig'
'sqlite'
'libutf8proc'
'pugixml'
+ 'hicolor-icon-theme'
)
makedepends=('nasm'
'mesa'
'glu'
'glm'
'wget'
-# 'asio'
+ 'asio'
+ 'libpulse'
+ 'portmidi'
+ 'portaudio'
+ 'libjpeg-turbo'
+ 'flac'
'python-sphinxcontrib-svg2pdfconverter'
'rapidjson'
)
source=("https://github.com/mamedev/mame/archive/mame${pkgver/./}.tar.gz"
'mame.sh'
- 'https://patch-diff.githubusercontent.com/raw/bkaradzic/GENie/pull/493.diff'
- 'mame.desktop::https://git.archlinux.org/svntogit/community.git/plain/trunk/mame.desktop?h=packages/mame'
- 'mame.svg::https://git.archlinux.org/svntogit/community.git/plain/trunk/mame.svg?h=packages/mame'
+ 'https://raw.githubusercontent.com/archlinux/svntogit-community/packages/mame/trunk/mame.desktop'
+ 'https://raw.githubusercontent.com/archlinux/svntogit-community/packages/mame/trunk/mame.svg'
)
-sha256sums=('c855d2a53956d7ecc6b2d029747495278cd701dc785c50548f0f20ffa673b91f'
- '441ecf30fa03c13945947f56bb577b7e12c9a6cc287097fd969eb71be0f3ae85'
- 'SKIP'
- '6beb883c8efed5b7466d43d0658b47c3e4a9928b5d0245ed56446b230e28306b'
+sha256sums=('f5228ccd7e561e8ee6e42d85f1f1be3432f4869169a4d692e646a6959c5c8f75'
+ '4447b80208ac512764f78fce52aef159ba494db2762c04c6fd79e2aceed5307b'
+ '0e5e93f84673c2d17a1bf7a6b256cfa54ef89a086a828df19bc054c12776d821'
'17c442c933d764175e4ce1de50a80c0c2ddd5d733caf09c3cd5e6ba697ac43f4'
)
-
install=sdlmame-wout-toolkits.install
-prepare() {
+build() {
cd "mame-mame${pkgver/./}"
- patch -d 3rdparty/genie -p1 -i "${srcdir}/493.diff"
-}
+ export CFLAGS+=" -I/usr/include/lua5.3/"
+ export CXXFLAGS+=" -I/usr/include/lua5.3/"
-build() {
- cd "mame-mame${pkgver/./}"
+ export CXXFLAGS+=" -Wp,-U_GLIBCXX_ASSERTIONS" # FS#73202
+
+ # Hack to force linking to lua5.3
+ mkdir lib
+ ln -s /usr/lib/liblua5.3.so lib/liblua.so
+ export LDFLAGS+=" -L${PWD}/lib"
make PTR64=1 \
SSE2=1 \
@@ -66,7 +76,7 @@ build() {
TEST=0 \
STRIP_SYMBOLS=1 \
VERBOSE=1 \
- USE_SYSTEM_LIB_ASIO=0 \
+ USE_SYSTEM_LIB_ASIO=1 \
USE_SYSTEM_LIB_EXPAT=1 \
USE_SYSTEM_LIB_ZLIB=1 \
USE_SYSTEM_LIB_JPEG=1 \
@@ -78,7 +88,8 @@ build() {
USE_SYSTEM_LIB_UTF8PROC=1 \
USE_SYSTEM_LIB_GLM=1 \
USE_SYSTEM_LIB_RAPIDJSON=1 \
- USE_SYSTEM_LIB_PUGIXML=1
+ USE_SYSTEM_LIB_PUGIXML=1 \
+ USE_BUNDLED_LIB_SDL2=0
}
@@ -89,7 +100,7 @@ package() {
install -Dm755 "${srcdir}/mame.sh" "${pkgdir}/usr/bin/mame"
# Install the applications, and the UI font in /usr/share
- install -Dm755 mame64 "${pkgdir}/usr/lib/mame/mame"
+ install -Dm755 mame "${pkgdir}/usr/lib/mame/mame"
_apps=('castool'
'chdman'
'floptool'
@@ -103,7 +114,6 @@ package() {
'regrep'
'romcmp'
'split'
- 'src2html'
'srcclean'
'testkeys'
'unidasm'
@@ -146,5 +156,4 @@ package() {
# install desktop file and icon
install -Dm644 "${srcdir}/mame.desktop" -t "${pkgdir}/usr/share/applications"
install -Dm644 "${srcdir}/mame.svg" -t "${pkgdir}/usr/share/icons/hicolor/scalable/apps"
-
}
diff --git a/mame.sh b/mame.sh
index d02b93a0b191..0b8f2256093b 100644
--- a/mame.sh
+++ b/mame.sh
@@ -11,8 +11,8 @@ mame_first_run() {
cd -- ~/.config/mame || exit
if [ -e mame.ini ]; then
- mv mame.ini mameini.bak || exit
- echo "Your old ini file has been renamed to mameini.bak"
+ mv mame.ini mame.ini.bak || exit
+ echo "Your old ini file has been renamed to mame.ini.bak"
fi
# Note: the single quotes here are not a mistake; MAME will save these
@@ -20,18 +20,19 @@ mame_first_run() {
# it is run in future.
mame \
- -rompath '$HOME/.local/share/mame/roms;roms' \
- -hashpath '$HOME/.local/share/mame/hash;hash' \
+ -homepath '$HOME/.local/share/mame/data' \
+ -rompath '$HOME/.local/share/mame/roms;/usr/lib/mame/roms' \
+ -hashpath '$HOME/.local/share/mame/hash;/usr/lib/mame/hash' \
-samplepath '$HOME/.local/share/mame/samples' \
- -artpath '$HOME/.local/share/mame/artwork;artwork' \
- -ctrlrpath '$HOME/.local/share/mame/ctrlr;ctrlr' \
+ -artpath '$HOME/.local/share/mame/artwork;/usr/lib/mame/artwork' \
+ -ctrlrpath '$HOME/.local/share/mame/ctrlr;/usr/lib/mame/ctrlr' \
-inipath '$HOME/.config/mame/ini' \
- -fontpath '$HOME/.local/share/mame/fonts;fonts' \
+ -fontpath '$HOME/.local/share/mame/fonts;/usr/lib/mame/fonts' \
-cheatpath '$HOME/.local/share/mame/cheat' \
-crosshairpath '$HOME/.local/share/mame/crosshair' \
- -pluginspath '$HOME/.local/share/mame/plugins;plugins' \
- -languagepath '$HOME/.local/share/mame/language;language' \
- -swpath '$HOME/.local/share/mame/software;software' \
+ -pluginspath '$HOME/.local/share/mame/plugins;/usr/lib/mame/plugins' \
+ -languagepath '$HOME/.local/share/mame/language;/usr/lib/mame/language' \
+ -swpath '$HOME/.local/share/mame/software;/usr/lib/mame/software' \
-cfg_directory '$HOME/.config/mame/cfg' \
-nvram_directory '$HOME/.local/share/mame/nvram' \
-input_directory '$HOME/.local/share/mame/inp' \
@@ -40,7 +41,7 @@ mame_first_run() {
-diff_directory '$HOME/.local/share/mame/diff' \
-comment_directory '$HOME/.local/share/mame/comments' \
-video opengl \
- -noreadconfig -showconfig > mame.ini
+ -showconfig > ini/mame.ini
}
if [ "$1" = "--newini" ]; then
@@ -51,15 +52,15 @@ if [ "$1" = "--newini" ]; then
if ! [ -e ~/.local/share/mame ]; then
mkdir -- ~/.local/share/mame
fi
-
+
(
+ cd -- ~/.local/share/mame || exit
+ mkdir -p data roms hash samples artwork ctrlr fonts cheat crosshair plugins language software
cd -- ~/.config/mame || exit
mkdir -p ini
- cd -- ~/.local/share/mame || exit
- mkdir -p roms hash samples artwork ctrlr fonts cheat crosshair plugins language software
mame_first_run
) || exit
fi
cd "${mamelib}"
-exec ./mame "${@/--newini/}"
+exec ./mame -inipath "$HOME/.config/mame/ini" "${@/--newini/}"