summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD15
-rw-r--r--pr-1092.patch78
3 files changed, 94 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da3700e82470..6aa5e05ebd88 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = sdrangel-git
pkgdesc = Qt5/OpenGL SDR and signal analyzer frontend.
- pkgver = 6.10.3.r0.873ec7809
- pkgrel = 2
+ pkgver = 6.17.6.r7.5c742a873
+ pkgrel = 1
url = https://github.com/f4exb/sdrangel
arch = x86_64
arch = i686
@@ -71,10 +71,11 @@ pkgbase = sdrangel-git
optdepends = airspyhf: Airspy HF+ support
optdepends = libxtrx: XTRX SDR support
optdepends = libuhd: USRP support
- provides = sdrangel=6.10.3.r0.873ec7809
+ provides = sdrangel=6.17.6.r7.5c742a873
conflicts = sdrangel
source = git+https://github.com/f4exb/sdrangel
+ source = pr-1092.patch
sha512sums = SKIP
+ sha512sums = 4b749458458d6b9b89f50c7fdc250fdab1320d44693a7c9c168c46277d3ec50da58043d1625d6cfefa32ba9280c0cfe9b927bc016f3b7deedce97e88f2eeca18
pkgname = sdrangel-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 6d09a2bb3f21..e889ad556c56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
_pkgname=sdrangel
pkgname=$_pkgname-git
-pkgver=6.10.3.r0.873ec7809
-pkgrel=2
+pkgver=6.17.6.r7.5c742a873
+pkgrel=1
pkgdesc='Qt5/OpenGL SDR and signal analyzer frontend.'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url='https://github.com/f4exb/sdrangel'
@@ -41,14 +41,21 @@ optdepends=('ffmpeg: DATV demodulator'
)
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
-source=("git+$url")
-sha512sums=('SKIP')
+source=("git+$url" "pr-1092.patch")
+sha512sums=('SKIP'
+ '4b749458458d6b9b89f50c7fdc250fdab1320d44693a7c9c168c46277d3ec50da58043d1625d6cfefa32ba9280c0cfe9b927bc016f3b7deedce97e88f2eeca18')
pkgver() {
cd "$_pkgname"
git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g;s/\.rc./rc/g'
}
+prepare() {
+ cd "$_pkgname"
+
+ patch -p1 < "$srcdir/pr-1092.patch"
+}
+
build() {
# https://bugs.gentoo.org/704322
export CXXFLAGS="$CXXFLAGS -fpermissive"
diff --git a/pr-1092.patch b/pr-1092.patch
new file mode 100644
index 000000000000..568fd8e3a3f9
--- /dev/null
+++ b/pr-1092.patch
@@ -0,0 +1,78 @@
+From cc3f4ab2f8eeddeee6ce9740b940c8c07e4031bf Mon Sep 17 00:00:00 2001
+From: Jon Beniston <jon@beniston.com>
+Date: Tue, 28 Dec 2021 11:31:15 +0000
+Subject: [PATCH] Fix for #1087. Support compilation with Boost >= 1.77
+
+---
+ plugins/channelrx/noisefigure/noisefigure.cpp | 9 ++++++++-
+ .../channelrx/noisefigure/noisefigureenrdialog.cpp | 11 ++++++++++-
+ 2 files changed, 18 insertions(+), 2 deletions(-)
+
+diff --git a/plugins/channelrx/noisefigure/noisefigure.cpp b/plugins/channelrx/noisefigure/noisefigure.cpp
+index a6a08d413..646fbf065 100644
+--- a/plugins/channelrx/noisefigure/noisefigure.cpp
++++ b/plugins/channelrx/noisefigure/noisefigure.cpp
+@@ -16,6 +16,7 @@
+ // along with this program. If not, see <http://www.gnu.org/licenses/>. //
+ ///////////////////////////////////////////////////////////////////////////////////
+
++#include <boost/version.hpp>
+ #include <boost/math/interpolators/barycentric_rational.hpp>
+
+ #include "noisefigure.h"
+@@ -41,6 +42,12 @@
+ #include "channel/channelwebapiutils.h"
+ #include "maincore.h"
+
++#if BOOST_VERSION < 107700
++using namespace boost::math;
++#else
++using namespace boost::math::interpolators;
++#endif
++
+ MESSAGE_CLASS_DEFINITION(NoiseFigure::MsgConfigureNoiseFigure, Message)
+ MESSAGE_CLASS_DEFINITION(NoiseFigure::MsgPowerMeasurement, Message)
+ MESSAGE_CLASS_DEFINITION(NoiseFigure::MsgNFMeasurement, Message)
+@@ -180,7 +187,7 @@ double NoiseFigure::calcENR(double frequency)
+ else
+ {
+ int order = size - 1;
+- boost::math::barycentric_rational<double> interpolant(std::move(x), std::move(y), order);
++ barycentric_rational<double> interpolant(std::move(x), std::move(y), order);
+ enr = interpolant(frequency);
+ }
+ }
+diff --git a/plugins/channelrx/noisefigure/noisefigureenrdialog.cpp b/plugins/channelrx/noisefigure/noisefigureenrdialog.cpp
+index 1200fe989..e51afe232 100644
+--- a/plugins/channelrx/noisefigure/noisefigureenrdialog.cpp
++++ b/plugins/channelrx/noisefigure/noisefigureenrdialog.cpp
+@@ -17,11 +17,20 @@
+
+ #include <QDebug>
+
++#include <array>
++
++#include <boost/version.hpp>
+ #include <boost/math/interpolators/barycentric_rational.hpp>
+
+ #include "noisefigureenrdialog.h"
+ #include "util/interpolation.h"
+
++#if BOOST_VERSION < 107700
++using namespace boost::math;
++#else
++using namespace boost::math::interpolators;
++#endif
++
+ NoiseFigureENRDialog::NoiseFigureENRDialog(NoiseFigureSettings *settings, QWidget* parent) :
+ QDialog(parent),
+ m_settings(settings),
+@@ -153,7 +162,7 @@ void NoiseFigureENRDialog::plotChart()
+ y[i] = points[i][1];
+ }
+ int order = size - 1;
+- boost::math::barycentric_rational<double> interpolant(std::move(x), std::move(y), order);
++ barycentric_rational<double> interpolant(std::move(x), std::move(y), order);
+
+ x.resize(size);
+ y.resize(size);