summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0afa07202ea9..d5f2015f9d04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = seafile
pkgdesc = An online file storage and collaboration tool
- pkgver = 9.0.2
- pkgrel = 2
+ pkgver = 9.0.3
+ pkgrel = 1
url = https://github.com/haiwen/seafile
arch = i686
arch = x86_64
@@ -18,9 +18,9 @@ pkgbase = seafile
depends = sqlite
provides = seafile-client-cli
conflicts = seafile-server
- source = seafile-9.0.2-1.tar.gz::https://github.com/haiwen/seafile/archive/v9.0.2-1.tar.gz
+ source = seafile-9.0.3.tar.gz::https://github.com/haiwen/seafile/archive/v9.0.3.tar.gz
source = seaf-cli@.service
- sha256sums = 619dd87bcb3a2d1a8e3ce08ab53d73e622b7d5591d2ac33f719dd53c82e8467b
+ sha256sums = d5558cd419c8d46bdc958064cb97f963d1ea793866414c025906ec15033512ed
sha256sums = c37510109c1de64c774896df39aece240c056b54414d2119fca01860211156ba
pkgname = seafile
diff --git a/PKGBUILD b/PKGBUILD
index ba306a3294e7..34ded0765c29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,8 @@
# Contributor: Aaron Lindsay <aaron@aclindsay.com>
pkgname=seafile
-pkgver=9.0.2
-_pkgver="$pkgver-1"
-pkgrel=2
+pkgver=9.0.3
+pkgrel=1
pkgdesc='An online file storage and collaboration tool'
arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
url="https://github.com/haiwen/$pkgname"
@@ -24,22 +23,22 @@ makedepends=(
)
conflicts=('seafile-server')
source=(
- "seafile-$_pkgver.tar.gz::$url/archive/v$_pkgver.tar.gz"
+ "seafile-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
"seaf-cli@.service"
)
sha256sums=(
- '619dd87bcb3a2d1a8e3ce08ab53d73e622b7d5591d2ac33f719dd53c82e8467b'
+ '287812758771d698b7bff9ffe50de9c35b9760fb008a5e971ab2ce824c7d2ec6'
'c37510109c1de64c774896df39aece240c056b54414d2119fca01860211156ba'
)
provides=('seafile-client-cli')
prepare() {
- cd "$srcdir/seafile-$_pkgver"
+ cd "$srcdir/seafile-$pkgver"
sed -i 's|(DESTDIR)@prefix@|@prefix@|' './lib/libseafile.pc.in'
}
build() {
- cd "$srcdir/seafile-$_pkgver"
+ cd "$srcdir/seafile-$pkgver"
./autogen.sh
./configure \
--enable-console \
@@ -49,7 +48,7 @@ build() {
}
package() {
- cd "$srcdir/seafile-$_pkgver"
+ cd "$srcdir/seafile-$pkgver"
make DESTDIR="$pkgdir" install
install -Dm644 \