summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
2 files changed, 9 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f25b9e61ccb7..0d84b34c77e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = seafile
pkgdesc = An online file storage and collaboration tool
- pkgver = 7.0.5
+ pkgver = 7.0.6
pkgrel = 1
url = https://github.com/haiwen/seafile
arch = i686
@@ -11,18 +11,16 @@ pkgbase = seafile
license = GPL2
makedepends = vala
makedepends = intltool
- depends = ccnet-server
depends = libsearpc
depends = libevent
depends = fuse
- depends = python2
- depends = python2-future
+ depends = python-future
depends = sqlite
provides = seafile-client-cli
conflicts = seafile-server
- source = seafile-7.0.5.tar.gz::https://github.com/haiwen/seafile/archive/v7.0.5.tar.gz
+ source = seafile-7.0.6.tar.gz::https://github.com/haiwen/seafile/archive/v7.0.6.tar.gz
source = seaf-cli@.service
- sha256sums = 19b353279e20f84af94b08c62b948748bda8cd69eeb980c9fc124ea9a9a5f825
+ sha256sums = 8a7f37b555b5e8750194db9ae8041d2b0ed0035b3fc832112d4a891e02b00488
sha256sums = c37510109c1de64c774896df39aece240c056b54414d2119fca01860211156ba
pkgname = seafile
diff --git a/PKGBUILD b/PKGBUILD
index 3952137ad771..b31c5e0946d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,17 @@
# Contributor: Aaron Lindsay <aaron@aclindsay.com>
pkgname=seafile
-pkgver=7.0.5
+pkgver=7.0.6
pkgrel=1
pkgdesc='An online file storage and collaboration tool'
arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
url="https://github.com/haiwen/$pkgname"
license=('GPL2')
depends=(
- 'ccnet-server'
'libsearpc'
'libevent'
'fuse'
- 'python2'
- 'python2-future'
+ 'python-future'
'sqlite'
)
makedepends=(
@@ -25,11 +23,11 @@ makedepends=(
)
conflicts=('seafile-server')
source=(
- "seafile-$pkgver.tar.gz::$url/archive/v${pkgver}.tar.gz"
+ "seafile-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
"seaf-cli@.service"
)
sha256sums=(
- '19b353279e20f84af94b08c62b948748bda8cd69eeb980c9fc124ea9a9a5f825'
+ '8a7f37b555b5e8750194db9ae8041d2b0ed0035b3fc832112d4a891e02b00488'
'c37510109c1de64c774896df39aece240c056b54414d2119fca01860211156ba'
)
provides=('seafile-client-cli')
@@ -37,10 +35,6 @@ provides=('seafile-client-cli')
prepare() {
cd "$srcdir/seafile-$pkgver"
sed -i 's|(DESTDIR)@prefix@|@prefix@|' './lib/libseafile.pc.in'
-
- # Fix all script's python 2 requirement
- shebang='#!/usr/bin/env python'
- grep -s -l -r "$shebang" | xargs sed -i "1 s|$shebang|${shebang}2|"
}
build() {
@@ -49,7 +43,7 @@ build() {
./configure \
--enable-console \
--prefix=/usr \
- PYTHON=/usr/bin/python2
+ PYTHON='/usr/bin/python'
make
}