summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD24
2 files changed, 16 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3fde83bc374e..b5ed8aaa55bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = seafile-client
pkgdesc = Seafile is an online file storage and collaboration tool. This is seafile client for synchronizing your local files with seafile server.
- pkgver = 4.4.2
- pkgrel = 2
+ pkgver = 5.0.0
+ pkgrel = 1
url = https://github.com/haiwen/seafile-client/
install = seafile-client.install
arch = i686
arch = x86_64
license = Apache
makedepends = cmake
- depends = seafile-shared>=4.4.2
+ depends = seafile-shared=5.0.2
depends = qt4
depends = qtwebkit
options = !libtool
options = !emptydirs
- source = seafile-client-v4.4.2.tar.gz::https://github.com/haiwen/seafile-client/archive/v4.4.2.tar.gz
- sha256sums = 86fbdfd2ac4de113aa4498802fbc663bc150ec4525f2ccf6b87d45af624f432a
+ source = seafile-client-v5.0.0.tar.gz::https://github.com/haiwen/seafile-client/archive/v5.0.0.tar.gz
+ sha256sums = 38a64c8bd0a32765ebccd4b32e9a12abd754b55a64bc18d32ddf75bbac142994
pkgname = seafile-client
diff --git a/PKGBUILD b/PKGBUILD
index c68fe2e8b2e4..5604703f140c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,26 @@
# Maintainer: Edvinas Valatka <edacval@gmail.com>
pkgname=seafile-client
-pkgver=4.4.2
-pkgrel=2
+pkgver=5.0.0
+pkgrel=1
pkgdesc="Seafile is an online file storage and collaboration tool. This is seafile client for synchronizing your local files with seafile server."
arch=('i686' 'x86_64')
url="https://github.com/haiwen/seafile-client/"
license=('Apache')
-depends=('seafile-shared>=4.4.2' 'qt4' 'qtwebkit')
+depends=('seafile-shared=5.0.2' 'qt4' 'qtwebkit')
makedepends=('cmake')
options=('!libtool' '!emptydirs')
install=seafile-client.install
source=("${pkgname}-v${pkgver}.tar.gz::https://github.com/haiwen/${pkgname}/archive/v${pkgver}.tar.gz")
-build ()
-{
- cd "$srcdir/${pkgname}-${pkgver}"
- cmake -DBUILD_SHIBBOLETH_SUPPORT=ON -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr .
- make
+build () {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ cmake -DBUILD_SHIBBOLETH_SUPPORT=ON -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr .
+ make
}
-package ()
-{
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}/" install
+package () {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
}
-sha256sums=('86fbdfd2ac4de113aa4498802fbc663bc150ec4525f2ccf6b87d45af624f432a')
+sha256sums=('38a64c8bd0a32765ebccd4b32e9a12abd754b55a64bc18d32ddf75bbac142994')