summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD31
-rw-r--r--seafile-client.install11
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..edd2428ba82f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = seafile-client
+ pkgdesc = Seafile is an online file storage and collaboration tool. This is seafile client for synchronizing your local files with seafile server.
+ pkgver = 4.2.4
+ pkgrel = 1
+ url = https://github.com/haiwen/seafile-client/
+ install = seafile-client.install
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = cmake
+ depends = seafile-shared>=4.2.4
+ depends = qt5-base
+ depends = qt5-webkit
+ depends = qt5-tools
+ options = !libtool
+ options = !emptydirs
+ source = https://github.com/haiwen/seafile-client/archive/v4.2.4.tar.gz
+ sha256sums = 49b8c7b2161a8a8fadbc2e2e36a80642d67ba8fd11b975a3f5f391d76de4c9af
+
+pkgname = seafile-client
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e66fed5a3674
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Moritz Maxeiner <moritz@ucworks.org>
+
+# Contributor: localizator <localizator@ukr.net>
+
+pkgname=seafile-client
+pkgver=4.2.4
+pkgrel=1
+pkgdesc="Seafile is an online file storage and collaboration tool. This is seafile client for synchronizing your local files with seafile server."
+arch=('i686' 'x86_64')
+url="https://github.com/haiwen/seafile-client/"
+license=('Apache')
+depends=('seafile-shared>=4.2.4' 'qt5-base' 'qt5-webkit' 'qt5-tools')
+makedepends=('cmake')
+optdepends=()
+options=('!libtool' '!emptydirs')
+install=seafile-client.install
+source=("https://github.com/haiwen/seafile-client/archive/v${pkgver}.tar.gz")
+
+build ()
+{
+ cd "$srcdir/seafile-client-${pkgver}"
+ cmake -DUSE_QT5=on -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package ()
+{
+ cd "${srcdir}/seafile-client-${pkgver}"
+ make DESTDIR="${pkgdir}/" install
+}
+sha256sums=('49b8c7b2161a8a8fadbc2e2e36a80642d67ba8fd11b975a3f5f391d76de4c9af')
diff --git a/seafile-client.install b/seafile-client.install
new file mode 100644
index 000000000000..1a05f573e594
--- /dev/null
+++ b/seafile-client.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}