summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD19
2 files changed, 19 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 124dbb435cfc..ee30aff4d9ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = seahub
pkgdesc = The web frontend for seafile server
- pkgver = 7.1.5
- pkgrel = 3
+ pkgver = 8.0.2
+ pkgrel = 1
url = https://github.com/haiwen/seahub
arch = any
license = Apache
- depends = seafile-server>=7.1.5
+ depends = seafile-server>=8.0.2
depends = python-future
depends = python-django-statici18n
depends = python-django-post-office
depends = python-django-webpack-loader
depends = gunicorn
- depends = python-pymysql
+ depends = python-mysqlclient
depends = python-openpyxl
depends = python-qrcode
depends = python-django-formtools
@@ -27,14 +27,14 @@ pkgbase = seahub
optdepends = python-django-pylibmc: Memcached support
optdepends = ffmpeg: For video thumbnails
options = !strip
- source = seahub-7.1.5-server.tar.gz::https://github.com/haiwen/seahub/archive/v7.1.5-server.tar.gz
- source = django-1.11.29.tar.gz::https://github.com/django/django/archive/1.11.29.tar.gz
+ source = seahub-8.0.2-server.tar.gz::https://github.com/haiwen/seahub/archive/v8.0.2-server.tar.gz
+ source = django-2.2.14.tar.gz::https://github.com/django/django/archive/2.2.14.tar.gz
source = django-picklefield-2.1.1.tar.gz::https://github.com/gintas/django-picklefield/archive/v2.1.1.tar.gz
source = django-rest-framework-3.11.1.tar.gz::https://github.com/encode/django-rest-framework/archive/3.11.1.tar.gz
source = seahub@.service
source = nginx.example.conf
- sha256sums = cc7f5a1642d203b2390ae3c30c8a5546d1e829d9d1a5ddf686e558292746ce5c
- sha256sums = 77a6b8c441bc060e42e7e147225ccac42191a5b96d57d03aefdb684c9ae4e09d
+ sha256sums = ad4f0358147859a5f0d6e4d078b7e53f6d619b83e8a52dc3e7adc69d73e982c5
+ sha256sums = 52590ea1a39713cb87cc1f93588867049a84d1985b215ed3884695bae01469ec
sha256sums = 5985205ec990ad1319e6d238616284b342f018d41a30dc089b76349fb17b15ae
sha256sums = 513c0da69619e76715a4ac9149d7715751b9c4820a29476cb143f2bb6b5a3d11
sha256sums = 67bb375871ce908b48bef53277284c9d8f80ee2e733efc89cb66d987647195e4
diff --git a/PKGBUILD b/PKGBUILD
index ba47905075ec..6568781182a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Aaron Lindsay <aaron@aclindsay.com>
pkgname=seahub
-pkgver=7.1.5
-pkgrel=3
+pkgver=8.0.2
+pkgrel=1
pkgdesc='The web frontend for seafile server'
arch=('any')
url='https://github.com/haiwen/seahub'
@@ -17,7 +17,7 @@ depends=(
'python-django-post-office'
'python-django-webpack-loader'
'gunicorn'
- 'python-pymysql'
+ 'python-mysqlclient'
'python-openpyxl'
'python-qrcode'
'python-django-formtools'
@@ -37,7 +37,7 @@ optdepends=(
)
# Outdated Python modules, but required by Seahub
_thirdpart=(
- 'django-1.11.29'
+ 'django-2.2.14'
'django-picklefield-2.1.1'
'django-rest-framework-3.11.1'
)
@@ -50,8 +50,8 @@ source=(
'nginx.example.conf'
)
sha256sums=(
- 'cc7f5a1642d203b2390ae3c30c8a5546d1e829d9d1a5ddf686e558292746ce5c'
- '77a6b8c441bc060e42e7e147225ccac42191a5b96d57d03aefdb684c9ae4e09d'
+ 'ad4f0358147859a5f0d6e4d078b7e53f6d619b83e8a52dc3e7adc69d73e982c5'
+ '52590ea1a39713cb87cc1f93588867049a84d1985b215ed3884695bae01469ec'
'5985205ec990ad1319e6d238616284b342f018d41a30dc089b76349fb17b15ae'
'513c0da69619e76715a4ac9149d7715751b9c4820a29476cb143f2bb6b5a3d11'
'67bb375871ce908b48bef53277284c9d8f80ee2e733efc89cb66d987647195e4'
@@ -91,11 +91,14 @@ package() {
cd "$srcdir/$thirdpart"
python setup.py install \
--root="$pkgdir/" \
- --install-lib="usr/share/seafile-server/$pkgname/thirdpart/" \
- --optimize=1
+ --install-lib="usr/share/seafile-server/$pkgname/thirdpart" \
+ --optimize=0
done
rm -rf "$pkgdir"/usr/{bin,share/seafile-server/"$pkgname"/thirdpart/*.egg-info}
+ python -m compileall -f -j 0 -o 1 \
+ -s "$pkgdir" -p '/' "$pkgdir/usr/share/seafile-server/seahub"
+
install -Dm644 \
"$srcdir/seahub@.service" \
"$pkgdir/usr/lib/systemd/system/seahub@.service"