summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6c92407c7658
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = sealcrypto-git
+ pkgdesc = Microsoft library for fully homomorphic encryption
+ pkgver = v4.1.1.r0.g206648d
+ pkgrel = 1
+ url = https://github.com/Microsoft/SEAL
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ conflicts = sealcrypto
+ source = sealcrypto-git::git+https://github.com/Microsoft/SEAL
+ sha256sums = SKIP
+
+pkgname = sealcrypto-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2555ea685da6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: phanium <$(echo bnhoc2R1QHFxLmNvbQo= | base64 -d)>
+pkgname=sealcrypto-git
+pkgver=v4.1.1.r0.g206648d
+pkgrel=1
+pkgdesc='Microsoft library for fully homomorphic encryption'
+arch=('x86_64')
+url="https://github.com/Microsoft/SEAL"
+license=('MIT')
+makedepends=('git' 'cmake')
+source=("${pkgname}::git+${url}")
+sha256sums=('SKIP')
+conflicts=("sealcrypto")
+
+pkgver() {
+ cd ${srcdir}/${pkgname}
+ git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd ${srcdir}
+ cmake -B build -S ${pkgname} \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ cmake --build build
+}
+
+package() {
+ install -m644 -D ${srcdir}/${pkgname}/LICENSE \
+ ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ DESTDIR="${pkgdir}" cmake --install build
+}