summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD17
-rw-r--r--gettid.patch13
3 files changed, 32 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2949dc94dd96..a438ca2a5e9c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = seamonkey-gtk2
pkgdesc = SeaMonkey internet suite (GTK2 version)
pkgver = 2.49.4
- pkgrel = 4
- url = http://www.seamonkey-project.org/
+ pkgrel = 5
+ url = https://www.seamonkey-project.org/
arch = x86_64
arch = i686
license = MPL
makedepends = unzip
makedepends = zip
- makedepends = pkg-config
makedepends = python2
makedepends = yasm
- makedepends = wireless_tools
makedepends = mesa
makedepends = autoconf2.13
makedepends = imake
@@ -37,17 +35,20 @@ pkgbase = seamonkey-gtk2
optdepends = gst-plugins-bad: aac, vp8 and opus decoding
optdepends = gst-plugins-good: webm and mp4 demuxing
optdepends = gst-plugins-ugly: h.264 decoding
- provides = seamonkey=2.49.4.4
+ optdepends = networkmanager: Location detection via available WiFi networks
+ provides = seamonkey=2.49.4.5
conflicts = seamonkey
source = https://archive.mozilla.org/pub/mozilla.org/seamonkey/releases/2.49.4/source/seamonkey-2.49.4.source.tar.xz
source = mozconfig
source = seamonkey-2.0-lang.patch
source = patch-bug1435212.xz
+ source = gettid.patch
source = no-crmf.diff
sha256sums = c8a66774d0a3525698b559fa2c41397186f2de99c5733e35b8eafb0ae5ccc4ee
sha256sums = 6ff9fd323eec175eb02cfefd3136c79491c3b40be0b1f899da7c75c2f76259ca
sha256sums = ab19d10fbd6258aec37ab5e5efb12429814b2c24a1193284a48dd654311b4e2e
sha256sums = dce68858694f820a9a1fc2428038a88ea00b4835cea0778734db794fea3bb21a
+ sha256sums = 923154d052f041af15a2495ceb1f76f7c8619fd8bfc66a0bbedfeab2514adf0b
sha256sums = fb85a538044c15471c12cf561d6aa74570f8de7b054a7063ef88ee1bdfc1ccbb
pkgname = seamonkey-gtk2
diff --git a/PKGBUILD b/PKGBUILD
index d853228aff5a..7efbe2afc91f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,28 +4,31 @@
pkgname=seamonkey-gtk2
_pkgname=seamonkey
pkgver=2.49.4
-pkgrel=4
+pkgrel=5
pkgdesc="SeaMonkey internet suite (GTK2 version)"
arch=('x86_64' 'i686')
license=('MPL')
depends=('alsa-lib' 'dbus-glib' 'desktop-file-utils' 'gtk2' 'hunspell' 'libevent' 'libnotify' 'libvpx' 'libxt' 'mime-types' 'mozilla-common' 'nss' 'sqlite' 'startup-notification' 'libpulse' 'icu')
provides=("$_pkgname=$pkgver.$pkgrel")
conflicts=("$_pkgname")
-makedepends=('unzip' 'zip' 'pkg-config' 'python2' 'yasm' 'wireless_tools' 'mesa' 'autoconf2.13' 'imake' 'python3' 'gst-plugins-base')
+makedepends=('unzip' 'zip' 'python2' 'yasm' 'mesa' 'autoconf2.13' 'imake' 'python3' 'gst-plugins-base')
optdepends=('gst-plugins-base: vorbis decoding, ogg demuxing'
'gst-plugins-bad: aac, vp8 and opus decoding'
'gst-plugins-good: webm and mp4 demuxing'
- 'gst-plugins-ugly: h.264 decoding')
-url="http://www.seamonkey-project.org/"
+ 'gst-plugins-ugly: h.264 decoding'
+ 'networkmanager: Location detection via available WiFi networks')
+url="https://www.seamonkey-project.org/"
source=("https://archive.mozilla.org/pub/mozilla.org/seamonkey/releases/$pkgver/source/seamonkey-$pkgver.source.tar.xz"
mozconfig
seamonkey-2.0-lang.patch
patch-bug1435212.xz
+ gettid.patch
no-crmf.diff)
sha256sums=('c8a66774d0a3525698b559fa2c41397186f2de99c5733e35b8eafb0ae5ccc4ee'
'6ff9fd323eec175eb02cfefd3136c79491c3b40be0b1f899da7c75c2f76259ca'
'ab19d10fbd6258aec37ab5e5efb12429814b2c24a1193284a48dd654311b4e2e'
'dce68858694f820a9a1fc2428038a88ea00b4835cea0778734db794fea3bb21a'
+ '923154d052f041af15a2495ceb1f76f7c8619fd8bfc66a0bbedfeab2514adf0b'
'fb85a538044c15471c12cf561d6aa74570f8de7b054a7063ef88ee1bdfc1ccbb')
prepare() {
@@ -41,6 +44,9 @@ prepare() {
# https://github.com/freebsd/freebsd-ports/blob/master/www/seamonkey/files/patch-bug1435212
patch -Np1 -d mozilla -i ../../patch-bug1435212
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1533969
+ patch -Np1 -i ../gettid.patch
+
# Don't exit with error when some libs are missing which we have in
# system.
sed -i '/^MOZ_PKG_FATAL_WARNINGS/s@= 1@= 0@' suite/installer/Makefile.in
@@ -72,6 +78,9 @@ build() {
CFLAGS+=" -fno-delete-null-pointer-checks -fno-lifetime-dse -fno-schedule-insns2"
CXXFLAGS+=" -fno-delete-null-pointer-checks -fno-lifetime-dse -fno-schedule-insns2"
+ # GCC 9
+ CXXFLAGS+=" -Wno-format-overflow"
+
make -j1 -f client.mk build
}
diff --git a/gettid.patch b/gettid.patch
new file mode 100644
index 000000000000..27a1b017e013
--- /dev/null
+++ b/gettid.patch
@@ -0,0 +1,13 @@
+--- seamonkey-2.49.4/mozilla/tools/profiler/core/platform.h.orig 2020-04-09 05:40:25.587372314 +0300
++++ seamonkey-2.49.4/mozilla/tools/profiler/core/platform.h 2020-04-09 05:41:24.195387788 +0300
+@@ -65,10 +65,6 @@
+ #include <unistd.h>
+ #if !defined(__BIONIC__)
+ #include <sys/syscall.h>
+-static inline pid_t gettid()
+-{
+- return (pid_t) syscall(SYS_gettid);
+-}
+ #endif
+ #endif
+